Libvirt problem

Hello,

I just installed TW today and i’m having some problems getting virt-manager to connect with libvirtd. I installed the kvm virtualization during setup.
Getting the following errors when i check the status of libvirtd:

● libvirtd.service - Virtualization daemon
     Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; disabled; vendor preset: disabled)
     Active: active (running) since Sat 2020-09-19 21:18:42 CEST; 1s ago
TriggeredBy: ● libvirtd.socket
             ● libvirtd-admin.socket
             ● libvirtd-ro.socket
       Docs: man:libvirtd(8)
             https://libvirt.org
   Main PID: 29907 (libvirtd)
      Tasks: 19 (limit: 32768)
     Memory: 26.4M
     CGroup: /system.slice/libvirtd.service
             ├─21521 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/lib64/libvirt/libvirt_leaseshelper
             ├─21522 /usr/sbin/dnsmasq --conf-file=/var/lib/libvirt/dnsmasq/default.conf --leasefile-ro --dhcp-script=/usr/lib64/libvirt/libvirt_leaseshelper
             └─29907 /usr/sbin/libvirtd --timeout 120

sep 19 21:18:41 xx systemd[1]: Starting Virtualization daemon...
sep 19 21:18:42 xx libvirtd[29907]: libvirt version: 6.7.0
sep 19 21:18:42 xx libvirtd[29907]: hostname: xx
sep 19 21:18:42 xx libvirtd[29907]: Failed to initialize libnetcontrol.  Management of interface devices is disabled  <--- this has me concerned, tried reinstalling this as well.
sep 19 21:18:42 xx systemd[1]: Started Virtualization daemon.
sep 19 21:18:42 xx dnsmasq[21521]: read /etc/hosts - 7 addresses
sep 19 21:18:42 xx dnsmasq[21521]: read /var/lib/libvirt/dnsmasq/default.addnhosts - 0 addresses
sep 19 21:18:42 xx dnsmasq-dhcp[21521]: read /var/lib/libvirt/dnsmasq/default.hostsfile

Also when starting virt-manager i get the following:

The libvirtd service does not appear to be installed. Install and run the libvirtd service to manage virtualization on this host.

A virtualization connection can be manually added via File->Add Connection

I’ve tried removing everything and then installing through yast’s virtualization option> kvm and kvm-tools.

Nothing seems to work, a couple of weeks ago on this same machine it all worked and other distro’s work fine right now.

I did do some googling but so far have not come up with a solution other than reinstalling and enabling virtualization after install is complete.

Please advise, thanks!

What output do you get from

systemctl status libvirtd

(run that as root).

Running “ssytemctl status libvirtd” will likely only display what has already been posted.

The attempt to install virtualization during initial install was a mistake.

Recommend…
Re-installation, especially if this is a brand new install. Troubleshooting and an attempted has problematic chances for success.
If your mistake was made after initial installation I would have recommended a btrfs rollbaback instead to before your mistake.

Then, install virtualization using the YaST module as you’ve attempted, accepting recommendations.

TSU

Well just did a reinstall using default settings. And the exact same thing happens, first boot i only enabled kvm and kvm tools, it did it’s thing and the service is showing it again.

So i’m at a loss… I’m new to Opensuse so not sure where to go from here.

Verify your SOP for installing is follows…

Install using either the DVD or NET install source media freshly downloaded from https://software.opensuse.org. If you use an outdated TW download, the install should attempt to download latest install source, but this doesn’t always work for me.

After a fresh install, it’s always critical to update/upgrade your system to make sure it’s latest. If a LEAP install, run “zypper up” but when running a TW, open an elevated console and run

zypper dup

Open YaST and look for the Virtualization module. Use it to install your choice (s) of KVM, Xen or LXC.
Accept recommended options so they’re available if you want to use them.

If you still have a problem, then there may be a problem in the latest TW image.

This is probably a good opportunity to review choosing TW or LEAP as your base install when you intend to also install virtualization of any type.
If you value reliability and stability, in particular for Production level use, you should choose LEAP.
If you either need the latest leading and bleeding edge technologies or are more a hobbyist who can tolerate a few days’ downtime when there are problems, Tumbleweed can be your choice. Tumbleweed problems will occur more often than on LEAP but rarely last too long because of the attention to everything reported.

If you still see a problem, then the problem may be brand new and only since the current, latest TW release which could be days old.
Should you need to submit a bug to https://butgzilla.opensuse.org, be sure to include

  • The TW version which can be returned by
cat /etc/os-release
  • Describe whether you’re still using the default Network Manager or changed to Wicked to manage your netowrking (You can see if switching to Wicked makes a difference but I’m sure the maintainers would want to know if there is a problem using Network Manager, too)

TSU

Did you enable virtualization in the bios? Every motherboard I have owned defaults to off/disabled.

http://bugzilla.opensuse.org/show_bug.cgi?id=961532

Do you use Networkmanager?

Can you enable libvirtd and restart?

libvirtd.service - Virtualization daemon
Loaded: loaded (/usr/lib/systemd/system/libvirtd.service; disabled; vendor preset: disabled)

I followed these steps the second time, used a DVD image and did not allow use of an updated mirror during install. My reasoning for going TW was i need an up to date plasma, after literally years a graphic corruption bug got fixed with 5.19 using amdgpu. I figured rolling with snapshots to back me up sounds like a good plan. I like up to date goodies but dealing with Arch or Gentoo became tiring and TW feels just as snappy in use as a fully riced Gentoo install with LTO. So why bother then? Sure TW boots slower but i boot once a day generally.

Back to the problem i had. Yeah it’s fixed and i’ll detail the steps for future reference.
Last night when it didn’t work i didn’t try anything else after installing kvm and tools through yast. But what i did was go to software and search for libvirt, i saw several things enabled but not “libvirt”, so i enabled that and it pulled in some other stuff. Brought up the bridge with virsh, rebooted and the message is gone from the status of the libvirtd service. Can connect to libvirt with virtmanager and it all works now.

Anyway i probably would’ve wanted a reinstall anyway, when reinstalling i noticed i could not transfer over the home drive from the previous install that was formatted as btrfs. Probably because it merged it with the root drive. I like home to be separate not striped in some way with root.

Yes, Fedora on another drive worked fine.

Yes i use NM because of vpn’s, but it’s all good now thanks.

Glad you were able to fix the problem, but shouldn’t have been necessary.
If you can submit a but to https://bugzilla.opensuse.org, the problem can be fixed so others won’t see the same problem. You can reference this Forum thread.

Also, FYI openSUSE is flexible so that for example if you want the stability of LEAP except for a very specific need like latest KDE, you can install LEAP and add various KDE repos to provide latest of those subsystems

https://en.opensuse.org/SDB:KDE_repositories

TSU