libstdc++ missing

From where can I get libstdc++ to install it? I’m running OpenSUSE 12.3 64.

libstdc++6

Thanks, it has been already there. Unfortunately AMD’s CodeXL 1.2 still seems to ‘think’ I don’t have it.

This package is from where?

http://developer.amd.com/download/AMD_CodeXL_Linux-1.2.2484-0.x86_64.rpm

And this is for what exactly?

If you really need it, you could ask someone with an OBS account to build it against 12.3
@malcolmlewis might accommodate you

Here you go: CodeXL | AMD

On 08/20/2013 06:46 AM, robirobi wrote:
>
> caf4926;2580340 Wrote:
>> libstdc++6 Thanks, it has been already there. Unfortunately AMD’s CodeXL 1.2
> still seems to ‘think’ I don’t have it.

maybe you tried this already, but didn’t mention it: if the new was
installed since your last boot, the system may need to run ldconfig
to rescan the libraries in its rather giant ‘hash table’ (which lets
linux link libraries faster)…so, after installing, or doing
anything which changes/add/removes a library run


su -
ldconfig

hth

dd
http://tinyurl.com/DD-Caveat
http://tinyurl.com/DD-Complaints

On Tue 20 Aug 2013 05:16:04 AM CDT, robirobi wrote:

caf4926;2580352 Wrote:
> And this is for what exactly? Here you go: ‘CodeXL |
> AMD’ (http://tinyurl.com/ljvuemv)

Hi
I downloaded the x86_64 bit tar.gz version, extracted it then changed to
the extracted directory and ran CodeXL, once installed libpng12-0 it was
complaining about it started fine, no looking for any thing else…


Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 12.3 (x86_64) Kernel 3.7.10-1.16-desktop
up 1 day 6:26, 4 users, load average: 0.66, 0.31, 0.20
CPU AMD E2-1800@1.70GHz | GPU Radeon HD 7340

On 2013-08-20 06:06, caf4926 wrote:
>
> libstdc++6
>
>

Do you have this installed?

libstdc+±devel - The system GNU C++ development files


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

I have libstdc++47-devel installed on my system.

On 2013-08-20 15:26, robirobi wrote:
>
> robin_listas;2580414 Wrote:
>> On 2013-08-20 06:06, caf4926 wrote: > > libstdc++6 > > Do you have this
>> installed? libstdc+±devel - The system GNU C++ development files –
>> Cheers / Saludos, Carlos E. R. (from 12.3 x86_64 “Dartmouth” at
>> Telcontar) I have libstdc++47-devel installed on my system.

But not libstdc+±devel-4.7-7.1.1.x86_64


Cheers / Saludos,

Carlos E. R.
(from 12.3 x86_64 “Dartmouth” at Telcontar)

Hi
CodeXL runs fine without this installed, I only have the following installed;


zypper se -i libstd

S | Name             | Summary                         | Type   
--+------------------+---------------------------------+--------
i | libstdc++6       | The standard C++ shared library | package
i | libstdc++6-32bit | The standard C++ shared library | package

Exactly. :slight_smile:

I installed the package while skipping the warning as well and I’ll see you well it goes beyond launching the application. :wink: