libsdl problem in Quake4

hi. loving suse at the moment! :):slight_smile:

just i love to play quake on linux and when i try to run quake4 i get this error!

/quake4.x86: error while loading shared libraries: libSDL-1.2.so.0: cannot open shared object file: No such file or directory

there is another file i can run called quake4-smp but that returns the error…

Fatal Error: Unable to initialize OpenGL

But i know i have my nvidia drivers installed properly! :\

i think i have my drivers installed correctly :confused:

On Sun, 24 Aug 2008 21:46:01 GMT
mikehmike <mikehmike@no-mx.forums.opensuse.org> wrote:

>
> hi. loving suse at the moment! :):slight_smile:
>
> just i love to play quake on linux and when i try to run quake4 i get
> this error!
>
>
> Code:
> --------------------
> /quake4.x86: error while loading shared libraries: libSDL-1.2.so.0:
> cannot open shared object file: No such file or directory
> --------------------
>
>
>
> there is another file i can run called quake4-smp but that returns the
> error…
>
>
> Code:
> --------------------
> Fatal Error: Unable to initialize OpenGL
> --------------------
>
>
> But i know i have my nvidia drivers installed properly! :
>
>

Probably need to install the SDL package, it contains the library you’re
needing.

Loni

–
L R Nix
lornix@lornix.com

ok well im looking for an SDL package now but i can’t get transparent windows in my Kernal or xchat… it says my window system doesn’t support them :expressionless:

well… after days of “googling” lols!

ive edited my xorg.conf so that the default color depth is 24 not 16. now it works :slight_smile:

but the performance is aweful! :’( it says its at like 63fps which my installation of vista runs it at BUT it feels really really choppy! :frowning:

Have you enabled KDE desktop effects or Compiz? Those can really slow down performance depending on what card you have.