LibreOffice Writer make logout suddenly

Hi

In a fresh installed of Leap 42.3 when I use Writer I encountered a critical problem, after some while Libreoffice freeze for a second and then make the system logout! I lose my work twice time.
I have the same problem in TW too (installed in other partition).

How I can figure out the problem and solve it?

Which Desktop?

  • GNOME or KDE or something else?

Which system language and, which user language?

Have you installed any extra fonts particular to your native language?

thanks for your reply:

My desktop is KDE with English UI
I have extra (Arabic) fonts in ~/.fonts but don’t use them in system UI (I even use LO Writer to deal with English articles).
BTW, VGA: Inetl HD Graphic 520 Skylake

Please make sure that, there aren’t any issues with the font caches:

  • With the CLI of the user “root” rebuild the system-wide font caches and the personal font caches of the user “root”:

fonts-config -f -v

fc-cache -f -v

Take care to notice any warnings about missing font cache directories – create the directories which caused the warnings and re-execute the command.

  • With the CLI of the user with the LibreOffice issue (crash), rebuild that user’s personal font caches:

> fc-cache -f -v
Take care to notice any warnings about missing font cache directories – create the directories which caused the warnings and re-execute the command.

Does this issue also occur with documents using no Arabic characters and/or fonts?

Given the Arabic font sets included with openSUSE, you may have to disable some or even all of them if, there’s a conflict between those fonts and the ones you have installed in your ~/.fonts directory.
You will need to produce a ‘/etc/fonts/local.conf’ file with a content like this:


<?xml version="1.0"?>
<!DOCTYPE fontconfig SYSTEM "fonts.dtd">
<!-- /etc/fonts/local.conf file for local customizations -->
<fontconfig>

  <rejectfont>
    <pattern>
      <patelt name="family" >
        <string>Arabic Newspaper</string>
      </patelt>
    </pattern>
  </rejectfont>

<!--
  <rejectfont>
    <pattern>
      <patelt name="family" >
        <string></string>
      </patelt>
    </pattern>
  </rejectfont>
-->

</fontconfig>

The font’s “family” can be determined by examining the font file either with “fc-query” or “fc-scan”.

Thanks for your reply

I executed the two commands (for rebuild system font cache), the first one:

#fonts-config -f -v

shows me warning about Japanese, Simplified Chinese, Traditional Chinese and Korean! because it cannot find fonts for those languages.
but there isn’t any warning about missing font cache “directories”. the second one:

#fc-cache -f -v

shows me warning about some missing directories, I create them, re-execute the command and it was succeeded without any warning
(the same thing with the third command).

I also edited my ‘/etc/fonts/local.conf’ as you mention.

I’ll use Libreoffice for the next couple of days and tell you if it’s make my system logout again.

thanks again.

It crushed again :confused: what we can do?

thanks :slight_smile:

Unfortunately, it may be that, the personal Arabic fonts located in ~/.fonts/ are influencing this issue.

It may be that, the personal fonts in ~/.fonts/ will have to moved away to another home directory, the Arabic fonts disabled in ‘/etc/fonts/local.conf’ will have to be re-enabled and, the font caches refreshed.

And then, try again.

I renamed ~/.fonts to ~/old-fonts and return the ‘/etc/fonts/local.conf’ as it was formerly. Today I used writer and the system was crashed after five minutes or so :confused:
so I don’t think the problem causes by fonts. What do you think?

does the file /root/var/crash report anything?
another thing you may want to try is launching Libreoffice from the terminal and see if there are any errors reported.

lowriter

I can’t find /root/var/crash file?
Actually the system freeze for one minutes before it logout so I can’t read the output of terminal at that moment but I’ll try

thanks for you.

How long is “some while”? Is it random?

Does it coincide with the time set for Libre Office’s “Save auto-recovery information every…” ?
If so, check the AutoBackup path (Options -> Libre Office -> Paths) points to a valid directory, which is writeable, and has free space.

I have the same problem in TW too (installed in other partition).

I suspect your problem may be deeper than Libre Office itself, but a few more things to try:

If you’re using Intel graphics try disabling “Use Anti-aliasing” (Options -> Libre Office -> View)
If you’re using Nvidia try disabling “Use Anti-aliasing”, “Use Hardware acceleration”, and “Use open GL for all rendering”
Normally those just result in screen corruption, but I’ve seen a few (old) bug reports that indicate it can cause LO to crash.

Does it still happen if you start Libre Office in “Safe Mode” (Help -> Restart in Safe Mode)
If no, then you likely have a corrupted user profile, more information here: LibreOffice user profile - The Document Foundation Wiki

Knowing whether it core dumps when crashing probably won’t help you much, unless you want to go down the gdb route.
However, after a crash you could try “coredumpctl list” or “coredumpctl info” from a terminal, (or use konsole).

Create a new Test User (YaST -> User and Group Management) - Log in as that user and see if the problem persists.