LibreOffice Writer freezes with 100% CPU utilisation

Hi everyone,

I’m a new convert to Linux/Opensuse so I’m hoping someone can point to a solution to the following problem.

LibreOffice Writer freezes about 30 secs after opening and browsing a large 8MB .odt file (Andrew Pitonyak’s guide to OO Macros & Basic), shortly followed by everything else on the desktop. This happens consistently(!) even if macros and java are disabled, and is a real barrier to my conversion from W****ws.- reading Andrew’s wisdom in 30 sec snapshots is impossible.

Gnome System Monitor shows 100% cpu utilisation with soffice.bin using 85-100% - ie whatever is left from background processes. soffice bin RAM usage is steady at around 150MB.

I have no such problem with much smaller files in Writer or Calc, or with any other application. This document s widely distributed so I don’t think it can be a problem with the document itself (which I have downloaded twice in case of bad download).

I am running LibreOffice 3.3.1 over OpenSuse 11.4 64-bit with Gnome 2.32.1 and nvidia graphics driver on an Athlon 3200+ 1.5GB RAM with Geforce 7300GS graphics. Opensuse 11.4 64-bit was downloaded from openSUSE website about 3 weeks ago; LibreOffice and other applications were installed with YaST.

Any thoughts or suggestions welcome. Thanks in advance.

The doc you are trying to read contains a warning that if you open it in a version of writer less than 3.4 then OO will crash when the doc is closed. This may be related to your experience. The doc says it is related to a bug involving many style changes in one document.

I have OO versions 3.3.1 and 3.4.2 on my machine. Indeed that doc does load on my computer and crashes OO 3.3.1 on close, but it does stay alive for longer than 30 sec. On OO 3.4.2 it loads and closes properly.

So the issue is either your version of OO, or perhaps your physical hardware is a bit underpowered? Just a couple of things to consider.

On 10/13/2011 04:46 PM, branestawm2 wrote:
> Any thoughts or suggestions welcome.

tell us more about that file…i ask because i just googled “Andrew
Pitonyak’s guide to OO Macros & Basic” found and then a link named
Macro document (updated March 31, 2011 12:28:46 AM EDT) which downs a
file named AndrewMacro.odt and it is less than 1MB

so, please gimme the exact address of what is causing your

the most CPU use i could get with this smaller doc was 77%, and that
required mouse in the scroll bar and hold down the left click to send
continuous scroll input…

btw, i note that everything about OO works faster and smoother if the
file is marked read only prior to opening (that way it doesn’t have to
continually be ready for your edit inputs, i guess)

openSUSE®, the “German Automobiles” of operating systems

DenverD, The file is OOME_3_0.odt and I downloaded it from

I’ll try loading it read-only in a couple of hours when I’ve cleared my desktop and am prepared for trouble …

Thanks for your interest and for the suggestion.


Ah, I never got to read it long enough to see the warning >:(

Yes, my h/w (Athlon 3200+, GF7300GS graphics, SATA 1 disk) is a tad underpowered by today’s standards - for W****ws perhaps, but surely adequate for Linux?

If v3.3.4 is a cure, am I stuck between a rock and hard place? I understood that 3.3.4 isn’t approved for opensuse 11.4 and won’t be available in YaST until 12.1 for stability reasons. But you have it, so am I wrong? Is 3.3.4 stable on 11.4? And 3.4?

Thanks for your helpful thought.

I tried to open the document with OfficeLibre 3.3.1 and I don’t have any issue. It seems that you need a bit more power for some applications(just got it upgraded from 500MB to 4GB). Scrolling I got to around 45% memory utilization(200MB memory), but that’s all. Good luck!

Tried opening OOME_3_0.odt in read-only mode, but it makes no difference, still freezes at 100% cpu.

RAM allocation/leakage doesn’t seem to be an issue, total RAM usage appears to be steady at 40% (of 1.5GB).

I’m surprised that an Athlon 3200+ doesn’t have the “grunt” for an OO wp document, even a large one …

Just to be clear, I am using LibreOffice 3.4.2 on 11.4 Opensuse. Works fine for my purposes, but then I am not a super heavy user of the finer attributes of the programme.

If you do a search at Download openSUSE 11.4 for “libreoffice” there appears to be a stable release of 3.4.2 there for 11.4. This would seem to indicate that the package is approved for 11.4?

Thanks for the pointer to libreoffice 3.4.2 - I’ll try it and see if it goes better on my system. I’ve also found instabilities with DDE links in in Calc, so a maintenace upgrade would seem a good idea - no one here has leapt in with caveats!

Thanks for your help.