Libreoffice slow

System is LEAP 42.1 with updates.
All, is your LIbreoffice working as per normal? or lets say, at a normal speed. I found Libreoffice Draw to be dog slow at the moment. I am currently using 5.0.4. having down graded because of this problem. Unfortunately this made no difference. I also attempted to install 5.2 beta from FACTORY but ran into dependency problems. When I open the application it goes through a slow process of loading the menus and setting up its screen or window. System is an i7 processor and 16gig of ram. Any ideas what may be happening? Libreoffice Writer might be working a bit faster, but it to suffers from a similar problem.

In the LibreOffice settings under “LibreOffice/Advanced” check that you’ve selected a Java Runtime Environment (JRE).

  • Yes, if you do not explicitly do this, LibreOffice is not as fast as it should be . . .

Tried this but it did not have the effect I was hoping for. The “Advanced” tab showed - - use java runtime environment. Beneath this were two versions both 1.7 and 1.8 by Oracle Corporation. Tried both - - required a restart - - but did not speed things up much.
Still going on this one.

LibreOffice is currently sensitive to the memory usage configuration values:
[li]In the LibreOffice settings under “LibreOffice/Memory” increase the default values to large values.[/li][/ul]
[HR][/HR]On my current systems with 8 GB memory, I use the following values with the LibreOffice versions available from the 13.2 and Leap 42.1 update repositories:

[li]Number of “undo” steps: 100 (possibly the default value).[/li][li]Memory used for graphics:[/li][LIST]
[li]LibreOffice: 512 MB (not the default value);[/li][li]Memory per object: 4.0 MB (possibly not the default but not really sure);[/li][li]Remove from memory after: 10 minutes (possibly the default value).[/li][/ul]

[li]Memory for inserted objects: number of objects: 128 (not the default value).[/li][/LIST]
[HR][/HR]Maybe I should have mentioned the following rules in my 1st post:

[li]LibreOffice on Linux systems demands that the JRE be explicitly set.[/li][li]The default memory usage values of LibreOffice on Linux systems are way too small for “normal” modern desktops and laptops (> 2 GB main memory).[/li][/ul]

I’m also having performance issues with LibreOffice 5.2. Adding memory hasn’t helped and JRE 1.8 is turned on. I posted a question on the LibreOffice forums so maybe I’ll learn something. There’s also two folders in ~/.config/libreoffice named 4 and 4-suse. I moved both of them out of that directory but 4 is recreated every time LO is started. Currently 4 is the only one in that directory but that hasn’t made a difference.

LibreOffice 5.1.3 is way faster than 5.0.4 here on Leap 42.1 with default memory settings (AFAIK, never touched that) on a 16 GB i7 4720 laptop.

Graphics Cache:
LibreOffice: 20 MB;
Memory per object: 5.2 MB;
Remove from memory after: 10 minutes.

Memory for inserted objects: number of objects: 20.

Number of “undo” steps: 100 (but it is in the “Expert Configuration” now).

Oracle Corporation jre1.8.0_91

So the problem might not be as simple as that.

Thanks – makes a big difference