Libreoffice save crash

I started getting problems with the latest beta of Libreoffice, so I reverted to the stable version - 4.2.11. However, problems persisted, especially crashing out of the program when trying to save a file. So I completely removed libreoffice, the profile and searched for any file with libreoffice in it - they were all over the place - and did a fresh install from the LO source. Still getting the same crash. Start from terminal and get:

(soffice:3588): GConf-WARNING **: Client failed to connect to the D-BUS daemon:Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
GConf warning: failure listing pairs in `/desktop/gnome/interface': No D-BUS daemon running

Program starts but on crash shows:

Error creating proxy: The connection is closed (g-io-error-quark, 18)

Using Linux 3.13.5-18.gbb654e2-desktopopenSUSE 13.1 (Bottle) (x86_64)
KDE 4.12.3

Any help gratefully received

John F.

There was a problem with the KDE branding stuff and dbus errors.

Many thanks for that. I removed the Gnome branding file, and noticed that the KDE branding files had already been deleted in the latest attempt to clean things up. LO now works, albeit with a pretty horrible interface, but I’m sure I can deal with that!

Best wishes

John F.

LibreOffice have found the problem. It is the GTK-Oxygen theme which is crashing the program. Changing it to another theme solved the issue.

Should I report this as a bug, if so where?

John F.

An update to the GTK-Oxygen theme is already underway, should be out some time next week.
I think you should wait for that and then report a bug if it still crashes.

You could report a bug here:
http://bugzilla.novell.com/ (same username/password as in the forum)

Or (maybe better) directly upstream at KDE here:
http://bugs.kde.org/

OTOH, you could install libreoffice-kde4 (and uninstall ibus if installed, as that effectively blocks the KDE4 integration), then the KDE theme should be used which should work fine now. (I actually pushed fixes for two crash/freeze bugs in libreoffice-kde4 to the January libreoffice update, see also http://forums.opensuse.org/showthread.php/492096-libreoffice-4-1-3-2-calc-freeze-drag-drop-cell:wink: )

OK, thanks for that!

John F.

For info, I’ve changed from ibus to libreoffice-kde4 but the oxygen theme still crashes 4.2.

John F.

I can only speak of 4.1. I don’t have 4.2 installed. But those fixes I mentioned should be part of 4.2 as well.
Could you run it in a terminal window and post the error message you get when it crashes?

Although I had installed it as a test for a short while, and it didn’t crash with the KDE4 oxygen them. But I don’t think I tried to save.
Can you try to enable “Use LibreOffice dialogs” in the settings (LibreOffice->General)?

I may try to upgrade to LO 4.2 later and see if I can reproduce this.

I installed LO 4.2.2.1 now from the LibreOffice:Factory repo, and can reproduce the crash with libreoffice-gnome and the Gtk-Oxygen theme.

But with libreoffice-kde4 (and the KDE Oxygen theme) it does not crash here.
Maybe you installed the wrong package? OpenSUSE’s libreoffice-kde4 package won’t work with the LO version from their homepage, if that’s what you installed.

Maybe try the version from the LibreOffice:Factory repo:
http://software.opensuse.org/download.html?project=LibreOffice%3AFactory&package=libreoffice

I’m not sure whether the packages from the LibreOffice homepage include the KDE4 integration.

Thanks for your help.

I think I have the right versions now, I was trying 4.2.3 which complicated things…:stuck_out_tongue:

Anyway, running 4.2.2 from the LO homepage and using libreoffice-kde4 from factory still causes the crash on opening a dialogue. Using the Libreoffice dialogues works OK.

The exit code is as above without the DBus stuff of course as ibus has been removed: i.e. Error creating proxy: The connection is closed (g-io-error-quark, 18)

So the workround seems OK to me, just use the LO dialogues.

Best wishes

John F.

Again, openSUSE’s libreoffice-kde4 won’t work with LibreOffice from the LO homepage.
Install the complete LibreOffice from the LibreOffice:Factory repo and the KDE4 integration should work (and not crash with the oxygen theme).

Apparently you were STILL using the GNOME integration, which indeed seems to have a problem with Gtk-Oxygen.

FYI: That crash with Gtk-Oxygen apparently has been fixed already: https://bugs.kde.org/show_bug.cgi?id=331879

The fix is already part of the packages in KDE:Extra and will be released as online update for 13.1 as well soon I hope.

Libreoffice 4.1.5.3 was crashing on save with opensuse 13.1 for me. I uninstalled ibus and after a reboot, things seemed to be back to normal. ibus seemed to show up after a recent update.

Everything is working as it was before after a recent update. So I have unchecked the LibreOffice dialogs.

An official update for 13.1 has been released today which fixes this crash.

I have found a workaround for the same problem with crashing after trying to save document.

  1. Run libreoffice as root user
  2. Try to create/save some document
  3. Copy (as root) the
    cp /root/.kde4/share/config/LibreOfficerc /home/PASTE_YOUR_USER_NAME_HERE/.kde4/share/config/LibreOfficerc
  4. Change the owner
    chown PASTE_YOUR_USER_NAME_HERE:users /home/PASTE_YOUR_USER_NAME_HERE/.kde4/share/config/LibreOfficerc
  5. Run libreoffice app as your user

PS
how to know your user name
run command:
id

OppenSuSe 13.1 x64 kde4

???

This should NOT be necessary at all.
First it should not crash any more.
Second, you can just delete ~/.kde4/share/config/LibreOfficerc, it only contains the settings for the KDE file dialog and LO will work fine without it. You don’t have to create it by running LibreOffice as a different user (or even root).
Third, with the GNOME integration (which is what this thread is about, it crashed with the Gtk2-Oxygen theme), this file is not even used. LO shows the Gtk file dialog then. So your workaround won’t work.