LibreOffice no longer does umlauts after 15.5 upgrade, but other apps do

Since the upgrade to opensuse leap 15.5 (I believe) I am no longer able to do umlauts in libreoffice ("+ o generating ö for example, also works here). This is a real obstacle for me when writing in German or Swedish on my French keyboard.

There are lots of tips on the ComposeKey etc in other fora, but I find them unhelpful because this used to work “just like that”, without any special keys, previously. I also know how to pick umlauts and other special characters from “insert special character”, but that is just not practical for normal typing.

I am using LO as supplied by the opensuse repository. I also tried to install manually LO 7.5, but this particular malfunction was not affected by that upgrade. The bug also seems to be unaffected by whether I use X11 or wayland.

It would be great if someone had an idea how to get this back.

1 Like

This is not something I know. I just tried on openSUSE Leap 15.4, in KDE, LibreOffice Writer, but +o gives me “+o”. Using my compose key (as I do for years in all my applications), I get normally “ö”.

So you used some feature that is not general for all and you might have set that sometime long ago.

Thanks, I understand the thought that I “might have set sometime long ago” - but I do not believe this is the case, I usually don’t tinker with such things…

Note that, in my example, I indicated that I first hit the ¨-key and then the o-key and this gives me, without any further keys ö.

I am rather surprised that this works in all other applications (as well as in this window), so why does it no longer do so in LO?

Perhaps I need to learn how to use the ComposeKey, but frankly, my attempts so far have been unsuccessful. Do I need to first activate this as a functionality, or should it work by default?

What desktop environment are you using (GNOME, KDE, anything else)? What keyboard layout is configured? What are “all other applications” (name some)? What is “this window”?

Thanks, and sorry for not having been very clear.

I am on KDE wayland (as default in leap 15.5). The keyboard is French (also default). Another application where this works is thunderbird (now 115, but earlier ones as well). And “this window” is where I am typing this message in my firefox 116 browser, with no special tricks installed regarding those keys.

Sorry, I did misunderstand that, I saw +o and thought that was is. I started LO Writer again and first hit the " and then the o. The result


So again, this combination that you probably thought to be a normal combination world wide, isn’t. It looks as if some feature with so called “dead keys” was working at yours.

And yes, when you have a typing habit in your fingers, it will be hard to change to another way of doing it.

About the Compose Key.
I said already I work with KDE. You apparently did not get the hint from this that you did not explain what you use. Nevertheless I will explain how I configured it on KDE (I did so short time ago on the German part of these forums).
Mine is in Dutch, thus back-translating the menu items, etc. in English might not give exactly what you see, but I guess you will understand.
KDE System Settings > Hardware > Input Devices > Keyboard, then the Tab Advanced. Check Configure keyboard options. Go down to Posiotion of Compose keyand open de black triangle. Now you can choose one of the keys there to use as Compose key. I use Right Ctrl (and it is now used by my fingers without thinking). The grey rectangle Psotion of Compose key will now turn grey to show you have changed there. Close everything.
Might be working directly. It could be that you have to log-out and log-in.

For me e.g. Compose " o gives ö (as you would expect, but there are many more. Most rather logical and e.g. = e and e = both give € to make it easy.

é è ë ê ē ẽ and so on.

1 Like

If you try to search for “linux libreoffice dead keys do not work” you get quite some hits. One of them is

[SOLVED] Dead Keys don’t work on Libreoffice when using plasma Desktop / Newbie Corner / Arch Linux Forums

It is old, but may give some ideas where to look.

Thanks for explaining. I must say that I tried that, in my desperation yesterday, and it did not work. Will have to try again step by step. Do I have to completely reboot after having assigned the ComposeKey?

I believe I even did that and it just did not work. Will try again nevertheless. Would have been nice if it just continued to work as It does in thunderbird and firefox, that would definitely have been the most logical for me.

well there is no place on my system with a file called, so I can’t see how that old thread would be applied - although it sounds like a good pointer.

There is nobody here who might know how libreoffice can be tweaked to understand my keyboard sequences in the same way as those other apps do?

Brilliant what you can learn from readings this forum. Like solving a problem I didn’t know I had!
Thank you guys

I do write in German, Englisch, Chinese, French and Russian.

You do have a keyboard swtich, that sets the layout to the corresponding language.

I know where the keys are supposed to be and I just type directly. Way faster then using the shortcuts.
and usually you don’t mix languages to much.

with fcitx x11 or ibus on wayland very easy.

Could this be Wayland connected (I run X11)?

But hey, when you find the setting as I described above, it should work IMHO regardless of that.

I think the OP is using a French AZERTY-keyboard. The button he is talking about is on a French keyboard right next to the P. So, for him to construct an ö, ä, or ü he just presses this button followed by o, a or u.

@wcr are any other keys shiftet in libre office? Like the A or Q?

In KDE System settings>Input devices>Keyboard>Layouts I have several different keyboard settings installed; I change them by clicking on an icon in the System tray.

The last time I checked, there was no Umlaut in the French keyboard but it was to the right of P in the German keyboard. So, if I need a key that is not available in the keyboard I am using, I switch to the one where it is available and switch back. That is helpful if you are familiar with each layout but I have always kept cheatsheets for each layout in case I forget.

BTW Insert>Special character in LibreOffice shows the Umlaut if you just want a single character.

I think you are on the right track, this might be a feature associated with a French keyboard in particular. As far as I can tell, all keys work as they are supposed to do - it is just this capacity of the ¨-key to produce umlauts which somehow gets suppressed by libreoffice.

There has to be a way to just get that back, I would think…

Yes, thank you all of you who are pointing me to the Insert Special Character option, this is what I now use, but it basically kills any kind of fluid typing.

(Source of the picture: AZERTY - Wikipedia)

Just to clarify for everyone else as well, it’s this keyboard layout and we are talking about the key in red, next to the P!? And this is a sticky key, so you press it, release it then press the letter (u, o, a) to get ü, ö and ä, right?

I found this old post: Dead keys won't work - #7 by petermau - English - Ask LibreOffice

It seems to be a on and off problem with libre office.

Did you already try to delete and reinstall it?

1 Like

You cannot fix any problem without identifying the root cause of it. As long as nobody else can reproduce it (I do not have Leap 15.5 with KDE, but I cannot reproduce it on Leap 15.5 with Xfce using any LO backend nor on Tumbleweed with KDE again trying all LO backends) it is up to you to find conditions that cause it to happen. Does it happen when you boot Live image? Does it happen for a new user using clean environment? Did you try different LO backend? Did you try different keyboard layout (like US international with dead keys)?

The French Wikipedia has this more detailed version: Disposition AZERTY sous Linux, dite « français variante »:

I was playing around with French keyboard layouts. I am on Tumbleweed Gnome…
I’ve noticed that there are many different French keyboard layouts. Some of them behave like you describe it and the one that was matching the desired behavior was named French (AZERTY). E.g. French (no dead keys) was resulting in the behavior you describe. Could you double check your keyboard layouts in the KDE settings?

Note that it seems that it’s possible in KDE to set keyboard layouts just for applications/windows/desktop/gobal. So, maybe try playing around with that. When you updated to Leap 15.5 you got maybe an additional layout that is not matching your desires. So you could try to delete all keyboard layouts that are not suitable for you, if there are any.

Thanks a lot, this is exactly the key I am talking about. Note that I never installed anything related to it, it seems to be out-of-the-box behaviour on my system (even in windows, I think), so what I am trying to figure out is why LO somehow blocks this.

And since I am lectured about the “root cause” here: If I knew the root cause of this behaviour then I would not have needed to even open this question, thanks a lot.