LibreOffice - Menu Bar text colour incorrect after update.

Updated LibreOffice to

Version: 4.1.3.2
Build ID: 410m0(Build:2)

Menu Bar text is now displaying in white. Anyone able to confirm this please?

SUSE Paste

openSUSE 13.1 wtih LibreOffice showing as Version: 4.1.2.3 Build ID: 410m0(Build:3) where see a sort of light grey, unless I change it.

Thanks, at least I’m not the only one seeing it…

Interesting, just had another update with a build time of Fri 15 Nov 2013 18:24:44 GMT. (from Index of /repositories/LibreOffice:/Stable/openSUSE_12.3)

LO still identifies itself as Version: 4.1.3.2 Build ID: 410m0(Build:2) – I guess 13.1 repo is different?

… unless I change it.

Could you clarify that please, is there an option in LO to set the colour of the UI text? – if there is, then I’ve obviously missed it. :expressionless:

If I (temporarily) change the colour globally, then the drop-down menus observe the change, but the menu bar text remains white.

hi,

the colours can change between updates depending upon the downloads and the set
system defaults,

look to see which of these files are installed,

  • libreoffice-gnome - GNOME Extensions for LibreOffice
  • libreoffice-kde - KDE Extensions for LibreOffice
  • libreoffice-kde4 - KDE4 Extensions for LibreOffice

if all are installed, its not known which takes preference,
for consistency suggest only install the package for the preferred/used desktop
manager

cheers

Thanks,

Just checked, only one version installed, KDE4, which is correct.

I’ve tried changing (KDE) themes and colours – LO Menubar text still remains white.

Reported it yesterday as a (possible) bug, https://bugs.freedesktop.org/show_bug.cgi?id=71635. Odd, as it’s the Menubar text I would have expected to see other reports of it – which I’ve not, apart from the confirmation from “paulparker” earlier.

Making some progress…
I have found that by toggling either (Options|LibreOffice|View), “Use system font for user interface”, or “Screen font anti-aliasing”, restores the Menubar text to it’s correct colour -but- only until LibreOffice is closed.

Upon restarting LO the text is again white -irrespective of- the above settings.

Further progress…

It’s related to the use of the Personalisation feature using Firefox themes. Perhaps why it’s not being widely reported – ??

Using this theme:
https://addons.mozilla.org/en-US/firefox/addon/matching-green-for-libreoff/

causes the Menubar text to become white.

Using this theme:
https://addons.mozilla.org/en-US/firefox/addon/soft-aqua/

the Menubar text respects the (KDE) global setting and is unchanged.

Apply theme - close and reopen LO to see the effect.

Bother! >:( Worked just fine in 4.0.x …

tannington wrote:
>
> Further progress…
>
> It’s related to the use of the Personalisation feature using Firefox
> themes. Perhaps why it’s not being widely reported – ??
>
> Using this theme:
> http://tinyurl.com/od2r6q2
>
> causes the Menubar text to become white.
>
> Using this theme:
> https://addons.mozilla.org/en-US/firefox/addon/soft-aqua/
>
> the Menubar text respects the (KDE) global setting and is unchanged.
>
> Apply theme - close and reopen LO to see the effect.
>
> Bother! >:( Worked just fine in 4.0.x …
>
>
you should have tried LO on another user login o check whether peronas
is broken


GNOME 3.6.2
openSUSE Release 12.3 (Dartmouth) 64-bit
Kernel Linux 3.7.10-1.16-desktop

Thanks, I had tried that - same “problem”.

Eventually found the cause: LibreOffice now uses the ‘Foreground’ colour as specified for the Persona. I was not aware of the setting.

After manually editing the “PersonaSettings” in “registrymodifications.xcu” I have restored the black text in the Menubar.

I gave a couple of examples of the persona changing the Menubar Text colour here: https://bugs.freedesktop.org/show_bug.cgi?id=68546#c4