LibreOffice Issues on V12.2 64, Display problem, Printing problem

Using LibreOffice Writer.

Issue 1.

When I open a file, the text is displayed okay.

But scrolling down, the text gets obscured by a white-patch-area, then using the mouse to “shake” the window, the text gets displayed properly after about 30 seconds.

When inserting text, the white-patch-area appears, obscuring the text and makes editting difficult if not impossible

Issue 2.

When printing, the text is over written a few times, the resulting page non-useable.

I have LibreOffice 3.6 installed on my 12.2/KDE 4.10 systems ,ATI and Intel, graphics.
Works well, has some print issues but not as you describe(more subtle)

To be of help, folks will need to know more info on your setup:

Desktop (KDE, GNOME, other)
Video Card (ATI, Nvidia, other)
Graphics Driver (OpenSUSE, proprietary, other)
LibreOffice version installed
Printer and driver being used
Do other programs (e.g. kwrite) print OK?

The display garble you describe sounds like an old (long ago) issue, which I recall being solved for some by turning off “Desktop Effects”.

Here’s what I could find, thank you for helping.

Architecture: x86_64
Processor: AMD FX™-4100 Quad-Core Processor × 4
Memory: 8 GiB, DDR3-1600
Graphics_Card: nVidia GT 630 (VGA compatible controller)
Graphics_Driver: Gallium 0.4 on NVC1
OS_Type: openSUSE 12.2 (Mantis) 64 bit
Kernel: 3.4.11-2.16-desktop
CPU: AuthenticAMD AMD FX-4100 Quad-Core Processor, 3600 MHz
Printer: HP Deskjet 940c Foomatic/pcl3
LibreOffice: 3.5:build-413
system-config-printer 1.3.9

Other programs do not print

I can’t find:
printer driver
desk effects

OK, you have an AMD “bulldozer” CPU and Nvidia graphics.
I’m no Nvidia guru, if one stops by I’ll let her/him take over.
This is a desktop, correct? I don’t think they put bulldozers in laptops.

Is it correct to assume that this is a new install of 12.2 from DVD?
Did you run Yast-Software Management and update after the install?

Your kernel is not the most current (3.4.28 is the most current update) which leads me to wonder if any packages have been updated.
If not, you should do the update first. That would get you updated video drivers and a whole bunch (perhaps 2GBs) of other updates.

If you are running KDE, on your desktop will be a "My Computer " icon(sorry, I am not familiar with Gnome desktop).
Click on that and report what version of KDE is running from the OS Information section.
The Display Info Section will provided video driver information.

Also on the desktop should be an icon for “Personal Settings”, or perhaps “Configure Desktop”, icon shows a crossed screwdriver and wrench .
Open the Desktop Effects section under Workspace Appearance and Behavior. This is where you turn on and turn off Desktop effects.

I believe you are running the Nouveau open source driver, which when up to date is usually consider to be working well.
Perhaps not as fast as the Proprietary Driver, but well enough.
You have plenty of CPU, so Desktop effects should work, as long as the driver is up to date.

For later: Once you have things update and running OK, you should update to LibreOffice 3.6.
Some LO3.5 builds have a nasty bug that trashes embedded images in Writer files.
But, fix your bigger issues first.
HP printer drivers are usually reliable, but perhaps there was an update for your specific one,

I’m using Gnome V3.4.2

I ran an update, no luck.

New information, a printer test page doesn’t print correctly.

Should I change from the opensource nVidia driver to the nVidia driver?

As I said, I have no Gnome experience.
Many do, sooner or later they will stop by.

If you want to try the Proprietary Nvidia, I suggest James’s item HERE.

Printer is likely unrelated.
You can look in Yast - Hardware - Printer
How did you install printer initially?

I see the printer in YaST==>Printer](

Yast ==> printer ==> automatic-configuration worked.

BTW, the “foomatic” option did not work.

Thank you.