LibreOffice .docx document icon disappeared

openSUSE Leap 15.4, KDE, LibreOffice

LibreOffice somehow lost its Writer document icon for *.docx files. Now everything *.docx shows a gray question mark as the icon for the document.

I cannot manually choose a document icon.


Lost from where exactly, you description is a little vague.

No problem with *.docx files on this 15.4 system, display correctly and it’s possible to allocate a different icon.

Perhaps a description of how to reproduce your problem, together with a screen-shot might clarify the issue.

Is it all *.docx or just one specific file. Have you checked the mime type of the file is correct?

file --mime <filename>.docx

It is not clear how to attach as screenshot at this point in the forum thread. I tried an in-line .png but that was not accepted by forum software.

The problem affects all *.docx icons. A document-ish icon is replaced by a default question mark icon.

I checked the link =

If I right click on a .docx icon and choose “Properties” I get the first pane no problem (General, Permissions, Checksums, Details, Share tabs).

However I cannot get to the second pane (General, Embedding tabs). All left and right clicking goes nowhere.

I checked mime type. Response = Notes_HTML.docx: application/octet-stream; charset=binary


You can go to and upload an image there (see the word Image at top-right).
After you did this, you can copy/paste the URL from the page as shown in the address bar of your browser (and not the URL of the image itself). Paste this using the Link button (the one with the globe) from the toolbar of the post editor.

Nice solution for posting an image

We’ll address that issue later.

I checked mime type. Response = Notes_HTML.docx: application/octet-stream; charset=binary

What created that file? For *.docx I would expect to see:

paul@HP255G7:~/Global/Downloads> file --mime sample2.docx
sample2.docx: application/vnd.openxmlformats-officedocument.wordprocessingml.document; charset=binary

Your file isn’t being recognised as *.docx, it’s being seen as a generic octect-stream, hence the “?” icon.

While you seem to be happy with my pointer to (you are quite welcome). I take the liberty to point you to another habit here. We do not like the way you posted the above quote. On a terminal you type the command and look to the output and then you copy/paste all of that between the CODE tags. Look at @tannington’s post: in this case three lines: prompt/command - output - next prompt. And then there no need for talking “I checked …”, because we all see what you saw. And that is what counts.

I usually use LibreOffice exclusively so the *.docx files were created by LibreOffice.

That being said to address another problem (printing to PDF and paper not being done correctly for large document files) I downloaded FreeOffice to use an independent app to check of LibreOffice was the problem (it wasn’t).

FreeOffice insinuated itself as the default word processor. I set the default back to LibreOffice. But somewhere in there the identity of *.docx seems to have been compromised.

I will keep code output convention in mind, good to know.




By default LO doesn’t save as .docx (unless that was the format of an existing document LO opened), you have to explicitly choose that format, it would normally use it’s native ODF (.odt) format.

I see you have three options at the moment:

  1. Leave as is and accept the “?” icon.

  2. If there are not too many documents, open each in LO and save as an ODF (*.odt) document, that would be my preferred choice, I try to keep all document in ODF format.

  3. Change the icon asscociated with “application/octet-stream”

System Settings -> Applications -> File Associations

Then change the icon associated with “application/octet-stream”, don’t associate a file extension or application, just change the icon.

Just one other thought…

You might want to check that “FreeOffice” hasn’t changed the file associations for *.docx

Again: System Settings -> Applications -> File Associations

For *.docx it would be set as shown:

If you wish to change the icon, that can be done by a left click on the icon currently shown.

I went to System Settings -> Personalization -> Applications

It turned out FreeOffice was still listed as the preferred application. What? Changed that.

typed in “docx”, got two results:



I selected “vnd.openxmlformats-officedocument.wordprocessingml.document” and typed “docx” in the search field.

Changing that icon did not work and affected nothing.

I then selected “wps-office.docx”

Left-clicked on icon, selected the one I wanted, clicked on Apply.

That worked! Problem solved. Yay!