libreoffice calc, backspace does not delete text in fields and dialogs

I have an annoyance I noticed while using libreoffice calc. When I delete text in say the Name Box field it does not actually delete the text from view. It makes it hard because what you type types over the letters/numbers already there. The Name Box field works, however. I can backspace in the field then type A1:A5 and it will select A1-A5. But its hard to read when typing because it just types over what’s there. I upgraded to the latest version in Libreoffice:4.4 repo --version to see if it corrected it. It did not. Don’t have this problem in any other programs…might be in all of libreoffice programs, but I’ve only noticed it in libreoffice-calc

Thanks for any ideas. Might try the version in Libreoffice:Factory

upgraded to libreoffice:factory repo --version Still the same problem. Wondering if it’s a dependency of it that is causing the issue.

I’ve got some other rendering issues in LO5 myself.
Try this workaround:

SAL_USE_VCLPLUGIN=gen loffice"

and tell us please, if it helps. Instead of “gen” you could also try “gtk2”; it looks better.


Thanks for your time Hendrik

I opened up a terminal (konsole) and typed

SAL_USE_VCLPLUGIN="gen loffice"

In libreoffice, chose spreadsheet and checked the Name Box, still didn’t delete contents away from view

I tried

SAL_USE_VCLPLUGIN="gtk2 loffice"

as well as

SAL_USE_VCLPLUGIN="gtk3 loffice"

neither had any impact on the Name Box.
However, I just found out that resizing the window deletes the previous contents from view. Not a great workaround (resizing every time) but better than what I originally had.
Have any more workarounds I can try for this problem? Oh and just to clarify, this problem is in, and

Sorry for my typos, but try it without quotation mark(s):

 SAL_USE_VCLPLUGIN=gen loffice

and maybe with “gtk” instead of “gtk2”.

That resizing solves this problem, indicates, that it is the one for my workaround.



sorry took so long to reply. I used gen and it worked, but sure is ugly. gtk and gtk2 did not work. kde4, however, is my favorite. Thank you for your help

this works great:

#>SAL_USE_VCLPLUGIN=kde4 loffice

I should have figured out that loffice was the command and not part of the value of SAL_USE_VCLPLUGIN. oops