LibreOffice Base + Remote MySQL on 12.3 64bit

I upgraded to 12.3 64 bit a few weeks ago and I have just had cause to access a remote MySQL database through LibreOffice. Prior to the upgrade I had no issues connecting. However whenever I try to connect now, Base crashes as soon as I type the password for the database in. Running from commandline, I get this error:

 	 	 	_terminate called after throwing an instance of 'sql::InvalidArgumentException'

what(): Couldn’t load library libmysqlclient_r.so: libmysqlclient_r.so: cannot open shared object file: No such file or directory_

This library doesn’t exist on the system and searching the packages for the file produces no result.

Can anyone provide any clues as to where to look?

libmysqlclient18 is present in the repos

Yes, and it is installed on my system:

rpm -qa |grep libmysqlclient
libmysqlclient_r18-5.5.30-119.1.x86_64
libmysqlclient_r18-32bit-5.5.30-119.1.x86_64
libmysqlclient18-32bit-5.5.29-1.1.1.x86_64
libmysqlclient18-5.5.29-1.1.1.x86_64

find . -name libmysqlclient*
./lib/libmysqlclient.so.18
./lib/libmysqlclient.so.18.0.0
./lib64/libmysqlclient.so.18
./lib64/libmysqlclient.so.18.0.0

I have tried with libmysqlclient_r18 installed by itself, installed with libmysqlclient18, and libmysqlclient18 installed by itself. I do not seem to be getting the correct files installed.

Are we able to access mysql through workbench ?

Yes, Workbench can access the remote DB with no issues.

i think this may be missing libreoffice-base-drivers-mysql in the installation
http://software.opensuse.org/package/libreoffice-base-drivers-mysql

Unfortunately not:

rpm -qa |grep libreoffice-base-dr
libreoffice-base-drivers-mysql-4.0.2.1-1.1.x86_64

I suspect version 4.0 of LibreOffice has an issue here. I may try downgrading over the weekend and see how it goes.

Intermission!

Please, use CODE tags around your computer texts. The # button in the toolbar of the post editor.

I had the same problem and solved it:

install libmysqlclient-devel

YES!!! Thank you… this worked like a charm.

For the record, meaning others reading this later, I have had a heck of a time getting MySQL and Workbench to work right on my machine. Between multiple versions of MySQL and multiple versions of workbench I kept having one of three issues. (1) MySQL refused to see my existing users in the database. (2) Causing site communication errors. (Rejected connections) and (3) MySQL refusing to start with errors like cannot find socket and all kinds of other ****. After 3 days of testing every possible configuration between like 8 versions of MySQL, 3 versions of workbench, (do the math, that is 24 possible matches) I finally got 1 setup to work. Then I upgraded workbench and ran into this error…

Couldn’t load library libmysqlclient_r.so: libmysqlclient_r.so: cannot open shared object file: No such file or directory

Installing the devel version sure did fix it and now I am up and running.

Thank you so much for that info. I would never have thought of it because I don’t normally allow devel/source packages to even show in my list. I am a php/perl programmer and don’t usually need those kinds of files for what I do.

So… in case any one has had a heck of a time like I have I have posted the details and what I finally got working in hopes to return the favor and save someone else from another headache, too.

libmysql57client18 5.7.1-8.1
libmysql57client18-32bit 5.7.1-8.1
libmysql57client_r18 5.7.1-8.1
libmysql57client_r18-32bit 5.7.1-8.1
**libmysqlclient-devel
** ** 5.5.32-137.1**
libmysqlclient18 5.5.32-1.8.1
libmysqlclient18-32bit 5.5.32-137.1
libmysqlclient_r18 5.5.32-137.1
libmysqlclient_r18-32bit 5.5.32-137.1
libmysqlcppconn6 1.1.2-31.15
libmysqld18 5.5.32-1.8.1
libqt4-sql-mysql 4.8.4-3.6.1
libqt4-sql-mysql-32bit 4.8.4-3.6.1
mariadb-errormessages 5.5.32-137.1
mariadb_100-errormessages 10.0.4-2.1
mysql-community-server-errormessages 5.5.32-1.8.1
mysql-community-server_57 5.7.1-8.1
mysql-community-server_57-bench 5.7.1-8.1
mysql-community-server_57-client 5.7.1-8.1
mysql-community-server_57-debug-version 5.7.1-8.1
mysql-community-server_57-errormessages 5.7.1-8.1
mysql-community-server_57-test 5.7.1-8.1
mysql-community-server_57-tools 5.7.1-8.1
mysql-workbench 6.0.6-68.4
perl-DBD-mysql 4.021-4.1.1
php5-mysql 5.3.17-3.4.1

You would think that all I would need to do is rollback to the suse approved/released, non-extra repository, releases and the standard install from the main repository would be fine but nope. I guess this is why I noticed that the DVD of openSUSE 12.2 had MySQL on it, and 12.3 DVD did not have MySQL on it. This was because they couldn’t get it working either so they left it off the DVD? Well, i dont know but i have a working setup now. Both 5.5 & 5.6 installed broken!

So for those who were googling the error: I have found that on 13.1 64-bit it’s also necessary to install libmysqlclient-devel for MySQL Workbench to work (workbench 6.0.8, mariadb/mysql packages as default on 13.1).

Came here by googling exactly the same error but thrown by mysql-workbench. Unfortunately adding the libmysqlclient-devel package does not solve the issue, any ideas?