LibreOffice Base / Mariadb not working after OpenSuse 13.2 installation

Can it be that some database drivers are missing from the Opensuse 13.2 installation?

I am running a Mariadb backend database from LibreOffice base client under OpenSuse 13.2. Everything worked as required under Opensuse 13.1

Now (under OpenSuse 13.2) I am getting an error “couldn’t load library libmysqlclient_r.so…no such file or directory”

I have made sure that the corresponding Mariadb packages are in fact installed. What could still be missing?

Cheers
Harvey

libmysqlclient_r.so? That’s part of libmysqlclient-devel but should not be needed for running programs, only for compiling them.

Or is it missing /usr/lib64/libmysqlclient_r.so.18 rather?
If that’s the case, try reinstalling it:

sudo zypper in -f libmysqlclient_r18

I have seen reports on 13.1 already, that the package’s files might get removed under certain circumstances.

That is how I understand it, as well. nevertheless, the full (fatal) error message is

“Couldn’t load library libmysqlclient_r.so: libmysqlclient_r.so: cannot open shared object file: No such file or directory”

Cheers
Harvey

Then install libmysqlclient-devel and it should work. In the end libmysqlclient_r.so is just a symlink to libmysqlclient.so (which in turn is a symlink to libmysqlclient.so.18) anyway.

And you should probably file a bug report. LO should not need libmysqlclient_r.so as mentioned, and if it does it should at least require the corresponding package.
http://bugzilla.opensuse.org/ (same username/password as here)

It works with the libmysqlclient-devel installed. Just for the record, this was a ‘new’ installation. I believe the previous LibreOffice Base under Opensuse 13.1 also only worked with the development package installed.

Thanks for your help!

Maybe.
I wouldn’t have noticed, as I do (and did) have libmysqlclient-devel installed (mysql-workbench requires it). And I don’t use lobase anyway.

It does make sense to not install libmysqlclient-devel by default though.

As said, libreoffice-base should require it if it needs it, or at least “Recommend” it (as other db backends will probably work fine without it).

Does mysql-workbench work with mariadb? Is there an alternative to LOBase for creating reports (with equivalent strength of features) ?

Yes.
You will get a warning at startup that it might not be compatible (because of mariadb’s version jump to 10.0), but it should work fine.
But mysql-workbench has a different problem at the moment (unrelated to mariadb):
http://bugzilla.opensuse.org/show_bug.cgi?id=904767

An update for this is on the way and should be released in the next days, you can find fixed packages in the bug report as well.

Predictably, that bug was pretty well the first thing I noticed with the workbench! The form view works fine though.

Bug 906147 submitted

JFYI, the update that fixes this has been released today.

I just installed it, and mysql-workbench’s result grid works fine now here.