LibreOffice 5 freezes system

LibreOffice 5 freezes system (screen), can not do anything more.
Only reset x server works.(CTRL-ALT-Backspace)

Don’t now why ???

Gerrit Jan

openSUSE leap 42.1 x64

I can confirm this strange behaviour.
It was one of main points for return back to 13.2.

Nothing unexpected here with Gnome, apart from the “upstream - Windowish” look due to libreoffice-gnome not being installed by default because of known desktop integration problems with Gnome.

Maybe your problem is configuration or video card related?

[LEFT] [LEFT]tried to go back to version 5.0.2.2, but also then freezes everything.
I turn plasma 5.
It is very annoying.:frowning:

really have no idea what causes it.
[/LEFT]
[/LEFT]

It might be caused by the GNOME/GTK3 integration.

Try to uninstall the packages libreoffice-gnome and/or libreoffice-gtk3 if they are installed.

If that doesn’t help, you could also try to remove libreoffice-kde4, but that works fine here.

Maybe LibreOffice is just triggering a problem elsewhere?
Assuming that it is a graphics / HW problem, you might try in KDE Plasma5:

Configure Desktop (System settings) > Hardware > Display and Monitor > Compositor > Rendering backend > OpenGL 3.1 (or one of the other options)

And in LibreOffice you might try to uncheck Options > LibreOffice > View > Use hardware acceleration
or > Use anti-aliasing
or check > Use OpenGL for all rendering

I’ve also read that Plasma5 is at odds with the current Nouveau driver for Nvidia chips. What’s you graphics / driver?
I’m using Gnome on Intel HD4600 here (Optimus not engaged by LibreOffice) and apparently everything OK…

@ wolfi323

Did try it, but no success.

@ OrsoBruno

I have a Intel graphics / driver
Set OpenGL 3.1 to OpenGL 2.0
And your tips don’t work either.

[LEFT][LEFT]Oh, the mouse and keyboard are working, but can not do anything on the screen.
[/LEFT]

OS: openSUSE Leap 42.1
KDE PLasma 5.4.2
QT 5.5.0
Kernel 4.1.12-1-default
Type OS 64-bit
[/LEFT]

I switch to GNOME and all is working fine there…

Did delete the libreoffice .config file in the home dir, but that did nothing.

Keep looking

Gerrit Jan

[LEFT] [LEFT]I have reinstalled 42.1 and so far everything okay with LibreOffice.

However I have 2 repos not yet added, Framework5 and LibreOffice.
I’m going to do, 1 for 1.
[/LEFT]
[/LEFT]

After freezing LibreOffice I always obtain error message that
KDEInit cannot run ‘/usr/lib64/libexec/kf5/kioexec’

Try changing Folder View settings and manually ‘Specify a Folder’ (the folder you want showing). It’s a known work around when that error message gets generated. Try it out.

Please, where is it possible to set this?
Because there is problem only in the case of opening LibreOffice file via Main KDE menu->Recent documets.
Problem does not occur in case of opening it via krusader or directly in LibreOffice.

Look at your desktop and ‘Folder View’ is the default desktop widget that you look at apart from your bottom panel. It’s where you usually put your files and folders that you currently work on,

Right click bottom panel and ‘Unlock Widgets’ and go to Folder View and hover over right side edge till the pop-out controls stick out. Aim for the spanner icon (third icon down) and click it.

In ‘Location’ put a dot in the ‘Specify a Folder’ radio button and click to navigate to your desktop (/home/username/Desktop) - or wherever it is you usually use. Press Ok, Apply and Ok. Try that.

David, thank you for your trying to help me.
But supposed solution does not work in my case.

Now I am again back on openSUSE 13.2.
For me presen comfort and stability of openSUSE Leap is still not on the level of the previous release. I try it again next year.

[LEFT] [LEFT]I have reinstalled the 42.1 X64, and added the repositories that I had before one by one.

And I now have no problems.
Have no idea what did causing it???

[/LEFT]
[/LEFT]

Well, this problem has been fixed today: (fix will be in KDE Frameworks 5.17.0)
https://bugs.kde.org/show_bug.cgi?id=353037

But as I understand it, it shouldn’t freeze LibreOffice but rather Dolphin or Plasma depending on how you open the file (until you close LibreOffice and click on the OK button of the then appearing error dialog).

@GJElde:
Was it this that you experienced?

If yes:
This shouldn’t happen if you start LibreOffice normally.
Did you reuse your home now when you did a fresh installation, or did you start clean?
If the latter, you maybe you had an incorrect launcher/menu entry for LibreOffice in your home directory or something like that.

Yes, exactly.

Well, this should be fixed in 5.17 as mentioned.

It was problem(freezes screen) For me too but the problem is not libereoffice
I after deleted all config(.folders) folders at home
Problem solved

This only helps when using the folder view to open documents.
It doesn’t change anything for the application menu or dolphin…

I submitted the fix to KDE:Frameworks5 2 days ago.
It will take a while until it is available for installation though, because at the moment the Plasma 5.5 (which is in Beta now, but 5.5.0 will be released in a little more than a week) packages are being prepared already.

An update for Leap 42.1 with this fix will be submitted as soon as the currently running update to KDE Frameworks 5.16.0 has been released (to not delay it).

If there is need, I can prepare a package with the fix in a separate repo though.