LibreOffice crashes with a std::bad_alloc

Posting in Beta forum as LO is from factory repo

LibreOffice crashes with a std::bad_alloc when opening menus in Writer

When opening a menu item in Writer the menu displays then a window opens with the message “std::bad_alloc”. The unusual/perplexing things are:

  • it does not happen in other LO apps (Calc, Impress, Draw)
  • it does not crash for a different user

Writer seems to function fine otherwise, I can enter and format test using the toolbar and context menu

I renamed ~/.config/libreoffice and that did not help, I then tried changing some application appearance options KDE’s systemsettings and that also did not help

any idea would be welcome


other things I’ve tried:

  • rename ~/.kde4 and restart
  • rename ~/.config and restart
  • deleted ~/.cache
  • deleted ~/.config/Trolltech.conf

still perplexed and searching that error and LibreOffice see it in relation to large docs and it happens with empty docs

FIXED IT, though not exactly sure why, by removing the hicontrast, sifr, galaxy and tango icon packages and gnome extensions - one of them was the culprit