LibreOffice 4.2.5 Save Window

after upgrading to LO 4.2.5 I noticed that the save window is changed
instead of Dolphin window now a different window is appearing, more simple

is there a way to restore the previous Dolphin window?

No. LO never used any “Dolphin window”.
What you mean is KDE’s file dialog… :wink:

Well, I’m aware of the fact that 4.3.0 doesn’t seem to use KDE’s dialog any more, but 4.2.x did use it last time I tried.

Do you have libreoffice-kde4 installed? (in the same version as the rest of LO)

Do you have “ibus” installed? That disables the KDE4 integration, so you have to remove it.

Check in LO’s settings->General that “Use LibreOffice dialogs” is not active.

problabily I’m not using the right expression, it was a windows similar to Dolphin look…

libreoffice-kde4 is installed
ibus is not installed, but several libs are there
“Use LibreOffice dialogs” was not selected

I’ve tried to enable or disable it but no effect…

But it doesn’t have anything to do with Dolphin. It is part of kdelibs and it is much older than Dolphin in fact.

Dolphin is just a file manager.

libreoffice-kde4 is installed
ibus is not installed, but several libs are there
“Use LibreOffice dialogs” was not selected

I’ve tried to enable or disable it but no effect…

Well, there might have been a change in LO 4.2 recently as well, so that it doesn’t use it any more (maybe even a packaging bug).
As I said, I noticed this with 4.3, but 4.2 did use KDE’s file dialog last time I tried. And I cannot try right now, as I have 4.3 installed. (no time to install 4.2 at the moment)

You could try to run LO like this to make sure the KDE4 integration is used:

OOO_FORCE_DESKTOP=kde4 lowriter

Other than that there’s not much you can do, except report a bug.

is anything related with the LO icon in the desktop folder?

I was deleting it…

this is what I mean:

LO Standard on my old Panasonic CF-29](

LO 4.2 on Dell Precision M4800 and Panasonic CF-53](


I know what you mean.
As I wrote, I saw the same with 4.3.
And I have installed 4.2 in the meantime and can confirm this there as well.

Still, as I also wrote already, there’s nothing you can do about that, other than to write a bug report.
This could a packaging error, but I don’t think there has been any change regarding the packaging recently.
Or this is a change in LO itelf. Maybe they even removed the use of KDE’s file dialog on purpose because of problems?
LO 4.1 even crashed because of such problems, this got fixed later on.

LO Standard on my old Panasonic CF-29
This is 4.1, right?

And it did work with 4.2 as well until recently? Until when? Or did you mean you upgraded from 4.1 to 4.2 when you wrote “after upgrading to LO 4.2.5”?
As I said, it did use KDE’s file dialog a while back when I last tried it (a few months ago).

PS, I found this with Google:
Which in turn points to this upstream commit from April:

So apparently they (LibreOffice developers) indeed disabled the use of KDE’s file dialog on purpose.

Sorry, I’ve seen your reply just now…

Yes, it is

No, it was not working in 4.2, yes I mean until I upgraded to 4.2…

thanks for the links :slight_smile:

FYI, since that commit LibreOffice checks if certain bugs are present in Qt4 and disables the KDE4 file dialog in this case.
Fixes for those bugs have been added to the libqt4 in the KDE:Qt repo and Factory in June already, but they didn’t fully work.
This has been fixed today.

So if you want to have the KDE4 file dialog back in LO, add the KDE:Qt repo to your system and install libqt4 from there.
E.g. for openSUSE 13.1:

sudo zypper ar KDE:Qt
sudo zypper dup --from KDE:Qt

If you have questions about that, feel free to ask.

The fix should be in Factory soon, and hopefully also in 13.2 final.

See also this bug report: