Libreoffice 4.1: Update warning

updated today to lo-4.1.0.4

could not open any file saved with password protection

files still open with lo-4.0.4.2-2

anyone else having this problem?

anyone found a fix?

cheers

fix available see

Bugzilla – Bug 64916

with the set-up on this PC the following solved the problem

sudo ln -s /opt/libreoffice4.0/program/libsqlite3.so /opt/libreoffice4.1/program/libsqlite3.so

keellambert wrote:

fix available see Bugzilla – Bug 64916 with the set-up on this PC the following solved the problem sudo ln -s /opt/libreoffice4.0/program/libsqlite3.so /opt/libreoffice4.1/program/libsqlite3.so

There is nothing in /opt folder on my machine.
Did you install LO from source ? :sunglasses:

– GNOME 3.6.2 openSUSE Release 12.3 (Dartmouth) 64-bit Kernel Linux 3.7.10-1.16-desktop

both lo_4.0 and lo_4.1 are both installed from ‘http://www.libreoffice.org/
on this PC, hence /opt installs

openSUSE12.3 and Tumbleweed do not install lo to /opt, apparently

search to where lo is loaded for these distributions then apply the logic

otherwise wait till lo_4.1.1 is released

cheers

I’ve been having good luck with 4.0, but 4.1 is definitely not ready for prime time. Check the release notes for 4.1

I generally check before updating, and this time I was glad I did. I decided to hold off.

There are a couple of bugs in 4.1 still that are really serious. The difficulty opening password protected files is only one. The other, letters jumping around on the line being typed, is even worse. I wouldn’t even consider going to 4.1 until these are resolved and a new version released.