LibreOffice 3.3.1 default printing options

Whenever I want to print from Libre Office, it’s default printer options are somehow set to duplex long edge (standard) and the print quality is set to economy. I want this changed to Duplex Off and print quality set to standard.

I’ve tried setting Libre Office’s printer settings (File > Printer Settings) and when that failed, I went to File > Templates > Organize > Commands button and selected Printer Settings and changed them from there. None of these worked. Whenever I open a document, the print quality is always set to economy and duplex is on (even when it is not needed). I have to keep changing it each time I print a document. I allow my children to use this computer for homework at times and I don’t want them to have to mess with the driver settings all the time (more of a chance for something to go wrong or be set incorrectly).

I’ve also checked the printer settings from within YaST and they are all ok.

I did try changing the settings from within the CUPS interface but when I did that, I could no longer print. The system couldn’t connect to port 631 anymore and I had to go into YaST again to make it reconnect to the printer port.

BTW, when I looked just now at the default printer settings within CUPS, everything seems to be set right, duplex is set to off and print quality is set to standard, which is what I want.

Why does Libre Office seem to be ignoring these settings? How can I fix this (easily I hope)?

I don’t see this problem.
Whatever setting I last used, seems to be the one used next time.

Open a office document and go to Print then to Properties (by the details section)
In the next box you can set the print quality
Do you see that?
Or is that what you were doing?

Hope you are well by the way :smiley:

This is what I’ve been doing all along. It is still set to print quality: Economy and duplex long edge. Those were not the settings last used at all.

I’m well. I’ve got a very busy day today. I will be showing my artwork this evening. How are you?

I’m OK thanks

I wonder if it’s worth trying a rename of /.libreoffice
To start a new one. You can always revert back

I messed it up really bad doing that.
After I tried naming it back to just .libreoffice It came up with all kinds of folders and stuff to write into. I hit cancel half way through them. When I open something with it now, I get this message:


Error loading BASIC of document file:///home/<username>/.libreoffice/3-suse/user/basic/dialog.xlc/:
General Error.
General input/output error.

P.S. I omitted my system username and replaced it with <username>
Now what?

The procedure is to rename like this:
.libreoffice > .libreoffice-old

When you start office again it will create a new .libreoffice
If using that didn’t help, you should delete the newly formed .libreoffice
Then rename .libreoffice-old > .libreoffice

If you (as this is how it sounds) you didn’t delete the newly formed .libreoffice when you renamed .libreoffice-old and a merge to place.

Your only alternative is to delete whatever .libreoffice is there and just start again. You just lost your old .libreoffice

Your only alternative is to delete whatever .libreoffice is there and just start again. You just lost your old .libreoffice

I just tried that (and I deleted the renamed libreoffice) and now libreoffice won’t start.
.libreoffice does not seem to be in the trash bin to restore it.

This what is says when I try to start it from the commandline:


[Java framework] Error in function createSettingsDocument (elements.cxx).
javaldx failed! 
terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

My java apps (SweetHome 3D and Art Of Illusion) seem to be fine though.

There is a difference between delete and move to trash.

Are you using libreoffice from a repo other than default?

It is the default one, the one that came with the system.
3.3.1.2-1.2.2-x86_64 from vendor openSUSE (installed).

ok, I did think that move to trash and delete were the same. That explains why I can’t find it in the trash bin to restore it then, doesn’t it?

So, should I uninstall it and then re-install it? Since there is an entry in /usr/bin/X11/libreoffice should I restart the computer after uninstalling it and before re-installing it?

Barbara:

The .foldername folders in /home - It should be possible to delete one (I usually rename it so I can go back to it if necessary)

Let me try it with .libreoffice
I’ll be back

I was able to rename .libreoffice and start libreoffice with no problem.

I then deleted the newly created .libreoffice and renamed the -old one back to .libreoffice
All was good.

Try removing any .libreoffice you have now and try libreoffice again. If that fails
Test a new user login

Try removing any .libreoffice you have now and try libreoffice again.
Libreoffice still fails for me so I did create a new user login. Libreoffice worked for the new user. It opened without any trouble.

So, now what do I do? Can I drag a copy of the new .libreoffice to my folder or something?

BTW, I think that the new user session might still be running. I just used switch user, rather than logging out. Was that ok? Also, I did not disable automatic login for myself when I created the new user. I hope that won’t cause any troubles.

No worries
It shouldn’t matter

But simply bringing the folder from the test account is no use. Something else is causing this.
Just confirm what happens in your normal account when you delete .libreoffice

Earlier you quoted here:
LibreOffice 3.3.1 default printing options

Yes, this still happens:

libreoffice
[Java framework] Error in function createSettingsDocument (elements.cxx).
javaldx failed! 
terminate called after throwing an instance of 'com::sun::star::uno::RuntimeException'

.libreoffice was deleted already. Libreoffice won’t start and as a result another .libreoffice can’t be created.

So, where do I go for finding out what went wrong?

Would uninstalling it and then re-installing it fix things?

Download this, extract and try it
http://dl.dropbox.com/u/10573557/.libreoffice.zip
remember it’s hidden

FYI this is my java apps:

timezone-java-2011g-0.2.1.noarch
java-1_6_0-sun-1.6.0.u26-0.2.1.x86_64
java-ca-certificates-1-9.1.noarch
java-1_6_0-sun-plugin-1.6.0.u26-0.2.1.x86_64


ok, it worked. At first I couldn’t see that there was a text file by the same name (.libreoffice) and that is what was preventing me from extracting the folder you gave me.

So, Libreoffice starts now! Yay!

Also, what command did you use to show all your java apps?

ok, now that we got that out of the way, the printer options are still ignoring the system defaults of Duplex mode: Off and Print Quality: Standard.

rpm -qa | grep java

If you try printing in the test account. Does the same issue remain?

Printing from the test account is perfect, Duplex is Off as it should be and Print Quality is Standard as it should be.

In my own account, I went to Printer Settings from within LibreOffice and set the printer the way I wanted it and when I printed my little document, it went right back to Duplex Long edge and Print Quality Economy. >:(

So, rpm -qa | grep java for me gives:

java-1_6_0-sun-1.6.0.u25-0.3.1.x86_64
java-ca-certificates-1-9.1.noarch
java-1_6_0-sun-devel-1.6.0.u25-0.3.1.x86_64
timezone-java-2011g-0.2.1.noarch
java-1_6_0-openjdk-plugin-1.6.0.0_b20.1.9.7-1.2.1.x86_64
java-1_6_0-openjdk-1.6.0.0_b20.1.9.7-1.2.1.x86_64
java-1_6_0-sun-plugin-1.6.0.u25-0.3.1.x86_64