Libre office crashes when opening document

Since a week ago libreoffice crashes when opening files. I can start writer or calc but when I open existing file both calc and writer crash. I tried already deleting the libreoffice directory in ~/.cache and ~/.config.

It happens with any writer or calc document and I can open the documents in Caligra Sheets

I’m running 42.3 Leap with all current updates. I’m using pacman repo at higher priority for the multimedia files. I did zypper dup using pacman but after this I had no problems. Also I’m using Firefox repo for Firefox 57.

I also tried adding libreoffice 5.4 opensuse leap repo and doing a dup. This hasn’t helped. I removed repo and updated (downgraded back to 5.3) and installed libreoffice-kde manually. This hasn’t helped either.

Please post output of

zypper lr -d

To exclude a user config: create a new user, login as that user and try to reproduce the crash. If it doesn’t crash for the new user, the culprit is in your homedir. If it does crash, try starting lowriter from a terminal window, make it crash and have a look at the messages in the terminal window.

Question; how did you use zypper dup ? Just plain, or with a --from parameter?

Doesn’t crash with new user. Interestingly you need to use yast, useradd is insufficient to add a user.
I used zypper dup -f (–force) 1

How do I go best about removing my account and not loosing data? In root terminal move my files elsewhere (I don’t think I have room for 2 copies or 100GB will take a while)? Then remove and recreate user?
Is there some way I could fix this by simply removing some configs?

Here is the output

# | Alias                          | Name                                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                          | Service
1 |       | nVidia Graphics Drivers                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                |        
2 | | Packman Repository                          | Yes     | (r ) Yes  | Yes     |   50     | rpm-md |                             |        
3 | mozilla                        | Mozilla based projects (openSUSE_Leap_42.3) | Yes     | (r ) Yes  | No      |   50     | rpm-md |        |        
4 | openSUSE-42.3-0                | openSUSE-42.3-0                             | Yes     | (r ) Yes  | Yes     |   99     | yast2  |                |        
5 | repo-non-oss                   | openSUSE-Leap-42.3-Non-Oss                  | Yes     | (r ) Yes  | Yes     |   99     | yast2  |            |        
6 | repo-update                    | openSUSE-Leap-42.3-Update                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                           |        
7 | repo-update-non-oss            | openSUSE-Leap-42.3-Update-Non-Oss           | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                       |        
8 | skype-stable                   | skype (stable)                              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md |                                           |        
9 | snappy                         | snappy                                      | Yes     | (r ) Yes  | No      |   99     | rpm-md | |        

Remove the LO config files in the user’s home maybe also clear the users .cache files. Might also be in the desktop config/cache files. If no problem with second user it is not a package problem.

I’m also having this issue in 42.3. So, as suggested, I deleted the LO config files in home. Let’s see…

Running LibreOffice (from without incident. Prior to upgrading to this repo, sporadic failures in Calc were experienced at LibreOffice from the Leap Update repo.

I pinpointed the issue to ~/.mozilla/firefox/randomprofilename.default folder. As soon as I move it away the problem goes away.

I logged out, moved my homedir to / as root and deleted and recreated the user. Then I logged in desktop session as user and started moving my files back. Of course I also wanted to move browser caches and other stuff but when I tried opening documents problem happened again. Then I moved stuff step by step and tested after each move.

I’m having difficulty understanding why the Mozilla Firefox browser files are causing LibreOffice to crash.

  • However, performing a case-insensitive search (with ‘grep’) in the ~/.config/ directory for ‘mozilla’ revealed that, the LibreOffice configuration files do in fact mention “Mozilla”.

Be that as it may, please be aware that, beginning with LibreOffice version 5.3, Type 1 (Postscript) fonts are no longer supported.
Only TrueType (TTF) and OpenType (OTF) fonts are currently supported by LibreOffice.

  • Do the files you’re attempting to open contain (embedded) Type 1 (Postscript) fonts or, are they attempting to load Type 1 (Postscript) fonts?

I am also having this problem.
I did a fresh install of leap 42.2, then added leap 42.3 oss and non-oss base and update repos, then did zypper dup.

>zypper lr -u
Repository priorities in effect: (See ‘zypper lr -P’ for details)
99 (default priority) : 4 repositories

| Alias | Name | Enabled | GPG Check | Refresh | URI

1 | 42.3_noss | repo-noss | Yes | (r ) Yes | Yes |
2 | 42.3_noss_update | repo_noss_update | Yes | (r ) Yes | Yes |
3 | 42.3_repo | repo-oss | Yes | (r ) Yes | Yes |
4 | 42.3_update | repo_update | Yes | (r ) Yes | Yes |

(I didn’t do a fresh install of 42.3 because the installer wouldn’t actually run)

I was using a simple spreadsheet, where I researched PC parts, that I created a month ago, containing only text and simple sum formulas. I was using default fonts. Also I then test created some writer documents using default fonts (New file, press keys, save, close Writer, open).

This seems strange to me as well. Was wondering if I could trace what it is libreoffice doing in mozilla profile.

I also did dup from 42.2 couple of months ago but that was before I successfully created saved and reopened the spreadsheets. Had no problems after upgrading from 42.2.

If I create a new user and run from there, it will launch without a problem, so it is something to do with config.

Yes; Catch-22 with UNIX® GUIs in general, has been (since early UNIX® GUI days), and remains (possibly for ever), the issue of system upgrades and user configurations.

The only viable solution for about 90 % of the UNIX® user community is, for the concerned (GUI) user to logout and then to delete the user’s GUI configuration from a TTY (CLI) or SSH CLI session. The user with the misbehaving GUI then logs back in, sets up the GUI preferences again and, continues working.

I see in ~/config/libreoffice/4/user/registrymodifications.xcu some links to mozilla folders, as I opened documents from ///temp (apparently directly from firefox) with Libreoffice.

Maybe you edited Firefox config files with Libreoffice in the past?

The remaining references to “mozilla” I can find in Libreoffice are references to “Mozilla Public License, v. 2.0” in the headers of files…

mv ~/.config/libreoffice ~/.config/libreoffice_old

Libreoffice now opens.

I had the exact same issue after installing opensuse 42.3. LibreOffice 5.3 would hang indefinitely.
renaming ~/.config/libreoffice with ~/.config/libreoffice_old as suggested by os_brendan did the job for me.

This problem raised it’s head again (2019-03-28) on Tumbleweed 20190325 with KDE Plama 5.15.3:
after a ‘sudo zypper dup’ - all of the programs in the libreoffice suite became unusable.

Upon attempting to start-up anything in the suite (spreadsheet, document, etc.) - the file recovery dialogue would begin (there was a small spreadsheet open when the problem first manifest, and I had tried to insert a column - and in doing so, the spreadsheet crashed, the window closed and the recovery dialogue began).
Every time I tried to start up any program in the suite, the recovery dialogue for that spreadsheet would appear. I could neither ‘recover’ nor ‘discard’ the file - either way, the recovery dialogue would continue - then ‘poof’ disappear with no resulting action. I tried all functions - documents, spreadsheets, etc. - all went through the same recovery dialogue into nothingness.

I tried un-installing and re-installing the libreoffice packages from yast - but this did not fix the problem. I found a forum that suggested the problem might be the relationship with Mozilla - so I tried un-installing and re-installing the mozilla packages, as well. I deleted the ~/.mozilla directory in my home directory. The problem spread to mozilla (firefox), as well.

After un-installing both libreoffice and mozilla packages via yast, I cleared the mozilla cache and deleted the ~/.mozilla directories in my home directories, then removed the entire directories in /usr/lib64/ for both mozilla and libreoffice:

rm -R ~/.mozilla/
rm -R ~/.cache/mozilla/
sudo rm -R /usr/lib64/mozilla/
sudo rm -R /usr/lib64/libreoffice

Then, I reinstalled both the mozilla and libreoffice packages with yast.

Then both mozilla firefox and libreoffice suites went back to functional state. Programs started up clean.
I was asked, when starting up libreoffice, if I wanted to re-configure - I selected the option to restore from last working state. That worked for me.