Libplacebo digest verification failure

Hi all,

I did an update today on my Tumbleweed machine and got this error message:-

Retrieving: libplacebo264-5.264.1-1.3.x86_64 (Main Repository (OSS)) (511/2967), 375.5 KiB
Retrieving: libplacebo264-5.264.1-1.3.x86_64.rpm …[done (350.0 KiB/s)]

Warning: Digest verification failed for file ‘libplacebo264-5.264.1-1.3.x86_64.rpm’
[/var/tmp/AP_0xkpPwq3/x86_64/libplacebo264-5.264.1-1.3.x86_64.rpm]

expected f2e6aa5c0b41f54ffa2dc7761163812d89fd55bbf5d5c503e4e3b2bb0b0989580dfa3baee6eca2682506645f73a816def1c88024a88127d2bd7616a0feac431d
but got dc7054984c9f2754f00dd8cc58e17b180f928b2b11c620bf5601a7ba2f8cce852671f99090446903b43ab00a0fded1039b45a7dbc63fef0a49d6325062a03d8e

Accepting packages with wrong checksums can lead to a corrupted system and in extreme cases even to a system compromise.

However if you made certain that the file with checksum ‘dc70…’ is secure, correct
and should be used within this operation, enter the first 4 characters of the checksum
to unblock using this file on your own risk. Empty input will discard the file.

Is anybody else aware of this?
Is there a fix coming?

Kind regards
Pedro

There is nothing what can be done from openSUSE side. It is either a mirror sync problem, a flaky connection on your side or a real interception in your connection.

Delete the zypper cache and retry the download. If this does not help, either eait or chose another mirror.

I can confirm I am encountering the same problem, and have done so for the past couple of days.
At the moment I will wait it out, until the mirror (http://download.opensuse.org) fixes itself.

Note: It is rare, but this does happen occasionally.

1 Like

I can confirm I also got this error. I guess I’ll just wait it out or wait till the next update

1 Like

I ultimately decided to uninstall the offending package, along with that which depended on it; I took note of these in Kate + saved, along with the correct checksum for lib placebo.

That allowed me to perform the rest of the updates. Afterwards, I checked the suse mirrors for libplacebo, and downloaded a copy of the rpm. I then did a sha512sum to ensure it was correct, which it was and installed it individually. Then, I installed everything which had been uninstalled earlier. A version 4 library for VLC was getting in the way but I set that to downgrade, and everything proceeded smoothly. I’m back where I want to be.

In case of trouble you may get some information on the affected package:

erlangen:~ # curl -I https://download.opensuse.org/tumbleweed/repo/oss/x86_64/libplacebo-devel-6.338.0-1.1.x86_64.rpm
HTTP/2 302 
cache-control: public, max-age=300
date: Thu, 12 Oct 2023 07:24:30 GMT
location: https://mirror.de.leaseweb.net/opensuse/tumbleweed/repo/oss/x86_64/libplacebo-devel-6.338.0-1.1.x86_64.rpm
server: Apache
vary: Accept,COUNTRY
content-type: application/x-rpm

erlangen:~ # 

Here at erlangen download.opensuse.org/tumbleweed currently points to mirror.de.leaseweb.net/opensuse/tumbleweed which exhibits excellent availability and reliability:

Thank you for your reply.

I just tried it again yesterday, and it all worked. Someone must have fixed it at the other end :grinning:

Kind regards
Pedro