Libnvidia-encode.so.545.29.06 hardware encoding fail for nomachine

Hi

The leap 15.5 update to nvidia driver to 545.29.06. via YAST.
But the nomahcine remote desktop can’t enable hardware encoding.

Tried to downgrade to 535.146.02 by init3 by konsole sh NVIDIA-Linux-x86_64-535.146.02.run

but not working …

Any tips for downgrade Nvidia driver ?

Hi,
couldn’t you just boot the previous snapper snapshot and lock the current version of the package to prevent updates?

Thank you for your reply , I have reinstalled the os from opensuse 15.4 to 15.5 to try solve this problem.
unfortunately , this issue existes whether it is 15.4 or 15.5.

Can you describe the problema bit more detailed. You try to connect from an openSUSE machine via NoMachine to some other device and it doesn’t work?

If so what is the exact error message?

Did it work with a different version of the nvidia driver?

What GPU are you using?

I used 15.4 for a long time until arount Nov 12, opensuse auto update the nvidia driver from 535 to 545.29.06.
then the nxmachine only coluld allow connect by software encoding.
well, the software encoding will decrease the performance.

The Nomachine (paid version) engineer found the issue from Nvidia driver updated and they could reproduced the issue on the lab. and the log shows the Nx can’t load the “Libnvidia-encode.so.545.29.06”. then Nx server will start software encoding.

While waiting for hte engineer to check the logs , I installed a new os to 15.5 and Nivida 545 driver and got same issues.

I know nvidia 535.146.02 is ok for me and try command init 3 to command line and sh NVIDIA-Linux-x86_64-535.146.02.run

but can’t completely execute the driver installation.

So with reinstalling, I assume you don’t have any older snapshot left or a cached version of your driver package?

Are you using the nvidia-G06 driver? What exact GPU are you using?

Did you check if the older version of your driver package is still available in the Nvidia repo?

I have two gpu , one is 1050ti , 3060-12g , 1050ti for nomachine Hardware encoding and 3060-12g for stable diffusion and cuda computing .

Befor update the nvidia driver , my system runs well, the nomahcine encoding by 1050ti and cuda computing by 3060-12g …

well , the yast software mananger nvidia-G06 driver has 545 ver only , the nvidia-G05 is ver 470 …

I used h264 hardware encoding by handbreak to compress a video and runs well. but nomahcine engineer insist the incompatibility issue comes from Nvidia new driver. recommand downgrade driver ver or wait for new driver .

Okay. Then it seems that there is no older version kept in the repo.

I tried to check here: https://download.nvidia.com/opensuse/leap/

But in 15.4 as well as 15.5 there seems to be just the version 545 available. 15.3 has still 525 but I couldn’t find version 535.

Also I searched a bit to see if the nvidia repo has some archive somewhere where you could find older versions but without success.

Unfortunately I think I am not able to help you with downgrading your driver as I don’t know where one could find older versions of it. Maybe somebody else does and jumps in, who knows.

Otherwise I think waiting for an update is not the worst advice.

1 Like

@aquinas when you say the run file install failed, in what respect? Did you remove all the old Nvidia rpms and reboot before using the run file? Did you also try the latest run file instead of the rpms?

That’s all I use here, the run file but I’m on Tumbleweed, I just use a Tesla P4 for all the work though, encoding, cuda etc, display card is a T400 which can do it as well, but used for my displays :wink:

1 Like

Try 545.29.02:
https://www.nvidia.com/content/DriverDownloads/confirmation.php?url=/XFree86/Linux-x86_64/545.29.02/NVIDIA-Linux-x86_64-545.29.02.run

Installing 535.146.02: uninstall 545 before install 535.

1 Like

Seems after run file install failed shows installation failed and still in driver 545.
I try to remove all nvidia file and intall nouveau driver by yast …
but run file can’t allow install nvidia driver if sys has nouveau driver.
but if without any vga card driver … can;t load to GUI after reboot.

So if i try init 3 to command line and zypper remove nvidia* then sh nvidia.run file ?

I have been tried uninstall 545 via yast but after reboot can’t load to kde GUI.
I have to uninstall 545 but install nouveau driver , then nvidia run install can’t install if system under nouveau.

do please let me know the steps of uninstall old driver and install new driver ?

To uninstall the drivers you need to follow these instructions (also following chapters to enable nouveau again):
https://en.opensuse.org/SDB:NVIDIA_drivers#Uninstalling_the_NVIDIA_drivers

To install the run file afterwards:
https://en.opensuse.org/SDB:NVIDIA_the_hard_way

1 Like

Thenk you …I will follow the tips and try it.