I am new to suse and would like to know if anyone knows what package I need to install libmysqltcl*.so (* referring to version so could be

I have mysql installed and did a search for libmysql* and nothing.

Any help appreciated.

Tell us why you think you need this. More info please. What are you trying to do.

Running an eggdrop script that requires it.

First login as root and type: find / -iname "libmysqltcl"
If it doesn’t find it then try re-installing Mysql via yast and the tcl/tk librarys.

Yeah, can’t really search for individual lib’s. You should be able to tho imho. The libs are made when you install/compile software. You should be looking for what software makes that library. If it didn’t make you missed something; i.e. didn’t install something that made the lib.

And don’t forget to say your daily prayers to the god known as Google. - Google Search
Debian – Filelist of package mysqltcl/sid/m68k

Yeah, the file list in the second link should give it away…

P.S. Since your new… remember to google the crap out of things before posting.

I couldn’t find what you quote exactly, do you have these](

OK I see mysql but which tcl/tk libraries? Search for which ones?
Appreciate the quick responses.

When I search for libmysqltcl I get No results.

My snapshot is deceiving because I actually searched for mysql
I put libmysqltcl in the search bar after, just as a ref to look at.

I couldn’t find libmysqltcl with the .rpm provides
I was really suggesting you try adding the libs in my shot.

How do I do that?

Well, open Yast - Software Management
search mysql
look at my screen as a ref:

Now click the box by the start of each package, when done, click Accept in the lower right of the screen.

I have all those already installed. I just reinstalled and the file is still not there.

So I Google it

Have done that too… Cant find anything for suse. I run debian on my other box and have the file. Really wanted to try suse.

I’m not sure where you should go from here. It’s not something I would even need myslef. I should keep at the Google search. Don’t just give in.

Even easier… Yast>SWM>Filter:Patterns>TCL/TK Development

The checkbox should be all the way at the bottom.

Thanks will look at that but I just copied the file over from my debian box.

hehe… let me know if that works…

worked fine :slight_smile: