libm.so.6 (GLIBC_2.29)(64-bit) required for updates.

Hi there,

I’m running Leap 15.2 and it works just fine.
But the auto-updates fail with needs / requires libm.so.6 (GLIBC_2.29)(64-bit).

Yast can’t find it…

RPM either.

It wants to do 17 updates, but bails.

Anyone know where I can find this package? I’ve had a look around, but can’t find anything for Leap 15.2.

Since everything is otherwise fine - maybe just turn off the updates and wait for 15.3?

Can I force the updates - well actually I did try that and it came back with the same problem.

Cheers

When you want to update your openSUSE 15.2 ,just run (as root)

zypper up

When that gives problems, then please copy/paste that as a whole (including the prompt-command line and the complete output) in a post here between CODE tags (that is the # button above the post editing field).

But the auto-updates fail with needs / requires libm.so.6 (GLIBC_2.29)(64-bit).

So the Question is:
What packages want to use this lib, this lib is not in the standard Repos:

rpm -q --provides glibc | grep -i libm
libm.so.6()(64bit)
libm.so.6(GLIBC_2.15)(64bit)
libm.so.6(GLIBC_2.18)(64bit)
libm.so.6(GLIBC_2.2.5)(64bit)
libm.so.6(GLIBC_2.23)(64bit)
libm.so.6(GLIBC_2.24)(64bit)
libm.so.6(GLIBC_2.25)(64bit)
libm.so.6(GLIBC_2.26)(64bit)
libm.so.6(GLIBC_2.4)(64bit)
libmvec.so.1()(64bit)
libmvec.so.1(GLIBC_2.22)(64bit

Please post also:

zypper lr -d

https://pkgs.org/download/libm.so.6()(64bit)

With Leap 15.2 you get glibc 2.26, not more.
IMHO you are trying to use packages for TW - use those for Leap 15.2 instead.

https://forums.opensuse.org/showthread.php/545893-Need-glibc_2-27-to-run-a-new-applicationss-!!?p=2974153#post2974153

Possibly you may manually add this file.