libgcj.so.9 error when installing app

I would like to install pdftk on opensuse 11.2 using the 1-click option found on the site.

However, the system provides an error saying that libgcj.so.9 is needed.

How can I solve this?

Ivan

Hi
You need to install libgcj43 :slight_smile:


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 13:34, 3 users, load average: 0.24, 0.12, 0.10
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

libgcj44 is installed by opensuse 11.2. But this doesn’t resolve the error.

Hi
It’s compiled against gcc43 not gcc44 which is the 11.2 default. 44
contains libgcj.so.10 not libgcj.so.9.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 16:17, 3 users, load average: 0.18, 0.15, 0.07
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Tx. What would be the best solution to solve this? Downgrade that package or trying to compile pktf from scratch? (I’m no expert in those things).

Hi
libgcj43 and libgcj44 should co exist without issues. Install them both.


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.27.37-0.1-default
up 17:12, 3 users, load average: 0.39, 0.58, 0.31
GPU GeForce 8600 GTS Silent - CUDA Driver Version: 190.18

Tx. Solved.

Thanks for the heads up.

A) What one-click option? I can’t believe the home:aljex repo is part of any one-click repo?

B) Be my guest and try to compile pdftk against gcj44.
The upstream source has not been updated since 2006 and gcj has changed in some way since then such that, in gcj 4.1 pdftk compiled with no warnings, in gcj 4.3 it compiled with a zillion warnings but it compiled, in gcj 4.4 it no longer compiles.

So either gcj is broken or the pdftk source needs a major overhaul.

That is why it is built against gcj 4.3 specifically.
It’s not ideal, but it’s either that, or do not upgrade beyond opensuse 11.1, or live without pdftk.

I just updated the spec in my package to require libgcj43 if opensuse version is 11.2 or higher.

It should pull in the required libraries automatically when you install the new rpm. The new rpm may take a while to get built. The OBS seems to be pretty busy rebuilding large chunks of Factory all day today.
In the mean time, just:

“zypper in libgcj43”

And you should be fine. It doesn’t conflict with the more current version or anything.

Hi, i have a similar problem.
I want to install the pdftoolkit with
rpm -Uvh pdftk-1.41-102.6.i586.rpm
It complains with a missing libgcj.so.9
I did a
rpm -Uvh libgcj41-4.1.3_20080612-26.5.i586.rpm with the following

warning: libgcj41-4.1.3_20080612-26.5.i586.rpm: Header V3 RSA/SHA256 signature:
NOKEY, key ID 3dbdc284
Preparing… ########################################### [100%]
1:libgcj41 ########################################### [100%]

Now, i think that the rpm is installed, but I can0t find the libgcj.s0.9 nowhere.
in /usr/lib i find libgcj.so.7

Anyone has any idea ?
Os is a SLES 11.1

On 2012-02-13 13:06, mdurbach wrote:
>
> Hi, i have a similar problem.

This is a thread from 2009. Are you sure you want to post here?

> Os is a SLES 11.1

Then you have to ask in the SLES forum, this is an openSUSE forum.


Cheers / Saludos,

Carlos E. R.
(from 11.4 x86_64 “Celadon” at Telcontar)

On 02/13/2012 01:18 PM, Carlos E. R. wrote:

> ask in the SLES forum

-=WELCOME=- new poster, but Carlos is correct, you need to post to here:
http://forums.suse.com/

the ID and password here and there is the same…but, the software
discussed is not…many folks here have never run (or even seen) SLE_
products and are unqualified and unprepared to give competent assistance…

however, if you wanna hang out and see if you get a tidbit that works
(and does no harm) you are welcome!


DD http://tinyurl.com/DD-Caveat http://tinyurl.com/DD-Hardware
http://tinyurl.com/DD-Software
Read what Distro Watch writes: http://tinyurl.com/SUSEonDW