libgalago building error: E: shlib-policy-name-error (Badness: 10000) libgalago3

libalago almost built but failed at the end with this error. I’m sure it’s easy to fix (?). Should I bypass rpmlint check? (don’t remember how).

The name of the package should be libgalago3 instead of libgalago.

I would have to name it libgalago3 if 0%{?suse_version} > 1140 and libgalago otherwise (not to break dependencies in other 11.4 and 11.3 packages).

What package depends on the package name “libgalago”??? Anyway that’s what provides/obsoletes are for: openSUSE:Package dependencies - openSUSE

Actually, the program that I’m using the most (after vim): gossip, a very simple jabber client. I’m perfectly aware of the alternatives (that I install and set up on all desktops btw) but I don’t like to use them myself. It won’t probably build for other reasons, because the gnome-panel is missing. But I got it compiled a while ago on Fedora 15, which is already using Gnome3 and dont have the panel … So it might be possible - I guess I disabled the notification applet or something that needed the panel.

It requires “” or “”, not “libgalago”, the gossip package doesn’t care about the galago package name. You can (and should) rename it to libgalago3 for every openSUSE version without any problem. For some reason it only complains in 12.1, but “libgalago” is the wrong name since was created a loooooong time ago.

Well, I managed to build libgalago in a manner you won’t like. But a similar or even worse hack - that allowed me to build galago-daemon in previous releases - doesn’t help for 12.1.

galago-daemon.i586: E: suse-dbus-unauthorized-service (Badness: 10000) /etc/dbus-1/system.d/galago-daemon.conf
The package installs a DBUS system service file. If the package is intended
for inclusion in any SUSE product please open a bug report to request review
of the service by the security team.

I’m aware of the signification of this … but nobody is going to use this product nor fix this package - I think. So how come this filter is ignored while trying to build for 12.1? (and it there a possibility to use it after all?).

Just set the badness to zero with rpmlintrc.

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.4 (x86_64) Kernel
up 4 days 0:59, 5 users, load average: 0.10, 0.18, 0.23
GPU GeForce 8600 GTS Silent - Driver Version: 290.10

Hi Malcolm,
Yes, that will be the next thing to try. However, it doesn’t explain why it caught the error but didn’t apply that filter (for 12.1 only).