and Salome3.2.6

I am trying to install OpenCascade salome 3.2.6 ( on my computer running OpenSUSE11.
The geometry creation module runs ok, but when I switch to the mesh module, the programme issues a missing library warning. Cannot locate library
I searched the repository and found libg2c33(3.3.3), I installed it and now I can access the mesh module but there are now two new missing libraries (They are already installed but the programme cannot locate them.
I guess it is a library version conflict.
Can any one help me find this
By the way, this is part of the GNU fortran compiler
Appreciate your time and help

What two libraries can’t it find? 32bit or 64bit system? What is your
configure options? is installed in /usr/lib or /usr/lib64 for a 64bit system.
You may need to add the option --libdir=/usr/lib or /usr/lib64

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 3:14, 2 users, load average: 0.47, 0.19, 0.11
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

Thank you very much for your reply.
My configuration is 32 bit.
Here is the message printed when I run the programme

linux-csfu:/home/ahmed # ./salome326
Configure parser: Warning : could not find user configuration file
Searching for a free port for naming service: 2810 2811 2812 2813 - OK
Lancement du Naming Service > /tmp/logs/root/salomeNS.log 2>&1
Searching Naming Service + found in 0.1 seconds
Searching /Containers/linux-csfu/FactoryServerPy in Naming Service +++++++ found in 3.5 seconds
Searching /Containers/linux-csfu/SuperVisionContainer in Naming Service +++++ found in 2.5 seconds
Searching /Kernel/Session in Naming Service ++++++++++++ found in 6.0 seconds
Start SALOME, elapsed time : 13.3 seconds
additional external python interpreters: 0
linux-csfu:/home/ahmed # SetSignal( Standard_False ) is not implemented…

  • Warning: library Component cannot be found
  • Module will not be available

  • Warning: library PyCalculator cannot be found
  • Module will not be available

what is confusing me is that these two libraries are part of the installed programme and they are located in KERNEL_3.2.6/lib with the rest of libraries used.
One last point, when the programme is installed, it creates a file with all the environment variables and I source this file each time I run the programme.

I really appreciate your reading my post

So you compiled as the root user? (linux-csfu:/home/ahmed #) I have
downloaded the src file and am attempting to compile, I have
openCASCADE installed but it is unable to find the CASROOT can you
advise how you set this. Could you also copy and paste the contents of
the file?

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 7:21, 2 users, load average: 0.00, 0.06, 0.22
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

No, I did not compile from the source files. I down loaded the RedHat package (It has the source files too) (Both RedHat and SUSE are package based distros, I read that somewhere but I do not know what it means ). when you untar this package, check the readMe file. Now to install the programme, there is a python script runInstall, when you start it, you have the option of installing from source code Or install the binaries. The first time I tried to install from the source files, it gave me a ton of red warnings/error messages, so I installed the binaries and here I am trying to figure out why the programme can not find my configuration file.
The file is created during the installation, I have no problem sending you the one created on my computer, it is just I do not know how. It is 8 pages (A4 size), I printed it and went through it line by line, and though I am not a Linux expert, I can see there is not a single wrong declaration of the environment variables.
Do you know why the programme cannot locate my configration file (The first line in the previous error message ?)
Please keep in mind that I am not a Linux guru/expert, so if I say something silly please tell me.
Hope this can be sorted out. It is a great multiphysics programme simmilar to Ansys Work bench and it is developed and used by the French Authority for Electric power.
I hope the people at OpenSUSE can include it in their next release,
Thank you for your interest and wish good luck for all

One last point:
The open cascade or any other library that is needed, are included in the package,e.g. under salome_3.2.6/CAS-6.2 etc.

It is my own computer, so I am the super user and single user. I just turn on the machine and that is it, hope that helps

Bug 1 - Suggested list of packages for science

Since Andrea Florio has already packaged OpenCASCADE I don’t expect too much problems packaging SALOME.
The “Warning: library XXXX cannot be found” messages are explained by Google.

Thanks for that :slight_smile: The standalone one works fine, hopefully they will
add Salome and openCASCADE is also in the packman repository.

@ rhoahmed, if you didn’t google it, those two are not available in the

Looking at the requirements and getting it to configure, there are
errors which are probably related to gcc 4.3 so it may be a while
before it may appear in the education repository…

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 1 day 21:06, 2 users, load average: 0.37, 0.30, 0.29
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

I have two reasons to cry “Eureka”
1- I have evidence that The OpenSUSE community/forums are alive, you post a query and you get an answer
2- I checked the scientific repository list and I see that you already were planning to include code Aster, Salome is the geometry/mesh generator and post processor for both Code Aster ( a finite element solver) and Code Saturne ( a CFD solver).
So warm congratulations on that, just complete the trio (Salome, Saturn & Aster ) and I believe that one of these days I will put a note on the CFD OnLine forum (The least I can do). EDF is planning to have the three released as one platform Salome Meca.

Thank you very much

Malcolm, you can create email account with hotmail or similar, put it here and I will send you the file.

I have it working fine now since I downloaded the redhat version. I do
note it creates a salome_appli_3.2.6 directory you can run it all
directly from there so you don’t need to source the sh file…

Cheers Malcolm °¿° (Linux Counter #276890)
openSUSE 11.0 x86 Kernel
up 2 days 0:19, 1 user, load average: 0.15, 0.20, 0.25
GPU GeForce 6600 TE/6200 TE - Driver Version: 177.80

That is good news, you know, if you ever get tired of the IT business, you can start a career as a mechanical designer, you have one of the powerful tools available at your disposal (Salome/Aster) Thanks to Electricité de France.
here is the web address to a starting tutorial:

Good luck and thanks for the tip

Hi Malcolm
Please check this address

Open Source Revisited