libcurl curl_easy_setopt configure error only on 11.2


I tried my first obs project and I’m stuck in weird configure problem with libcurl. On 11.1 and 11.0 the spec file works fine, but with 11.2 it can’t finish the curl-config part. Funny thing is it works on my 11.2 x86_64 machine at home if I try it as root. With “obs build openSUSE_11.2” in a shell a friend tried, but received the same error as in the build system.

So, the question is for me, why doesn’t it configure with libcurl now? Has something changed from 11.1 to 11.2?

For the same spec file I get:

on 11.2:
checking for curl_easy_setopt… no
configure: error: cURL 7.1.1 or newer required (cURL is available from cURL and libcurl)

on 11.1:
checking for curl-config… curl-config
checking for curl_easy_setopt… yes
checking for curl_easy_strerror… yes
checking for cURL SSL support… yes

Index of /repositories/home:/uebelhacker/openSUSE_11.1

Thanks in advance,

Probably it will be fixed with “export SUSE_ASNEEDED=0” as explained at Packaging/Fixing - openSUSE

But if SUSE_ASNEEDED fixes the problem there is a bug in the configure script that should be fixed and submitted upstream.