problem with rpm (alien)

Hi all! I would like to install a tool that doesn’t has an rpm version, so I downloaded the .deb version, converted with alien and tried to install.
The installer says that is missing. I don’t think that’s true because I installed ffmpeg, and so many codecs… is it possible that there are problems with libavcodec location being the package originally a .deb?

Likely the codec version, what is the output from;

zypper se libavcodec

You may need a symlink to the version that is installed. Install mlocate, run

sudo updatedb

If there is one with a higher version number behind the so, create a symlink to the .so with the name, it should not complain anymore.
But, are you sure there’s no rpm?

Agree that maybe an RPM build exists for your tool…

I wrote the following Wiki describing several ways I recommend for finding files and apps… Although I didn’t mention converting a DEB, I do mention as one of the last options finding the source and compiling it.


Thank you all guys, but i have another problem now: i can’t boot Opensuse because grub doesn’t show it. I’ve opened another thread, when i will solve this problem i will try your solutions :frowning:

S  | Nome                         | Sommario                         | Tipo     ---+------------------------------+----------------------------------+----------
   | ffmpeg-2-libavcodec-devel    | Development files for FFmpeg's-> | pacchetto
   | ffmpeg-3-libavcodec-devel    | Development files for FFmpeg's-> | pacchetto
   | ffmpeg-4-libavcodec-devel    | Development files for FFmpeg's-> | pacchetto
i+ | libavcodec56                 | FFmpeg codec library             | pacchetto
   | libavcodec56-debuginfo       | Debug information for package -> | pacchetto
i+ | libavcodec57                 | FFmpeg codec library             | pacchetto
   | libavcodec57-32bit           | FFmpeg codec library             | pacchetto
   | libavcodec57-32bit-debuginfo | Debug information for package -> | pacchetto
   | libavcodec57-debuginfo       | Debug information for package -> | pacchetto
i+ | libavcodec58                 | FFmpeg codec library             | pacchetto
   | libavcodec58-32bit           | FFmpeg codec library             | pacchetto
   | libavcodec58-32bit-debuginfo | Debug information for package -> | pacchetto
   | libavcodec58-debuginfo       | Debug information for package -> | pacchetto

That’s the output :slight_smile:


That is the output for the “locate” command… how can i create a symlink? Thanks!

The tool is I’ve tried to find it in many differents ways, but i didn’t find rpm packages nor source code :’(

In the /usr/lib64/ directory i used these two commands

sudo ln -s
sudo ln -s\(\)\(64bit\)

…but nothing, i continue to have the same error…

All pretty straight forward…

This is all in my $HOME directory on Leap 15.1 and all as my user;

mkdir -p Visual
mv visual_1.27-1_amd64.deb Visual/
cd Visual
ar -x visual_1.27-1_amd64.deb

control.tar.gz  data.tar.xz  debian-binary  visual_1.27-1_amd64.deb

tar xf data.tar.xz

control.tar.gz  data.tar.xz  debian-binary  usr  visual_1.27-1_amd64.deb


Oct 27, 2019 6:12:28 PM java.util.prefs.FileSystemPreferences$1 run
INFO: Created user preferences directory.
Reconfiguring logging...


Screenshot from 2019-10-27 18-13-00.png

Note: Only default oss/non-oss and update repos added and libavcodec57 installed only.

Perrrrfect, i followed your commands and all wark without any problems… the only problem is that i’m obviously stupid because it was simple (i suppouse) lol!
Can you explain what i did? I simply “unpackaged” the .deb package?

Not sure, but you used alien to convert the deb file :wink: I think it doesn’t have the logic sometimes…

There are some folders the application is looking for, perhaps the never made it to the correct place…

Sometimes easier to install/run as your user, probably with some additional foo a spec file could be created to install as an rpm, but alien would not be able to do this.

If you copy the usr/share/applications/VisUAL.desktop to ~/.local/share/applications directory and then manually edit the paths to point at the script and icon it will appear in your desktop menu system;


\It does need to be the full path…

I should read your message first this morning… i spend much time to create a working menu link with icon… i just used “~/”, and after many tries i knew that it wants full path lol!
Have a nice day!