Lexmark z517 z600 z510 printer howto

I’m a new opensuse user, and I’ve got a lexmark z517 colour printer, that works correctly on my ubuntu, but it was a tough job to make it work on opensuse, because of the rarely support of this printer, but I found some howto-s, and with a little correction, I managed to install the driver, I share my solution to help people with this printer. This is it:
How to install Lexmark Z517 printer on openSuse 11.1

The driver for lexmark z600 should be good for z517 also, so I searched for driver for z600.
I found a little manual at The Lexmark Z605 printer and SuSE 9.3, a little HOWTO, but it didn’t work with my system. So we need a little makeup.
Before you enter the method, you should install libstdc++ from the package manager, because the printer driver will miss it.

Then you can start it:

Download the rpm2targz utility to your home directory, open a console and unpack it:

bunzip2 rpm2targz.tar.bz2

  • Install it as root:

cd rpm2targz
(maybe you get some errors, but don’t mind it)

  • Download the Lexmark Z600 driver in for example a lexmark directory in your home folder.
  • cd into your lexmark folder
  • su to root and unpack the driver package:

tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz

  • Extract the actual driver:

tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz

  • Untar install.tar.gz you just created:

tar -xvzf install.tar.gz

  • Convert the RPM’s you just created to tarballs:

rpm2targz *.rpm

  • Untar the two tarballs:

tar -xvzf z600cups-1.0-1.i386.tar.gz -C /
tar -xvzf z600llpddk-2.0-1.i386.tar.gz -C /

  • Run ldconfig:


  • cd to the backend directory and try out the printer:

cd /usr/lib/cups/backend

  • Under SuSE 9.3 the output should be:

direct z600:/dev/usb/lp0 “Lexmark Lexmark Z600 Series” “Lexmark Printer”

If you are ready, connect the printer via USB, then open the printer manager, maybe you find it in System/Hardware or something.

well done; thanks for this;

lexmark inkjet printers have not had a lot of linux support: their laser printers seem to have more support offered;

If you go here

OpenPrinting database - Printer: Lexmark Z517

it is described as a paperweight, and you would help the linux community if you edit this and describe how you got it working

One question though arises.

Why do you create RPMs (which makes perfect sense for an RPM-based distro) and the moment you have them, you convert them back to tgz?

Makes no sense to me, why not install the RPMs?

(If the RPMs are sane, this would also make the ldconfig-step obsolete.)

And another very bad move:

  • su to root and unpack the driver package:

I don’t think doing this as root will be needed. Double check this, if it does not need root privileges to unpack a tarballe (which is the normal case, I never had a tarball which needed to be unpacked as root), then don’t use root for that.

I am pretty sure, root will be needed for only one step, installing the drivers and that’s it.

Well, I’ve just installed openSuse yesterday, I tried to install those rpms given, but it failed with some errors, so i had to find an other way to install.
I tried to do it from here OpenPrinting database - Printer: Lexmark Z517 , but it didn’t work.

Being a little more precise on what those errors actually were and what exactly did not work would help.

(I have an idea what it might have been, but rather prefer facts over wild guessing.)

Well, i can’t paste the outputs, because it was my mother’s machine, and i’m not at home now, but first i tried to install the rpms with the package manager, z600llpddk-2.0-1.i386.rpm package had been installed correctly, but the z600cups-1.0-1.i386.rpm package returned with errors, but i cant remember what it was, maybe it had problems with cups.
Thanks for your help.

So there are two possibilities now, at least if one assumes the most likely “error” when installing the package via RPM, which would be “missing dependencies”.

A) The packages themselves are not build well and search for an obsolete or non-satisfiable dependency (due to the same dependency having another name on openSUSE than the one being marked as required in the RPM)

B) The packages themselves really need this dependency and it has to be satisfied to make the driver run correctly

Neither A) or B) can be solved by not using RPMs, you just circumvented them, in case of A it is not of bigger concern (but could be fixed easily), in case of B) this most likely will bite you the moment a function of the driver package calls for functionality provided by a requirement not installed.

What you installed will remain completely unknown to your package manager and therefore you might run into trouble if anything related to the driver is changing while it would be most likely detected by RPM.

I have tried to download the rpm driver files but, the CUPS rpm returns a ‘File not found’. Can this information be updated to make it more useful.

This is not a very useful forum. Is it?

You may find that the forums are of greater use by looking around. The absence of replies to your query should not be interpreted as a metric for the quality or value here.

As to your query, Lexmark printers are almost renowned for the dearth of Linux support and drivers. I have three (3) Lexmarks (from 2003, 2005 and 2007) acquired with Windows PCs. I have been able to get these to run under Ubuntu (marginally well) using the same materiel you referenced earlier. Attempts to get these to work under openSUSE (and Fedora) have been quite unsuccessful. Each attempt gets to the CUPS stage and aborts with different error messages: some dependency problems, some “File not found” and some directory problems.

My immediate solution has been to print to a -PDF file in a “Printing” folder, and send same to a PC with Windows or Ubuntu to print. This technique, on its surface somewhat rudimentary, has the benefit of printing almost anything on an inkjet, a photo-ready or a laser without concern for the specific printer type(s). I selected the PDF approach over .ps (postscript) due to the Windows/XP abilities with .ps files.

My objective is to acquire a networked printer supported by openSUSE and Windows/XP, with Windows/7 and Ubuntu support as a bonus. I have not, as yet, reached Linux-printer nirvana, but failing a deus ex machina announcement, the new printer(s) will NOT be Lexmark.

Thank you for your reply.
I must admit to being over critical about the forum (frustration), which I now realise is just a bunch of people trying to help each other. I was ready to expect a quick and succinct answer to my problem, after all I had very quick and successful solutions whilst using Ubuntu and later Debian but, Suse has thrown me a wobbler.
I shall persevere.

There is only so much a man can bear. I have tried different drivers and forums and think this is just a lost cause. It’s time to go back to Debian.

*This thread has been residing in my in-box/to-do list for longer than usual. Refer to post Lexmark z517 z600 z510 printer howto for my printer array. I decided to ramp up efforts since one of my non-profit/pro bono clients has the same printers, and (sadly) a lack of funds for replacement.

After a long battle with a Lexmark P3150 (P3100), I finally got this working on Ubuntu. openSUSE had problems recognizing the P3150 (I do not know why, nor care any more), so I hooked up a Lexmark X1150 (also an X1100), which also worked on Ubuntu, and, lo and behold, openSUSE recognized it!!! So, on with the saga.

As expected, oS could not find a driver, so I resurrected the instructions (The Lexmark Z605 printer and SuSE 9.3, a little HOWTO) and started again. First problem was getting the proper driver (“CJLZ600LE-CUPS-1.0-1.TAR”). Although I already had copies of this driver, I found a new link:

[CJLZ600LE-CUPS-1.0-1.TAR.gz - 4shared.com - online file sharing and storage - download](http://www.4shared.com/file/21rJhN4O/CJLZ600LE-CUPS-10-1TAR.html)

to get the driver. The second link (for “rpm2targz”) is still valid. The last link (GenToo) is dead.

First, install “rpm2targz” from the file downloaded to your home directory:

  1. bunzip2 rpm2targz.tar.bz2

  2. tar -vxf rpm2targz.tar

  3. su (Install as root, NB: NOT “su -”)
    cd rpm2targz

NOTE: The above procedure(s) use “gcc”. Make certain it is installed (YAST–>Patterns–>Development or just install “gcc”).

Also required is “libstdc++5” (libstdc.so.5) 32-bit. (Install package “libstdc++33”).

Next, install the driver:

  1. exit”, to get out of “root/superuser” priveliges.

  2. mkdir lexmark

  3. cd lexmark

  4. Download the driver

  5. su to root and unpack the driver package:

    tar -xvzf CJLZ600LE-CUPS-1.0-1.TAR.gz

  6. Extract the actual driver:

    tail -n +143 z600cups-1.0-1.gz.sh > install.tar.gz

  7. Untar install.tar.gz you just created:

    tar -xvzf install.tar.gz

  8. Convert the RPM’s you just created to tarballs:

    *rpm2targz .rpm

  9. Untar the two tarballs:

    tar -xvzf z600cups-1.0-1.i386.tar.gz -C /
    tar -xvzf z600llpddk-2.0-1.i386.tar.gz -C /

  10. Run ldconfig:


  11. cd to the backend directory and try out the printer:

    cd /usr/lib/cups/backend

NOTE: In the original documentation, the following message was suposed to be displayed:

direct z600:/dev/usb/lp0 "Lexmark  Lexmark Z600 Series" "Lexmark Printer"

I could not get this message. If you do not get an error here, the driver is installed! Install the printer in YAST, and point to the driver just installed.

NOTE: When you get to the end of the YAST install, make certain that the box labeled “Enable Printer” is checked!!! (I wasted a lot of time here, as the default is not checked!).

The above worked for me. If you have issues regarding shading or alignment offset, refer to https://help.ubuntu.com/community/HardwareSupportComponentsPrinters/LexmarkPrinters.

Good luck!

Post edit-timeout threshold addition:

Though the extracted rpms could be installled as packages via YAST, attempts to do so gave a dependency problem in the z600cups package. Specifically, a dependency of cups. was unresolvable. The above procedure does install a working driver.