Lexmark 3200 Driver

I was fairly disappointed to discover that OpenSUSE 11.0 doesn’t seem to have a driver for the Lexmark 3200. I’ve previously used SUSE 9.2 and 10.1, and both properly detected my printer and had the driver necessary to use it.

After a few false starts, I found a solution! If you also own a 3200 and are having problems with 11.0, try the following. Please note that I’ll be suggesting that you skip some information that I felt was irrelevant to my own installation. If you feel it’s important to read everything, I cannot argue with that!

Go to OpenPrinting database - Driver: lxm3200-tweaked – the page dedicated to “OpenPrinting database - Driver: lxm3200-tweaked”, and OpenPrinting/Database/CUPSDocumentation - The Linux Foundation – the “OpenPrinting/Database/CUPSDocumentation” page, each in separate windows. Both Tinyurl links redirect you to the pages (described above) at OpenPrinting - The Linux Foundation aka Main Page - The Linux Foundation.

I’m pointing you to the CUPS information because, when I originally attempted to use YaST to install my printer, it automatically launched the CUPS server – I’m assuming anyone else trying this will have the same experience. If that’s not the case, I’m not sure what to tell you. ^.^;

In the first page (“Driver: lxm3200-tweaked”), scroll down until you see

Select printer: [Lexmark 3200] [Generate PPD File]
[X]download ]display the PPD file
]GUI texts limited to 39 characters

Select “Lexmark 3200” from the dropdown menu (as suggested above) and the “download” option beneath that, then click the “Generate PPD File” button and save the file to someplace you can find it. :wink: If you’re interested in the nuts and bolts of the driver, you can use the “Show execution details” in the next section. Otherwise, you’re done here and can shut down the window – though you may wish to bookmark it first, for future reference!

Now go to the “OpenPrinting/Database/CUPSDocumentation” page, and skip directly to Step 2: “Install a PPD file” and scroll past all the “If you” instructions. What you’ll do next is based upon the paragraph beginning with “Save the PPD file in the directory…”

Find the PPD file in the directory into which you downloaded it – it will be named “Lexmark-3200-lxm3200-tweaked.ppd”. Move it into the directory /usr/share/cups/model/Lexmark – you’ll probably need root access to do this.

Next is Step 3: “Restart the CUPS daemon.” Log in as root and enter the command “/etc/init.d/cups restart”. You’re now finished with the “OpenPrinting/Database/CUPSDocumentation” page, unless you want to read it more thoroughly later.

Make sure your printer is connected to your computer and is powered on. Then launch YaST and select Hardware -> Printer. Your printer should be detected and listed as “not configured”. click “Configure”, and then in the next window, select the “Basic Settings” tab. The “Model Name” field should already be filled in with “Lexmark 3200”, and the “Driver” field should display “Lexmark 3200 Foomatic/lxm3200-tweaked (recommended) (Lexmark/Lexmark-3200-lxm3200-tweaked.ppd)”. If this is not the case, you’ll probably want to revisit all previous steps to this point.

If the Model Name and Driver are both good, click “Next”, which will send you back to the first configuration page. Click “Print test page” and follow the instructions, and if it does indeed print, you’re set! Click “Finish” then exit YaST, and happy printing!

I should note that I’m absolutely not an expert of any sort – I just happened upon this solution, and used a little intuition, and it worked out. I guess what I’m saying is that maybe I’ve created some kind of problem that I won’t discover 'til later, but I suppose that’s a risk.

I hope someone else finds this information to be useful!


Thank you for sharing your solution.

Thank you.
I have a HP Deskjet 5740 printer, that is not directly supported in Suse 10.3 (was supported in 9.2). I have used Deskjet 5550 driver that was a bit unsatisfactory. I applied the instructions you gave and now I have the correct driver. I added and installed the driver with Yast as I am not that familiar with CUPS administration interface.