Lenovo Yoga 900-13ISK2

Hi, I’m trying to install latest Leap 42.1 version in my Lenovo Yoga 900-13ISK2 Signature Edition, and installer can’t see the disks at all. I also tried releasing a partition from Win, but it just can’t see the whole disks.
There’s a related topic in Lenovo’s forum at https://forums.lenovo.com/t5/Linux-Discussion/Yoga-900-13ISK2-BIOS-update-for-setting-RAID-mode-for-missing/m-p/3341798/highlight/false#M7835

Any ideas will be really welcome.


You haven’t provided much information about how your system is set up, but assuming typical Windows OEM installs, I’d recommend

  • AFAIK there is only one boot exploit known to be in the wild, and that was detected in a LAN, not out in the Internet. So, you can decide whether you really need secure boot (which typically is recognizable by not being able to access the BIOS on boot with a key combination). Until now (I haven’t personally decided to change yet), I’ve been disabling secure boot. To do this, within Windows you have to find the Advanced system setting to reboot into BIOS and recovery options. Without secure boot, life is simpler.

  • Like any other OS installation, the openSUSE install will look for free, unformatted space and automatically offer to install into it. I typically run Gparted Live to re-size any existing partitions and move to the front as far as possible.

  • The default openSUSE install requires 3 partitions for the default layout (swap, root, home). If your system is currently set up using GPT(most likely), then number of partitions is not an issue. If for some reason your system is set up with the older MBR, you will be limited to 4 primary partitions and your existing Windows will already be using at least one. You may decide to configure an extended partition containing logical disks within one of your remaining Primary partitions to support a larger number of partition-like devices. If you have to set up an extended partition, Gparted Live can do that for you, remember to leave the logical disks unformatted. You might also need to select the “Advanced” option during the openSUSE install to fit the recommended layout into the partitions and/or logical disks you have pre-created.

After you have addressed the above, your openSUSE install DVD or network install should work without a problem.



Thanks for your answer. It’s true there’s not too much info. That link I added points to a site where tech guys are commenting the details, that I don’t understand.

For me, I just see that the installer can’t see the HD at all.

I tried releasing space in the disk using Windows itself, and there’s a “free” partition space now. But, anyway, the installer just can’t see the whole disk.

There should be issues with the required partitions later, but I’m not there yet :frowning:


Just read the thread on the Lenovo forums, and it seems not much to do. Really concerning a laptop manufactorer ships a machine you cannot install anything on! (from what I read not even a clean Win 10 install?) If I were you I would return the machine if it is still possible, and look on Google before you buy the next laptop to ensure it has Linux compatibility, or you could wait to get a BIOS update, but not guaranteed I would expect.