Lenovo y570 randomly shuts down when working on battery

I have Lenovo Ideapad y570 with opensuse 12.3 with gnome installed on it. Sometimes when working off battery it suddenly turns off. No error messages on the screen, no nothing. How can I diagnose what happens?

What power management settings have you checked? e.g. profile for battery operation.

The only things I checked are some power settings in gnome applet:
On battery power:
Suspend when inactive for 10 minutes
When power is critically low Hibernate
And also full brightness, turn screen off when inactive for 5 minutes and lock settings.

I don’t think these settings have something to do with that because my notebook doesn’t hibernate, it just turns off and also the battery wasn’t critically low. However when my notebook is charging, it sometimes shows a warning that battery is critically low and that it may hibernate soon (while actually it’s charging at 60% or something) but it never actually hibernates because of that.

Maybe not, it’s useful info for helpers so thanks for providing it. I’m not sure I will be able to fix your problem, although my notebook is a Lenovo ThinkPad model with Ideapad firmware. I mainly use KDE.

That has resulted in a few things e.g. suspend not working with openSUSE/Linux for all users with that model. Because it remains suspended in a perpetual coma, a power-button reset resulting in a power-on restart is required. This means I have to change profile settings away from any action to suspend. Apparently a BIOS update was supposed to fix it, but others reported on the internet that it hadn’t worked, so I haven’t. However, hibernate has worked now for many openSUSE releases. KDE occasionally notifies me on start-up that my battery is faulty, and has zero charge, it is not correct but may not be KDE’s fault.

Just to be clear, does your notebook suspend automatically and also by command i.e. lid closure or function key, and can you reactivate it normally?

Yes, it suspends when the notebook is closed, it suspends if I use suspend button in gnome. It usually wakes up from suspend ok however today once after waking up there was just black screen, ctrl+alt+f1/f2/…/f7 and ctrl+alt+backspace didn’t work. I tried to replicate that but it woke up ok every time after that.

From the black screen, how did you recover the system? BTW for hibernate to work you need a swap partition available, you may already know that. :slight_smile:

From the black screen I had to hold power button to turn computer off. I know that I need swap for hibernate and it’s hibernation is working for me.

Try some coffee https://extensions.gnome.org/extension/517/caffeine/

From what I can find on the net this seems to be an Optimus system, can you give us the output of this command.

/sbin/lspci | grep VGA

Yes, it is.

00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)
01:00.0 VGA compatible controller: NVIDIA Corporation GF108 [GeForce GT 555M] (rev a1)

Could you please give an alternative for KDE. I decided that gnome is not very good and switched to KDE.

Also I don’t really see how that could help. It is unlikely that my notebook tried to suspend or sleep while I was browsing internet on it. Yes, it turned off while I was working on it.

Proposed that since i read the below line. I am not too familiar with KDE.

                                               I have Lenovo Ideapad y570 with opensuse 12.3 with gnome installed on it.