Lenovo X220t running openSuSe 13.2 shuts down uninvited

From time to time, over the last 6 months or more, I’ve found that I return to the machine after an interval of hours away (sleeping, or at work) to find it has rebooted. Is there any obvious explanation for this? I do update the software regularly. I’ve also, twice in the past month or so, had the experience of the machine slowing down and the mouse developing a mind on its own, as if someone else were in control. Most disconcerting (on those occasions I have immediately rebooted). Thanks

the mouse developing a mind on its own, as if someone else were in control.

I suppose that is a possibility, but I doubt it. Is it a wired USB mouse? I have often found that they go nuts at times and – as you describe it – seem to move around as if they have a mind of their own, in 13.1 and 13.2, KDE. Funny thing is, the wireless USB mouse does not have this problem at all.

I suspect it has something to do with another tendency I have noticed among the wired USB mouses: If you poll the ports, you will see that they seem to jump around in their /dev/ assignments.

I have observed this behaviour on several machines.

As for the other problem, rebooting, I have no answer at this time, unless overheating is involved.

… but, it could also be someone else in control, or trying to take control. How is your firewall set. Are you also behind a router, and do you have the firewall set in the router. If a router, check the firewall settings. I would also disable UPnP in the router.

Thanks, yes it’s a wired mouse (Logitech), quite old. Firewall setting in YaST has “Enable Firewall Automatic Starting” checked ON. The router security settings are “SPI Firewall protetction low” ( I’ve reset that to “high”), IPv6 firewall protection on, no ports restricted, “Block anonymous internet requests” checked on. I’m not sure where to look to disable UpNP (nor what this refers to). Thanks again.

UPnP stands for Universal Plug and Play. Many commercial routers have it in one of their configuration tabs. It allows applications to automatically open some ports when they require them.

I much prefer to manually choose whether ports can or cannot be opened. I personally view UPnP in routers as a security weakness.

But, for many users with little experience, it makes some things easier.

OK thanks, I’ll take another look at the router settings.

I have the same device/OS combo, no random shutdowns here. I do have the occassional failure to return from sleep (=crash), which shows up as a fresh login screen and could be interpreted as a random shutdown/reboot. Also, although you seem to indicate that you are not moving your device, I have had very rare but regular issues with the hard-drive becoming slightly unseated. All of these could lead to crash, but not shutdown.