Lenovo X201 openSUSE 11.[23]


I have been try to install several different Linux distribution on my new Lenovo X201 Thinkpad without luck. So far I tried

openSUSE 11.2 (net install, downloaded ‘ages’ ago)
openSuse 11.3 Factory (update from a text mode 11.2)
kubuntu 9.10
kubuntu 10.04 latest beta 2

I get different mileage with every distribution. kubuntu 9.10 / 10.04 immediately blank the screen after hitting enter in grub. openSUSE 11.2 starts and the graphical installer is shown. I can install the system without problems. Once the system reboots the screen blanks half way through booting right before the X server is to be started. So lets install 11.2 in text mode only (runlevel 3). This works. I have a running system.
Now I installed some X stuff (KDE…) still keeping the system in runlevel 3. Reboot. Half way through booting the screen blanks and the system is dead in the water.

Next try: install 11.2 in text mode (runlevel 3). Now update to 11.3 and reboot. After hitting enter on the grub screen the screen is turned off completely (it is not blanked but totally shut off).

I think its a pretty safe guess that the Intel graphics driver is involved somehow. So the question is does anyone got openSUSE 11.2 (or in fact any other recent Linux distribution) running on an Lenovo X201? Is there any way that I can force the de-installation of the Intel grfx drivers without breaking to much in the system?


PS while writing this post I installed kubuntu 9.04 to see if this is working. Unfortunately I only had a 32bit copy lying around. Guess what this is working. As war as I see it’s using the vesa driver for running X.

So the next thing I’ll try is to update this to kubuntu 9.10 / 10.04

After installing and on the first reboot (when you get the screen problems), try typing a 3 at the grub boot menu.
This will take you to single user non graphic mode. You can still login to a terminal and configure the system running yast in text mode.
Start by identifying the graphics card and then enable either the ati or nvidia repositories.
To configure the display, run sax2 as root in the terminal login in runlevel 3.

Wildcart, you have to appreciate that most users will not know what configuration/hardware is on your Lenovo X201. you have faster access to that than likely anyone on our forum, so your best bet is to give us more information as to your hardware specifics …

I note this page:
Category : X201 - ThinkWiki

and for Intel graphics I note this page:
Intel HD Graphics - ThinkWiki

I think it makes it clear you need a 2.6.33 kernel. OpenSUSE-11.2 ONLY comes with the 2.6.31 kernel.

Hence you are likely best off to wait until openSUSE-11.3 is released in mid-July , or simply join the bug testing team for 11.3 milestone releases and install that from DVD.

Dear whych,

thanks for the reply but as I have written, as soon as any X stuff is installed the screen turns black even though I am still in runlevel 3 or is shut off completely after the grub screen (11.3). The only way I get any prompt is to boot with init=/bin/bash (11.2, won’t help for 11.3).

As oldcpu mentioned the thinkpad x201 uses the Intel HD Graphics (sorry for not making this clear). So installing the ATI or NVIDIA drivers wont help.

My mileage with kubuntu (32bit):
I have now also updated the kubuntu installation. 9.10 is running just fine (kernel 2.6.31). The version of the Intel X.org driver is 2.9.0. Unfortunately, I forgot to check whether it was actually used or if the VESA driver was still used by X.org. After I saw that 9.10 was running I updated to 10.04 (kernel 2.6.32, Intel X11 driver 2.9.1). After I hit enter on the grub screen I briefly see the ‘Boot from… starting up…’ message. After that the screen is turned off completely.

kubuntu keeps the old kernels installed when updating to a new version of the distribution. So I tried to boot with the old 2.6.31 kernel. It works and the Intel driver is used. Like I have written before, the LiveCDs of the 64 bit versions of kubuntu (9.10, 10.04) show the same symptoms as the installed 10.04 32 bit (the screen is shut off immediately after grub). Which is odd since the installed 9.10 (updated from 9.04) works just fine.

I’ll also report this to the kubuntu forums / launchpad, also.

I just downloaded and tried to boot the openSUSE 11.2 32 bit KDE LiveCD. Once it tries to start the X server the screen turns black. For now, I have a working combination kernel 2.6.31 / intel 2.9.[01], kubuntu 9.10 32 bit, while the 64 bit version of LiveCD using the same kernel / graphics driver wont start. On kubuntu 9.10, all essential hardware is supported and the system runs smoothly. At least in 32 bit!

I’d be happy to join the 11.3 testing group but I am not sure how to help as the screen is turned off after the boot manager using this version :frowning:

sorry for this long post just trying to give you as many information as possible.


wildcart, the problem here , and please do not take offence, is your hardware is new, and the support is currently limited for it, and your knowledge of openSUSE specifics is not strong.

For example if you get something to work (like you did with ubuntu) you HAVE to figure out WHY ? What driver? Else you are just spinning your wheels. Spinning does no one any good.

For the openSUSE-11.2 liveCD, I believe sax2 was still ON that liveCD, so you could have opened a terminal, typed “su” (no quotes, use < enter > for password) and then type “init 5”. That would bring you to a full screen text mode. Type “linux” (no quotes) as the user to login with <enter> as password. Then type “su” (no quotes, use <enter> for password) and then type “sax2 -r -m 0=vesa” to try create a custom vesa configured /etc/X11/xorg.conf file. If that works, then type “init 5” to go back to X windows (with no reboot - which wipes everything in a liveCD) required.

You could also download and try the openSUSE-11.3 Milestone4 or Milestone5 liveCDs. Note sax2 is NOT on the 11.3 liveCDs.

Unfortunately in this cutting edge hardware area, your (lack of) experience with openSUSE is hampering your progress.

For example if you get something to work (like you did with ubuntu) you HAVE to figure out WHY ? What driver?

Please have a look at My mileage with Kubuntu (32bit): from my second post. What more information are you looking for, perhaps running a kernel debugger, reading through all commit messages for patches to the graphics sub system of the kernel between the versions used in Kubuntu 9.10 and the upcoming 10.04?

For the openSUSE-11.2 liveCD, I believe sax2 was still ON that liveCD, so you could have opened a terminal, typed “su” (no quotes, use < enter > for password) and then type “init 5”. That would bring you to a full screen text mode.

How am I supposed to do that if I have a system which is ‘dead’ (11.2 installed from the net install CD), as stated in my first post? To turn it off I have to hit the power button for 4 seconds.

your knowledge of openSUSE specifics is not strong.

Please do not make any assumptions on things you don’t have a clue about.

I finally got things working, not perfectly but at least I have a usable system. I’ll write a post about how to make openSUSE run on the lenovo x201 later.


Debugger ??? No.

Simply look in the /var/log/Xorg.0.log file to see what driver. All average to advanced Linux users will know that. New users will not. Or are you saying that Ubuntu no longer has such a file ?

You can also look at the /home/user/.xsession text file (I may have name of syntax not correct as I am not at a Linux PC) and that may say something. Again, All average to advanced Linux users will know that. New users will not. Or are you saying that Ubuntu no longer has such a file ?

You can also look at the /var/log/messages text file . Again, All average to advanced Linux users will know that. New users will not. Or are you saying that Ubuntu no longer has such a file ?


Go back. Read my post again. You stated this worked in other distributions. I stated go to the other distributions (where this worked) and check tosee what they are doing !! I did NOT say to check this on a system that would not boot.

I think no comment is needed there on my part in reply. Your frustration speaks for itself.

Glad to read this is working. Truely!! I am glad to read this. Congratulations !!

I still think if the “other” distributions worked so well, that my advice to check what driver was in use, would serve you well to go check now (like I noted above) to help you tune things better and understand better why some work and yours did not/does not work as well (if that is still the case).

But what do I know? Clearly I know nothing. Clearly I have on good authority that I do not have a clue about anything to do with this subject . :X

This confused me, as in a subsequent post you noted you downloaded the 11.2 32 bit KDE LiveCD. Last I looked there was a version of that liveCD that is NOT a net install, and I assumed that was what you were subsequently using.

How I got things working for openSUSE 11.2:

There’s a difference between the net install CD and the LiveCD. Booting the net install CD will start a graphical yast. The X Server (1.6.5) uses the frame buffer driver (fbdev 0.4.1). I guess it’s doing this because there’s an xorg.conf file on the CD in /etc/X11/ naming only this driver among others like vesa, vbox… . I can install the system without any problems.

After the first reboot (and all following reboots), however, the problems start: the screen blanks and I need to do a power-cycle, the system crashed. Also typing ‘init 3’ at the grub prompt which should leave me in text mode after booting fails as it still tries to open up a X display and the system crashes.

The only way I get any type of command line is to start with ‘init=/bin/bash.’ In BASH I remounted the root file system read-write and set-up a basic X config file by hand. This file only has the server layout, screen and device sections. The device section tells the X server to use the VESA driver (2.2.1). All other sections only contain an identifier and what screen / device section to use. Now I re-started the system, again using ‘init 3’. Half way through the boot process an X display pops up. (Why, I am in run level 3 which should be text mode only?). A few seconds later yast starts and configures the system. Once yast is done the system remains in text mode. Subsequent boots using ‘init 3’ will not open any X displays any more. Now when I type ‘startx’ on the command line the X server works fine. Rebooting the system and staring into run level 5 now also works.

So, the problem after the installation is, that without explicitly telling X to use the VESA driver, it will auto-detect the Intel graphics chip-set and it tries to load the Intel driver coming with openSUSE 11.2’s X.org 7.4 package (zypper info xorg-x11-driver-video Version: 7.4-87.88.1). At the moment I can’t figure out what the correct version number of the Intel driver is. According to the release page of X.org this is 2.4.1. However, this page also says that the version of the X server which is part of X.org 7.4 is 1.5, but from the X log file (/var/log/Xorg.log.0) I get version 1.6.5 for the X server.

On a side note: the grub boot entry Failsafe which specifies x11failsafe doesn’t help. I hoped that this is forcing the use of the VESA driver for X or something similar. Unfortunately, the system still crashes when the X display is initialised. So my guess is that the server still tries to use the Intel driver. By the way can you explain me, why there’s no /var/log/Xorg… file for the crashed X when I reboot using ‘init=/bin/bash’. The file that’s present in /var/log is from a successful run using the VESA driver. Also, the time-stamp doesn’t match the last system boot (it’s too old).

The LiveCD doesn’t come with a pre-configured xorg.conf file so it tries to auto-configure the graphics system at boot time. It will find the Intel chip-set and it will try to load the Intel driver. This is why it crashes once it starts the X server. Starting the LiveCD with ‘init 3’, setting up an xorg.conf file by hand or using sax2 as mentioned by oldcpu, then doing an init 5 and installing the system will work. After the installation, however, the system has the same problems as described above.

How I got things working for openSUSE 11.3:
Kernel 2.6.34rc3
Using X server 1.8
VESA driver 2.2.1
Intel driver 2.11.0

This is a totally different story. First of all I couldn’t install using the net install CD (11.3 milestone 5) because it was crashing even before the lanuage selection, copyright agreement screen was displayed. I got an error code 139. Does the /var/log/yast.log (can’t remember the correct name) contain useful information. I had a brief look at it but couldn’t make out anything related to the crash.

So: from the running 11.2 system I made an update to 11.3, and I renamed the xorg.conf file to use X auto-configuration. After I reboot the system, the screen will be shut-off (including the back light) shortly after the grub boot screen. The system, however, seems to be running fine. Just without any graphical interface. I also didn’t see the openSUSE splash screen that you normally see during the boot process. I can ping the machine and log into it using ssh, so its not crashed.

This is the same effect I observed when running Kubuntu 10.04 which uses kernel 2.6.32. Also, from Kubuntu I knew that using an older kernel (in this case 2.6.31) booted the system just fine. The X server which was started, in this case, used the Intel driver (2.9.1). Unfortunately, openSUSE doesn’t keep the old kernel when upgrading to a new openSUSE version, so I couldn’t easily check if using an old kernel would be working on openSUSE as well. I may try to manually install an old openSUSE kernel see what happens.

From the experience with Kubuntu I knew that this time it wasn’t the Intel driver, which on top of not working is crashing the system, but it is something related to the kernel. My best guess was the kernel driver for the Intel graphics chip-sets (i915) providing frame buffer and kernel based mode setting (KMS) support. Using this guess to search the internet finally returned relevant / helpful results. At the grub prompt, you have two options. You can either specify i915.modeset=0 or acpi=off (which will give you lots of errors initialising devices). Specifying either of these two options will give you back the openSUSE splash screen. However, X (with auto-configuration, and trying to use the Intel driver) will not start complaining about missing KMS support in the kernel. So you’re again stuck with the VESA driver, which at least gives you a running system.

This problem was introduced at some point of the 2.6.32 release cycle as older 32er versions seem to work while everything newer, including kernel version 2.6.3[34] will shut-off the screen.

A very useful link is: https://bugs.launchpad.net/ubuntu/+source/linux/+bug/515246
I need to check what happens if I try to install one of the patched kernels mentioned in that thread. The kernels are for (K)Ubuntu so I guess it won’t be too easy to get them to work in openSUSE, but I’ll try later this week.


Simply look in the /var/log/Xorg.0.log file to see what driver.

Where do you think I got all the driver and version information from, that I mentioned in my second post?

Please do not make any assumptions on things you don’t have a clue about.
I think no comment is needed there on my part in reply. Your frustration speaks for itself.

I am just wondering how you know how much I know about openSUSE in specific and Linux in general and where you got this information from?

I still think if the “other” distributions worked so well, that my advice to check what driver was in use, would serve you well to go check now

I am really sorry for writing this, but have you read my second post? I give all the relevant information regarding kernel version, the X driver used and its version in that post. The really hard problem was to figure out what openSUSE is really doing because I couldn’t get access to any type of Shell TTY, X, whatever, except with init=/bin/bash which doesn’t help me much if I want to start a X server (see my previous post for detailed information on why and how).


Go to the source (src):
Index of /update/11.2/rpm/src
Look inside (various ways to do this) and can see:

or even easier, LOOK at the change history that comes with the rpm. Its written there! :open_mouth:

ie CLEARLY the intel driver is version 2.9.1

Or if looking at a new driver, go here:
Index of /repositories/X11:/XOrg/openSUSE_11.2

Note these rpms with the intel driver:

Look inside and you will see:
or alternatively just read the change notice to see version 2.11.0

ie **clearly for the “cutting edge repos” the intel driver is 2.11.

Anyway … hope that helps … and pardon the “tongue in cheek” aspects here in this post. … these are rpm specific aspects that a user from a .deb environment may not yet be familiar with.

The manner in which your post was typed suggested it to me. OK, I was inaccurate in that assessment … but let me explain.

First, you referred to a Lenovo X201 and it appeared you did no research as to what kernel was needed with the graphics on that laptop. Give the sources I found noted 2.6.33 kernel is recommended, and you tried (and still try) to install 11.2 on it where 11.2 has a 2.6.31 kernel. That makes no sense to me. I would not waste my time trying that. It suggests to me a conclusion, that in hindsight was wrong, that you did not know what you were up to, and that you were new. Your approach looked to me to be a classic new user mistake (trying to install a driver with an older kernel when recommendations indicate a newer one is needed).

When you quoted other distributions worked, but openSUSE did not, you provided no information as to their kernel versions, nor their driver versions, which CAN be figured out. That to me is a classic new user mistake/lack of research. OK, an inaccurate conclusion again on my side, but that is where I got the view from. An average or experienced user would provide that information. An experience user looking for help would not skimp on the corners here.

An inability to look inside an rpm and see a driver version?

Thats a new user lack of knowledge. Most average or experienced user would know this.

I am NOT a guru. I am an average user. But I can do this. Hence when I read you did not provide the above, that suggested to me the level of a new user.

Unfortunately there is no number beside a user’s name that indicates experience. A large post count (such as I have) means nothing. I am NOT a guru. I am an average user. A small post count beside a new users name means NOTHING. They could be an advanced guru, or they could be the rankest of new users.

So all one can do is make the best assumption they can on the information provided, or the lack of information. Typically a LACK of information indicates a new user. In your case it did not … but most the time it does.

Anyway, it appears your knowledge level is such that you surely don’t need me here… seriously … I may know the odd tidbit about rpms (such as my above tongue in cheek post) but in truth, from the approach you adopted and what you have done, I think there is very little I can offer.

Good luck to you in your efforts.

Thats a good point.

I appreciate (and sympathize) totally with the difficulty there.

I wish I could recommend 11.3 milestone5, but I can’t. My brief brush with it indicated milestone4 was better than milestone5. … But I have good hopes for milestone6 which is not far away in time.

I should have added, if you look at the intel driver page, you can see the open source drivers intel have made available here: Intel Linux Graphics

There is also the iegd proprietary Intel driver, which as near as I can tell from a skim (i could be wrong as I did not look in detail … I’m in a rush) is not applicable to your hardware … but I could be wrong.

I made vague reference to the iegd driver here: openSUSE Forums - View Single Post - openSUSE Graphic Card Practical Theory Guide for Users and more specific reference here: in post #43 and #44 . However in truth I know nothing about that proprietary driver , … and since it may not be applicable to your graphics and since I know nothing about it, its possible I should not mention it at all as this could be a wild goose chase (I simply don’t know).

… but the Intel Linux Graphics driver is relevant, as I think that is the one you are currently attempting to use.

… I’m wrong here … you did provide this in a SUBSEQUENT post … which I read too fast.


Getting up this morning and looking at my posts in this thread, it was not one of my brighter nor more tactful moments. Apologies for my going off on a tangent that was incorrect and out in left field. Many of my statements/assumptions above are wrong.

I hope you have more success in this. I’m told openSUSE-11.3 Milestone5 WILL install … apparently the “trick” is after the installation is complete, the PC will refuse to boot if the installation DVD is still in the hard drive! So when it fails after the reboot, remove the DVD, restart, and supposedly the installation will continue. I hope to test this on the weekend.

I mention this only in case you decided to test the 11.3 milestone5 to see if you can have more success than you had with 11.2. 11.3 milestone5 can be found here: Software.openSUSE.org I do NOT normally recommend 11.3 milestone releases to new users as they are very very rough in places. But I can see now that you know your way around Linux hence this caution is likely not so relevant. Still, I also note a milestone5 is like an “alpha” version of a pre-release so this is not a final answer to the problem encountered even IF it were to work better.