Lenovo x200 won't sleep with opensuse 11.0 and kernel 2.6.27

I cannot make my laptop sleep… When i press sleep button or just got to menu and click sleep, the laptop goes for milliseconds to sleep (i can see that “sleep light” goes on") but then I see message in bottom-right corner that network is disabled and that is it… no sleep.

Any ideas?

Try setting up kpowersave
And in kde3 at least, I set in General tab - Button Events - Lid close =suspend to ram

My sig is my desktop. My laptop is lenovo R61e

I use Gnome…

So is there a Gnome Power Manager. I just looked in the Gnome repo and there is a .rpm of that name. Maybe it’s the same thing?