Lenovo X1 Carbon: Partitioned Not possible to install OpenSuse

Hello,

I’ve tried to installed on a Windows 10 based Lenovo X1 Carbon partitioned SSD the OpenSuse Leap 42.2. The Boot UEFI options were changed to Legacy and the installation started normally until I hit the partitioning page on the OpenSuse installation. The option to delete the Windows partition did not satisfy me so I’ve tried to change the configuration only to have a message that it was not possible to access the /dev/sda disk.

Note that from Windows I have already partitioned the 256SSD to 2 partitions one that holds Windows and one (NTFS) that supposed to be destined for linux. The disk is not encrypted.

Are there any suggestions on what am I doing wrong? I suspect the BIOS options though I cannot figure out what might be the problem.

Thanks in advance

Please (re)check if your Win10 is installed in “legacy” mode on a MBR formatted disk (unlikely on such a new ultrabook), or if the disk is GPT partitioned and W10 boots in UEFI mode.
If the latter is true, you must start the installer in UEFI mode, maybe with SecureBoot disabled (you may re-enable it after install): you must never mix UEFI and “legacy” if you want to be able to dual-boot.

Then be aware that OpenSUSE doesn’t install on a NTFS partition and it is better to leave free (unallocated) space on the disk and let the installer use it at best.

Please also check if you really intend to install Leap 42.TWO which is currently in Alpha 3 test phase, or if you are referring to the current Leap 42.1.

@OrsoBruno I’ll start with the last proposal of yours. I’ve noticed that the 42.2 is in alpha3 state when I have almost downloaded the DVD iso image. I will try today to download and install the 42.1 stable version instead and let you know. I have already deleted the D: volume and let it be as unallocated for future use. As for the UEFI boot options I suppose that this is not the problem as it does let me start the installation for the OpenSuse linux distribution. If I have the same luck with the above changes I will try to mess around with the BIOS settings once more. Thank you

OK, a few additional notes might be helpful.

The installer starts even in legacy mode, but then expects an MBR formatted disk and if it finds a GPT disk it tries to wipe everything (Windows or not) and reformat the disk as legacy MBR. So, if you want to keep a GPT/UEFI Win10, you MUST start the installer in UEFI mode.

If you have an X1 Carbon with an i# 6xxx (Skylake) processor, you are better off with a kernel version 4.4.x and above, as in Leap 42.2; that’s why I asked to check.
With the 4.1.x kernel currently on Leap 42.1 you are likely to see graphics glitches with integrated graphics.
Should this be the case, you may install 42.1 and then upgrade the kernel one way or the other; feel free to ask if you need help.
Should you dare to install 42.2, please be aware that the next Beta1 should be released in a week or so. It is already useable, but not ready for production work yet.

No luck :frowning: The machine I am running is an i7 4600. The message that parted o/ps is: “Error Operation not permitted on disk /dev/sda. The partitioning on your disk /dev/sda is either not readable or not supported by the partitioning tool parted used to change the partition table …” I’ve downloaded and made bootable a usb-flash with 42.1 opensuse version. Half of the SSD disk was unallocated. Yet I get the same error message as before. Now as far as the UEFI settings from BIOS I have tried to change it to reboot to windows only using the UEFI mode (so I imagine it looked for GPT partitioned disk) and the pc did not manage to boot. I suppose that means that Windows installation took part on an MBR formated SSD. Changing back the BIOS to Legacy it managed to boot normally. The installation of OpenSuse 42.1 took part while the BIOS was set to legacy. I have tried earlier with 42.2 to install them in UEFI mode but installation stuck at the same partitioning section. Better this way as I would not be able to dual boot any more. Finally I used Diskpart from Windows just to try to verify if the current partitioning is MBR or GPT based but I came out with no results. I did not feel comfortable playing with it to be honest.

Chances are that this is indeed an MBR formatted disk. Please be careful with Win Diskpart, you might loose everything on the disk if you don’t know what you are doing. But you can safely issue the following commands and post results:


LIST DISK

SELECT DISK 0 (assuming you have only one disk installed)

LIST PARTITION

If you have an OpenSUSE (or other GNU Linux) live or rescue CD, you might use parted or gparted to get more information on your disk.
I think that booting the installer, at the partitioning stage, if you choose the “Expert Partitioner” and double click on “Hard Disks”, then “sda” and look in the “Overview” tab for “Disk Label” you can see if it is a GPT disk or not.
The “Partitions” tab should also reveal info equivalent to the Diskpart commands above.

With the above info maybe we are able to understand why you see “Error Operation not permitted on disk /dev/sda.”

Ok, I did what you suggested and I came back with some results:

DISKPART> list partition

  Partition ###  Type              Size     Offset
  -------------  ----------------  -------  -------
  Partition 1    Primary            500 MB  1024 KB
  Partition 2    Primary            113 GB   501 MB
  Partition 3    Primary            109 GB   114 GB

And the results from OpenSuse installation are:

Hard Disk: /dev/sda
...
Hard Disk


  - Vendor: INTEL 
  - .... 
  - Disk Label: **GPT**
 


So I suppose I do have the format in GPT mode.

Any suggestions from now on? Thank you!

OK, let’s assume that your system has:

  • a GPT formatted disk (so it has almost no limit on the number of partitions available)
  • Win10 is installed and booted in “legacy” (or MBR) mode (unusual, but still possible).

Apparently (from Lenovo web site) your laptop seems to be equipped with a 256 GB SSD.
Your 3 partitions span about 223 GB, contrary to your statement in post #5 that “half of the SSD was UNALLOCATED”.
When the OpenSUSE installer sees a situation like that, it cannot go ahead without DELETING or RESIZING a partition to make room for the new OS to be installed; hence the “operation not permitted” warning.

Now my guess is:

  • Partition 1 is a Win10 boot partition (or might be a UEFI boot partition, but apparently you boot in “legacy” mode, so I’m not sure);
  • Partition 2 is the Win10 System partition; be absolutely sure not to delete partitions 1 and 2;
  • Partition 3 is still an NTFS partition you created for OpenSUSE (an “empty” partition is not “unallocated” space on the disk).
    Please double check if this is the actual setup on the disk and DO NOT COMMIT ANYTHING TO DISK if you are not absolutely sure.

In a situation like that, I would do the following.

  1. Delete the empty partition (let’s assume it is Partition 3);
  2. setup a 20 GB partition, formatted as EXT4, to be mounted as /root for OpenSUSE; (note: I prefer EXT4 on SSD installs, use a 40GB partition formatted as BTRFS if you prefer the standard OpenSUSE install);
  3. setup a swap partition just larger that your RAM (4 - 8 GB?) if you plan on using “suspend to disk” AKA “hibernate”;
  4. fill the remaining space with an EXT4 (or XFS if you prefer the standard OpenSUSE install) partition to be mounted as /home for your user files in OpenSUSE.
    I think you can do all that with the “Expert Partitioner” during install, but I don’t have an installer image to check at the moment. Use GParted on a LiveCD or Linux rescue disk if you have one.
    It is generally safe to play with the installer UNTIL YOU PRESS THE “INSTALL” button when you are warned that “if you go ahead you will overwrite the content on your disk” or similar…
    Please ask here before doing that if you are not absolutely sure.

Yes you are right:
I have once more removed the unallocated space to NTFS when I saw that it was not possible to install OpenSuse and then executed Diskpart. Hence the Partition 3 appears to be NTFS.

I will turn it back to unallocated and try the manual installation using the steps you have suggested and let you know.

Thank you very much for everything!

Nope!

Here is the o/p from Diskpart right at this moment:

DISKPART> list partition

  Partition ###  Type              Size     Offset
  -------------  ----------------  -------  -------
  Partition 1    Primary            500 MB  1024 KB
  Partition 2    Primary            113 GB   501 MB

DISKPART>

So it dos not “see” any more the Partition 3 which is now Unallocated.

I have tried to install OpenSuse manually and the message I get when I try to Add a new partition (or assign something to the unallocated space) I get the same error message which I will provide bellow almost complete:

Error
 Operation not permitted on disk /dev/sda.  

The partitioning on  your disk /dev/sda is either not readable or not supported by the  partitioning tool parted used to change the partition table

You can use the partitions on disk /dev/sda as thy are or format them and assign mount points, but you cannot add, edit, resize, or remove partitions from tat disk here

Then it says that I can select Expert ->Create New Partition Table but I will loose any data on the disk.

What I saw on the expert settings partitioning by selecting from Disks the /sda the two partitions as in Diskpart as
/dev/sda1 500.00 MiB
/dev/sda2 113.93 GB
and only the Unallocated space in graphic form on top in red showing the correct space as 109.14GB. The Add button on this stage produced the message above.

I suppose the only option I have left is to format the whole disk and start over. Or is there another?

That’s weird, never seen something like that: maybe your HW has unusual features or your Win10 protects the partition table somehow?
But since the error says that “You can use the partitions on disk /dev/sda as thy are or format them and assign mount points”, maybe you can create 3 partitions in Windows (20-40GB, 4-8GB, 60+ GB), leave them unformatted (or format to FAT or NTFS if forced) and then reformat as needed in the installer “Expert Partitioner” and assign mount points as needed?
Or you can try live rescue tools like PartedMagic or similar to change your disk as needed?

I cannot check right now, but it is possible that the OpenSUSE installer when booted in “legacy” mode only sees the “protective MBR” on the GPT disk and so refuses to do anything on it.
If that is the case, the installer booted in UEFI mode should see the GPT partition table and should be able to add and format partitions, even install OpenSUSE unless something unusual is on your disk; but such an install normally can’t dual boot a Win system installed in “legacy” mode and you need a workaround I’m not currently aware of.
And from post #5 apparently you can’t install even in UEFI mode if I understand correctly?

I have not read the whole, but is Windows shutdown or suspended properly?

If this was asked, please ignore it.

Correct. I have tried that once before

Ok I have managed to install OpenSuse 42.1 using your suggestions!

Yet I have only one operating system right now :frowning:

What I did additionally to what you have suggested is that I have added a /boot partition to the 3 partitions.
So to summarize before to seek any advice for the grub2:
[ol]
[li]I have Logged to Windows and made 4 partitions using the graphical interface from Manage PC [/li][/ol]

[LIST=|INDENT=1]
[li]/root 20GB /dev/sda3 [/li][li]/swap 8GB /dev/sda5 [/li][li]/boot 100MB /dev/sda6 [/li][li]/home the rest ~83GB /dev/sda7 [/li][/LIST]
2. I’ve booted using the bootable usb with opensuse 42.1 installing with manual partitioning
3. After 3-4 tries playing with boot loader and after changing the settings as below I managed to have grub2 loading the boot screen without though the option to boot in Windows.

Settings of my boot loader are:

[b]Boot Code Options:[/b]Boot Loader = GRUB2
Boot Loader Location=Boot from Master Boot Record (only this is checked)
/dev/sda4
Boot Loader Installation Details

[INDENT=2]Disk Order Settings
[/INDENT]
[INDENT=3]Disks
/dev/sda

[/INDENT]
[b]Kernel Parameters:
[/b]Vga Mode=Unspecified
Optional Kernel Command Line Parameter=resume=/dev/sda5 splash=silent quiet showopts
[b]Bootloader Options:[/b]
Probe Foreign OS=checked
Timeout in seconds=8
Hide menu on boot=unchecked
Default Boot section=openSUSE Leap 42.1
Protect Boot Loader with Password=unchecked


Note that the partition /dev/sda4 was a small partition already existed while installing linux and I did not choose it during the installation. I do not know how it ended up in Boot Code Options section.

The df command o/ps:

> df
Filesystem     1K-blocks    Used Available Use% Mounted on
devtmpfs         3923752       4   3923748   1% /dev
tmpfs            3929860     212   3929648   1% /dev/shm
tmpfs            3929860    2180   3927680   1% /run
tmpfs            3929860       0   3929860   0% /sys/fs/cgroup
/dev/sda3       20027260 5110772  13876104  27% /
/dev/sda6         102182    4490     97692   5% /boot/efi
/dev/sda7       84194824  131012  83019380   1% /home

Is there a possibility by changing the boot loader options to manage to dual boot?

Thanks in advance

Welcome to OpenSUSE! Now at least we can speak the same (system) language.
If you can open a terminal, issue “su -” and the root password to login as superuser, issue “gdisk /dev/sda”, then “p” at the “Command :” prompt and post the result, you can share with us the current layout of your disk.

Apparently you successfully installed Leap in “legacy” mode.
Don’t mind /dev/sda4 as long as the “Custom boot partition” checkbox in the bootloader settings was not checked. Apparently you also did an attempt to install Grub2-EFI and sda4 might be a byproduct of that attempt.
Or it might be a reserved, hidden or whatever MSoft partition; but as long as it is not mounted it should do no harm.

Now, in theory, you should open a new thread titled “How can I dual boot my Win10?” :wink:

Sauerland in post #13 suggests that maybe you did not disable “Fast Boot” in Windows before shutting down, leaving the system in an undefined state that Grub2 is unable to read despite the “Probe Foreign OS” flag in the installer.
If that is the case, I see no alternative to booting into Win10 one way or the other (by a Win repair or recovery disk? By a Win install disk if you have one?), disable “Fast Boot”, really shutdown (NOT “hibernate” or “suspend”), then boot to OpenSUSE (maybe via a rescue disk or the installer rescue system if you destroyed Grub2 during the Win repair) and rebuild the bootloader. Or, in an extreme case, reinstall OpenSUSE: your disk should be already prepared for that.

Or you might scan the forums for many similar threads (dual-booting problems seem fairly common).
Or wait for somebody with a knowledge of Win internals better than mine to join this thread and write a better answer rotfl!

To be honest I do not remember my settings in Windows about Fast Boot. I guess due to the small time of loading them it should have been on.