Lenovo W520 w/Intel Matrix RAID - installation fails when formatting partitions

I’m trying to install openSuSE 11.4 onto my brand-new Lenovo W520 laptop, using the Intel Rapid Storage Technology (FakeRAID?) controller, ROM version

I have 2 physical 500GB disks configured in a mirror (RAID-1).

Everything looks fine, the installation program comes up and asks if I want to use mdadm to manage the RAID, to which I answer yes.

I go through the normal setup screens, and select the partition layout that I want (for sake of this post, I’ll limit myself to the layout that the system itself recommends).

The problem comes when it becomes time to format the partitions. Somehow the partitioning program gets it into it’s head that the root partition is 10TB, not 20GB, and the ext4 partitioning fails in various ways (short reads to sector zero, unable to map using 4096 byte sectors, etc, etc) depending on exactly which partitioning scheme I’m attempting.

I pretty much get the same result no matter how I play the paritions, which file systems I use (XFS, ext4, etc [of course, I can’t use XFS for /boot…]).

Reading around this issue it seems as if there is a generic set of problems with FakeRAID which I’m presumably falling foul of?

For now I’ve gone ahead and set myself up using software RAID, since this system is unlikely to become dual-boot with Windows for a few years at least.

(As an aside, but as a hint to others, when the installation fails, I end up having to go back into the Intel RAID controller BIOS boot to clear out the entire RAID setup each time it fails - the disks are left in a completely useless state).

The exact error I’m getting is:

Failure occurred during the following action
Formatting device /dev/md126p2 (10.00TB) with ext4

System error code was: -3008

/sbin/mke2fs -O dir_index -m5.0 -t ext4 -v ‘/dev/md126p2’
mke2fs 1.41.14 (22-Dec-2010)
Warning: could not erase sector 2: Attempt to write block from filesystem resulted in short write
Warning: could not read block 0: Attempt to read block from filesystem resulted in short read
Warning:could not erase block 0: Attempt to write block from filesystem resulted in short write
ext2fs_mkdir: Attempt to read block from filesystem resulted in short read while creating root dir

Well, I intended to go ahead and set myself up using software RAID, but the partitioner on the 11.4 install DVD shows 2 500GB disks, but says:

There are not enough suitable unused devices to create a RAID.

when I go to the RAID selection.

I even went so far as to boot up in the rescue mode and blow away any pre-existing partition on the underlying disks, but to no avail.

Did you turn off the FAKE RAID in the BIOS? Goodness only knows what would happen if you try to RAID a RAID array.

I have precisely the same error and symptoms. I am running Intel Raid on a SuperMicro Server board. Two 1TB Seagate drives in Raid1. Partition layout goes smoothly, shows the drives organized in 1TB Raid 1. Auto creates partitions then starts formatting… I get report of a 10TB drive being formatted in my / partition, then a -3008 failure.

Bug - Ticket - CR?

I think you can overcome the softraid issue by disabling raid in bios (going ide/achi) then creating an unformatted partion on each physical volume first, after which you should be able to create a softmirror using the two defined partitions.