Lenovo w510 connect to home wifi but not 802.1X work network

I recently got a lenovo w510 laptop and I installed openSUSE 11.3 KDE on it. the wireless works fine at home (802.11g WPA2) when I go to work I have tried to set up the wifi for the 802.1X PEAP network but it doesn’t look like it even tries to connect.

The work network set up is as follows.

  • non-brodcasting SSID (do I need to tell network manager of this? I manually enter the SSID no problem)
  • Dynamic WEP 802.1X
  • PEAP
  • blank anonymous identity
  • no CA cert (I suspect this might be the problem)
  • PEAP v 1
  • MSCHAPv2

I have verified my username and pw several times, as well as the SSID.
Just yesterday I helped a co-worker get on the network under ubuntu and it worked like a charm.

The Hardware profile displays the wifi card as a “WiFi Link 6000 Series” It is an intel card.

Any ideas on what I can try?

PEAP is the problem I think

openSUSE doesnt have any support for PEAP? or is there a package I need, or a config file I need to edit?

It should work, I think it needs xsupplicant installed

Thanks a lot (quickest reply I have ever seen on a forum.) I installed it and will report back the next time I go into work.

No worries.
I just wish there was one standard method that worked for everyone

no dice. any ideas on how to trouble shoot this?

I don’t know. But if it were me…

I would try my Gnome install (just in case it’s anything in kde’s network manager), but I have both kde and gnome installed.

I also have Linux Mint (Which is basically Ubuntu)

I also have win7 (Not that I ever use it but…)

You see I have options

yea it works great under win7 (I have to use win for CAD and matlab stuff.) I will try gnome and report back.

I got on the network with the opensuse 11.3 gnome live cd without any problems. Bug report filed https://bugzilla.novell.com/show_bug.cgi?id=648144

any one know how to get the configuration settings from Network Manager in gnome? I was directed to NetworkManagement - KDE UserBase . I have the log from KNetwork Manager, but when I boot into the openSUSE gnome live cd qdbus is not avaliable.

Just an update, this problem still exists in openSUSE 11.4 x86_64. I even have tried:

sudo /usr/sbin/iwlist wlan0 scanning essid [SSID]

in hopes that once KNetworkManager marks a network as trusted, it will connect, but it still doesn’t.

I found this link and tried it, and got my network running using gnomes network manager in kde. Not an ideal solution, but it works. The link talks about mobile broadband, but I can’t speak for that since I dont use it. openSUSE starter: Step 2. Need mobile broadband? Use the GNOME applet

In case that blog goes down in the future I’ll summarize what it says:

  1. Remove all NetworkMaganger packages that include kde4 in the name
  2. add the package Networkmanager-gnome
  3. add the packages qtcurve-gtk and qtcurve-kde4
  4. on the command line: sudo killall knetworkanager
  5. In YaST network config make sure that it is set to use networkmanager
  6. set the gtk theme to qtcurve in KDE settings
  7. also in KDE settings set nm-applet to autostart (in advance setting make sure that launch in system tray is checked and register multiple instance with dbus)
  8. log out/log in and enjoy gnome’s network manager

I have to manually tell it to connect to a hidden network, but it does connect, and I still have access to my home network that is WPA2.

I would also recommend to secure the Wifi network by using WPA2-Enterprise for advanced authentication.

We recently started offering a Free Edition of our IronWifi service, a hosted RADIUS/AAA service offering 802.1X authentication for use with WPA/WPA2-Enterprise encryption.

The Free Edition features 5 user accounts, supports 1 AP, and includes: PEAP authentication for wireless and wired connections, web-based control panel, Android client, and activity logging.

This is great for IT professionals wanting to experiment with 802.1X or to get enterprise security in homes and small offices.

For more info visit our site: