Lenovo ThinkPad T520 Touchpad suddenly malfunctioning


recently the touchpad of my Lenovo ThinkPad T520, which is running openSUSE Leap 42.1, started to behave strangely. After starting a new session, it is only possible to navigate the mouse, but no left/rick clicks with neither key. After disabling and enabling the touchpad once (2x Fn+F8), the Touchpad is again functioning as you would expect, except that one of the two right click keys (the lower one) is still not working. What could be the issue?

Thanks in advance.

Well, as you’ve described it was working, but now not behaving correctly, that would indicate a possible hardware problem. You could try booting a Live distro (eg on a USB stick) to compare touchpad behaviour with another OS I suppose.

Hi, just a hint: on Leap 42.1 I witnessed occasional malfunction with some clickpads when all the three following packages are installed:
Please see if you “recently” had an update or install of any of the three; I had to uninstall xf86-input-libinput to restore things as usual, maybe keeping libinput and uninstalling evdev (and/or synaptics) might work as well.

No problem so far with all three installed in Leap 42.2 Alpha3, so maybe there is a version mismatch somewhere…

Okay, I tried this and in the Live environment the touchpad behaved even worse than on my real installation (not even Fn+F8 fixed symptoms, anymore). I suppose this is indeed more of a hardware than a software issue, then. Thanks for the help.