Lenovo Thinkpad EDGE support?

after writing thread about Speakers bug in Lenovo thinkpad EDGE laptop, I wondered if there is a proper hardware support for this model in opensuse 11.3, I noticed that CPU fans work at one speed only and no sound in movies as well as there some other issues(well it can be due to codecs but on my toshiba laptop with 11.3 and the same configs all worked), so does anybody have the info about opensuse 11.3 Lenovo ThinkPad EDGE support. That is a really annoing, cause I have to work in Linux most of the time(

Multi-media and Restricted Format Installation Guide

There are no helps specific to your model. Only here:
HCL:Laptops - openSUSE

Have you searched ThinkWiki for your particular EDGE model?

There is also this forum with a linux section, and lenovo community.

thank you a lot for information I’ll check it out!

Actually it doesn’t, this is what I found in my dmesg output:
13.758587] thinkpad_acpi: Not yet supported ThinkPad detected!
so this is the answer to my question, then I have another question, when this lenovo model support will be available in suse kernel? and, well, there is no support for official Suse partner laptop, that is quite stange?

To answer this question, you need to cast your “net” further and wider than just looking at openSUSE. :wink:

Googling, I found this link, read that for starters. It mentions your acpi issue, and possibly the minimum release of kernel you may need, but if it’s the wrong model, well you didn’t give much info about your model of Edge. For more hits, try googling: thinkpad edge linux kernel

Well some people say its too new, so Ubuntu users do have some issues with it, I was struggling with my soundcard config for a month, its still is not completelly resolved, that made me report a bug, asking dear SUSE kernel masters to work on it, so I could at last enjoy using it without manual system tweaking, and now that I found that its acpi is not supported makes me confident that it is new for linux, I shall wait for proper drivers for it. Because once I chose SUSE exactly because it had the widest laptop support among other distros, I hope it does)!

yeah checked the link, but its Gentoo, I’m really happy for EDGE Gentoo users, but what about SUSE?

Hi
Install a 2.6.35 kernel on your machine???
http://download.opensuse.org/repositories/Kernel:/HEAD/openSUSE_11.3/

Else try out a live version of 11.4 M2
http://software.opensuse.org/developer/en


Cheers Malcolm °¿° (Linux Counter #276890)
SUSE Linux Enterprise Desktop 11 (x86_64) Kernel 2.6.32.23-0.3-default
up 2 days 0:24, 3 users, load average: 0.09, 0.15, 0.10
GPU GeForce 8600 GTS Silent - Driver Version: 260.19.06

wrt sound (and not ACPI) there is a fix in the latest 2.6.34.7-0.4 kernel for 11.3 to address Bug 640338 on the Thinkpad Edge (when I plug in the headphones, laptop speakers are not automatically turned off ).

However given there is an ACPI problem, if it were me I would download the 2.6.35 kernel that malcolmlewis pointed to and install it along side the existing kernel, with:

rpm -ivh kernel-default-2.6.36-rc7.30.1.x86_64.rpm   

(note kernel-default-base-2.6.36-rc7.30.1.x86_64.rpm may also be needed) in same command. ie instead of the above, one may need to try:

rpm -ivh kernel-default-2.6.36-rc7.30.1.x86_64.rpm default-base-2.6.36-rc7.30.1.x86_64.rpm  

I have not done this often, and I confess I forget the exact details.

Once successful this should give a multiboot where one can choose which kernel to boot to

… and then I would pay VERY careful attention to the /boot/grub/menu.lst to ensure its content to configure the multiboot survives this and all subsequent kernel updates. Its possible if one’s drivers are broken by the kernel update that one may also need to install kernel-source and kernel-syms of same kernel.

yeah! thanks, I was on my way of updating the kernel already, it all works fine with 2.36 onboard, thank you.

Well done, you worked your way through it. I may end up doing the same for my ThinkPad SL510 due to its IdeaPad firmware. It’s not quite as new as yours. Most of the features I need work with 11.3’s kernel, including hibernate, but a few things don’t, like some special function keys and suspend (to ram).

Are there any features on yours that don’t work with 2.36?

Well, actually, my hotkeys worked with 2.34 kernel, my soundcard didn’t work properly, and I had quite a lot of trouble with it, so now on new kernel it seems to work ok, acpi works and all configured properly, well I tried hibernation but it failed on wake up, but there could be other reasons for it, anyway I’m confident that with official new kernel update everything will work.