Lenovo T430s and OS-12.2

Hi!

On a newly Lenovo T430s I have installed OS-12.2 with an empty 256-GB-SDD and 16GB RAM. Everything installed without any problems and so far all features are working as they should. Unfortunately I have a serious problem I am not able to resolve so far. The computer freezes erratically roughly every 1-12h while working. The freeze happens not reproducible, mostly while using the mouse i.e. doing some desktop stuff. I am using so far only the intel-grafics driver, because there seams to be a bug in the nvidia-driver enviroment (https://bugzilla.novell.com/show_bug.cgi?id=779136). Their is no mark in /var/log/messages at the freezing moment, it simply freezes.

To resolve the problem, I have done the following things:

  1. Testing the hardware with Lenvo-Linux-diagnostic tools
  2. Testing RAM with memtest
  3. Flashing newest BIOS from Lenovo
  4. Using latest kernel from OpenSUSE (3.4.10)
  5. Using latest KDE-4.9.1 and not using any desktop effect.
  6. Removed one RAM (8GB)
  7. Using only an external Monitor

After every of those steps, the freezing behavior still occurs.

Any idea?

Thanks,

Michael

I would recommend installing “powertop”. It can help you identify what is consuming the most memory on your laptop.
Also, have you tried turning off Nepomuk? Navigate to Configure Desktop → Startup and Shutdown → Service Manager and turn off Nepomak Search Module.
Then navigate to Desktop Search → Basic tab - uncheck “Enable Nepomuk File Indexer”, “Enable Nepomuk Semantic Desktop”.

Log out and log in and see if it makes a difference

Also recently bought T430s (2356 model) and soon going to get extra 3 cell UltraBay battery,

Does anybody know if the installation of tp_smapi (main implemented functionality is control of battery charging and extended battery status. The tp_smapi software package also includes an improved version of the HDAPS driver.) and HDAPS (Active Protection System Linux Driver) is very much a good idea to be installed; if so can anybody help how and where to get the relelvant packages for the openSUSE 12.2 and what to do install and make them run properly.

Thanks in advance.

Instead of tagging on to an older posting. Please start a new thread covering your new topic “tp_smapi”. Yes?

Whenever you require a software package, I always recommend navigating to Downloads → Search for Packages.
I have provided the link for you to click on tp_smapi. Click “Show unstable packages” and choose one of the repositories from the left column.
Add it to Yast for installation. After installation you must shutdown and reboot your laptop.

If you are using KDE navigate to Configure Desktop → Power Management. If you are using GNOME open the Control Panel.

Once you get things working, please navigate to our Hardware Portal, click on the Laptops link then IBM/Lenovo and add your laptop to the list.

T430s & openSUSE 12.2 doesn’t sound old post, besides having duplicate threads is not the best way to go.

Anyways, thanks a lot for the tips; noted. Will try as per your reco and post the info on notebook.
BTW, how aboud http://www.thinkwiki.org/wiki/HDAPS ? (Update: seems like the latest 0.41 tp_smapi kernel includes HDAPS)

P.S. In KDE 4.10 “Configure Desktop” = “System Settings”

It’s not a duplicate thread if your issue is different from the OP’s in an older thread (i.e. older iin time) . As Romanator said, you should start a new thread instead of tagging onto an older one, even if the platform is the same. Duplicate posting (strongly discouraged) is where the same issue is posted twice or more by the same user in any of the forums.

That helps by increasing the visibility of your issue, while avoiding the irritation caused by real duplicates. :slight_smile:

Does the freeze still happen with special desktop effects disabled?

Got it, will do so as. For me OP’s (i.e. older iin time, not Original Poster) is new jargon, haven’t been on the forum for around a year, as at one time i.e. before the three forums were merged I had over 10K posts. Another thanks for the tip.

In the meantime perhaps I should have a dedicated thread in Hardware for T430s & openSUSE so keep it up and updated (as I got this techie notebook recently) and as mentioned by Romanator to edit and add info on Hardware Portal.

In the meantime, if I may continue on the subject, I have installed the tp_smapi (kernel-desktop) and see no change in Power Management; gotta do more research on this and another issue with the built-in Fingerprint scanner, to make it work with openSUSE.

Thanks.

New thread on the topic as requested:

https://forums.opensuse.org/english/get-technical-help-here/laptop/483506-lenovo-thinkpad-t430s-t430u-t430-power-management-tp_smapi-hdaps-thinkpad_ec.html#post2529221

Right, OP still refers to Original Poster. You wrote “T430s & openSUSE 12.2 doesn’t sound old post”. That seems to be stating that since the platform is still current, then the post isn’t old. I was just clarifying what I meant by older, but could have been a little clearer with “older, as in time”, wrt an OP’s post. :slight_smile:

Good luck with the FP scanner. Mine is several years old, and still doesn’t work on openSUSE (W7 ok). YaST throws an error on configuration. It depends on an external project which seems to be well behind the curve on manufacturers’ product diversity, and they don’t have all the hardware to test. For me it’s not a must have feature anyway.