Lenovo T430 on Opensuse 12.2 wont work with second monitor

Hi guys,

I have a brand new Lenovo T420 and so far im pretty happy with the performance of it running on Opensuse 12.2. The only issue I have is that it will not work with an extra monitor. Doesnt work in the dock, and I have tried all 3 connections, Display plug, DVI and VGA. Also it will not work by just plugging into the VGA port on the laptop itself. Has anyone had this problem? If so how did you fix it. I have the Nvidia NVS 5400M graphics in this machine but Suse 12.2 only recognizes the Intel graphics chip. Thanks a ton for the help!

so after some reading, it seems like its not working because its not using the NVidia driver. So I have been reading some more and found how to install the driver for the nVidia card. I can not get that thing to work for the life of me. I have been following the SDB:NVIDIA the hard way guide. I am able to follow up until the part where it says to add “nomodeset” in /boot/grub/menu.lst and to add the modeset.nouveau=0 line…that file does not exist on my machine. Can anyone give me a hand with this?

A little more info might help with answers here:

  1. Which desktop environment are you using?
  2. Graphics chipset info. (A little googling suggests that you have the Intel HD4000 graphics, along with the NVS 5400m you mentioned). As you have a hybrid graphics system, have you tried installing bumblebee and suitable nvidia drivers? I don’t have an Optimus system, so can’t advise directly, but this thread may point you in the right direction.
/usr/sbin/hwinfo --gfxcard
  1. What does the following command report
xrandr

Reprt back with the requested information, and hopefully others more familiar with this hardware will chime in.

I think you’ll need to follow optimus-specific threads/guides…

This may be useful. Read it thoroughly first though)

Smithfarm - the Brain: openSUSE 12.2: How to install ‘bumblebee’ for NVIDIA Optimus VGA

Hi there. Sorry for leaving out that bit of info. Been one of those days.

  1. Gnome Desktop environment on Opensuse 12.2

10: PCI 02.0: 0300 VGA compatible controller (VGA)                [Created at pci.319]
  Unique ID: _Znp.xyab_qHvGD6
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel VGA compatible controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0166 
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x21f4 
  Revision: 0x09
  Driver: "i915"
  Driver Modules: "drm"
  Memory Range: 0xf1400000-0xf17fffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  I/O Ports: 0x6000-0x603f (rw)
  IRQ: 46 (319865 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00008086d00000166sv000017AAsd000021F4bc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=no, avail=yes, need=no, active=unknown


24: PCI 100.0: 0300 VGA compatible controller (VGA)
  [Created at pci.319]
  Unique ID: VCu0.GzbCgJWuFs9
  Parent ID: vSkL.ixb0O1BfT2D
  SysFS ID: /devices/pci0000:00/0000:00:01.0/0000:01:00.0
  SysFS BusID: 0000:01:00.0
  Hardware Class: graphics card
  Model: "nVidia VGA compatible controller"
  Vendor: pci 0x10de "nVidia Corporation"
  Device: pci 0x0def 
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x21f4 
  Revision: 0xa1
  Memory Range: 0xf0000000-0xf0ffffff (rw,non-prefetchable,disabled)
  Memory Range: 0xc0000000-0xcfffffff (ro,non-prefetchable,disabled)
  Memory Range: 0xd0000000-0xd1ffffff (ro,non-prefetchable,disabled)
  I/O Ports: 0x5000-0x5fff (rw,disabled)
  Memory Range: 0xf1000000-0xf107ffff (ro,non-prefetchable,disabled)
  IRQ: 11 (no events)
  Module Alias: "pci:v000010DEd00000DEFsv000017AAsd000021F4bc03sc00i00"
  Driver Info #0:
    Driver Status: nvidiafb is not active
    Driver Activation Cmd: "modprobe nvidiafb"
  Driver Info #1:
    Driver Status: nouveau is not active
    Driver Activation Cmd: "modprobe nouveau"
  Config Status: cfg=no, avail=yes, need=no, active=unknown
  Attached to: #9 (PCI bridge)


Primary display adapter: #10



Screen 0: minimum 320 x 200, current 1600 x 900, maximum 8192 x 8192LVDS1 connected 1600x900+0+0 (normal left inverted right x axis y axis) 309mm x 174mm
   1600x900       60.0*+   40.0  
   1024x768       60.0  
   800x600        60.3     56.2  
   640x480        59.9  
VGA1 disconnected (normal left inverted right x axis y axis)



You’re on a hybrid system. One thing you can’t do is installing the NVIDIA drivers from the default NVIDIA repo. You need Bumblebee, plus, if you want to use the NVIDIA for programs to run using it, the NVIDIA driver from the Bumblebee-Project repo. Search the forums for “NVIDIA Optimus”. If you don’t succeed, get back here tomorrow and ask for some more, it’s too late now, but tomorrow I could write up some instructions on how to get it done. Meanwhile get used to the idea of having to use the Intel for daily use, you cannot (for example) run the entire X session on the NVIDIA. Not yet, maybe.

Thanks for chiming in here Knurpht. Your in good hands now tbattista1 - Knurpht has experience with similar hardware and familiar with the steps required.

thanks a bunch. Ill give it a shot. Is there any benefit for me to even get it setup? I mean my biggest concern is getting my second monitor working. Is it indeed because of the video driver?

It’s weird that the second monitor doesn’t work. Can you tell us a bit more about how you got to this point. For example, is this a fresh install? Did you have the external monitor connected when you did the install?

On my system, which is running KDE, a monitor settings window pops up immediately when I connect the external monitor to my laptop’s VGA port. It sounds to me like you may have the external monitor disabled in the Gnome equivalent of system settings. Just a guess - something to look at.

If I’m not wrong, this laptop has a full three state mux for the graphics. Look into the BIOS settings and see if you can find a setting where you can switch between Integrated, Discrete and Optimus. If you have such a switch you might not need bumblebee at all, that’ll depend on how you intend to use the system. You can for example run the Nvidia graphics when on AC and the Intel graphics when on battery, lenovo has done there home work. It’s also very likely that you will need the Nvidia propiarity driver to set up an external display, but you wouldn’t need that when on battery? It’s possible to set up your system so that you can have direct rendering on both cards, but this alternative rules out Optimus and bumblebee.

Well something odd happened last night, my HDD decided to die, thankfully i had an extra SSD drive on hand. Popped it in reinstalled Opensuse this morning but installed 12.3 with KDE this time. First itme using KDE and i must say its very nice. I still however have the same issue with the second monitor. This time around I installed opensuse while the laptop was in the docking station and with the monitor plugged in and on. When I open Kinfocenter and go to Graphical info and click on X-Server, its not even recognizing the monitor, even though the monitor is on, and the light is green. Its getting some kind of a signal. If it wasnt the light would be amber. Its just a black screen. Not sure where to go from her. Thanks for the help guys!

You are correct, After i saw your post i went into Bios and found it. I set it to Discrete and when I try to boot the computer freezes during the boot process at:

doing fastboot
Creating nodes with udev

It wont move from that spot. So i thought maybe it needs to set like that before installing opensuse 12.3, but again it freezes during the boot process just before it goes into the installer.

You could try typing nomodeset on the command line after you have highlighted the installation option, most Nvidia cards needs that before you install the driver, but they usually don’t freeze that early. But it’s worth a try.

So I tried that, no improvement :’( still cant get that second monitor to work.

First of all, Kinfocenter is not the place to go, although I would be curious to hear what resolution the X server is reporting there.

Second, to enable your second monitor you should be going to “Configure Desktop”, which at least in openSUSE 12.2 is the KDE equivalent of “system settings”, “control panels”, or whatever you prefer to call it. You get there by hitting ALT-F2 and typing “configure desktop” and then hitting ENTER.

Once there, find “Display and Monitor” (in the Hardware section) and click on it. Tell us exactly what you see. Best would be to post a link to a screenshot.