Lenovo T420, Graphics cards not loaded properly KDE 13.2 64bit

Hello,

I’ve recently lost my Lenovo T410S, and replaced it with a T420.

1.I had Opensuse13.1 KDE 64bit originally on T410S, didn’t have any issues but switched to 13.2 because I was hoping some bugs were ironed out. 13.2 KDE 64 bit did not load graphic card properly on it.

  1. With T420, I installed 13.1 KDE 64bit, then after 10+ hours of customization, due to mistakes I’ve made on repos, scripts and few small things, an upgrade destroyed what I’ve worked on. It removed dolphin for example.
    After contemplating, I decided to give another shot at 13.2 KDE 64 bit, I spent 5 hours so far customizing it. I am having two problems:

a) codecs simply won’t install properly, I didn’t have this issue with 13.1 or on T410S. However, I’ve started a separated thread on that.

b) Graphic card is not loaded properly, on both T410S and T420, these are issues. I think I filed a bug report after being advised from someone at this forum, now with T420, I was able to run some cad programs and some games without any problems using 13.1 KDE.
With 13.2 KDE, I can’t load the cad problems and I cannot play the same games I installed the same way.

It’s been a while since I dealt with systems issues, please walk me through the process, what information you may need and etc. In case if you’ve read my other thread regarding 13.1 evergreen, please nevermind, I think I have a 256MB integrated graphics card instead of Optimus Nvidia 1GB. I would like to confirm this with terminal commands, but I don’t recall how.

After reading another thread, this may help:

Gyro:/home/SJL # hwinfo --gfxcard09: PCI 02.0: 0300 VGA compatible controller (VGA)              
  [Created at pci.328]
  Unique ID: _Znp.L_qGQ0CawLB
  SysFS ID: /devices/pci0000:00/0000:00:02.0
  SysFS BusID: 0000:00:02.0
  Hardware Class: graphics card
  Model: "Intel 2nd Generation Core Processor Family Integrated Graphics Controller"
  Vendor: pci 0x8086 "Intel Corporation"
  Device: pci 0x0126 "2nd Generation Core Processor Family Integrated Graphics Controller"
  SubVendor: pci 0x17aa "Lenovo"
  SubDevice: pci 0x21ce 
  Revision: 0x09
  Driver: "i915"
  Driver Modules: "drm"
  Memory Range: 0xf0000000-0xf03fffff (rw,non-prefetchable)
  Memory Range: 0xe0000000-0xefffffff (ro,non-prefetchable)
  I/O Ports: 0x5000-0x503f (rw)
  IRQ: 40 (150231 events)
  I/O Ports: 0x3c0-0x3df (rw)
  Module Alias: "pci:v00008086d00000126sv000017AAsd000021CEbc03sc00i00"
  Driver Info #0:
    Driver Status: i915 is active
    Driver Activation Cmd: "modprobe i915"
  Config Status: cfg=new, avail=yes, need=no, active=unknown


Primary display adapter: #9



Its possible the following command run in a konsole/xterm may also confirm this:


/sbin/lspci -nnk | grep VGA -A3

I guess it’s just the intel HD

Gyro:/home/SJL # /sbin/lspci -nnk |grep VGA -A300:02.0 VGA compatible controller [0300]: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller [8086:0126] (rev 09)
        Subsystem: Lenovo Device [17aa:21ce]
        Kernel driver in use: i915
        Kernel modules: i915



After searching I note that thread: opensuse 13.2 KDE 64 bit, missing codecs - Multimedia - openSUSE Forums From what I can read - that thread solved your ‘codec’ problem.

Honestly - IMHO - having all those repos is ‘asking for trouble’. I always stay with OSS, Non-OSS, Update, Non-OSS update and Packman. And no others. If I want an app on another I will add the extra repos, install the app,and remove the additional repos.

If cutting edge is what you are looking for (with the latest and greatest versions of the apps) then I would recommend either Tumbleweed or another rolling distribution. If you want stability, then keep your repositories to a minimum.

I searched a bit on the T420, and I could find no suggestion of generic graphic card problems. Which does not mean there are not any but it does suggest to me the problem could be elsewhere. Frankly, I would blaime the massive repositories that you have in place (from other thread). If you do continue to believe the problem is graphic card related, you could look at the /var/log/Xorg.0.log file to see if yields any hints.
.

Thank you, yes, the codec issues were indeed solved. It seems that I have Intel HD graphics 3000

SJL@Gyro:~> cat /var/log/Xorg.0.log |grep -i graphic     9.114] (II) intel: Driver for Intel(R) Integrated Graphics Chipsets:
     9.114] (II) intel: Driver for Intel(R) HD Graphics: 2000-6000
     9.114] (II) intel: Driver for Intel(R) Iris(TM) Graphics: 5100, 6100
     9.114] (II) intel: Driver for Intel(R) Iris(TM) Pro Graphics: 5200, 6200, P6300
     9.116] (--) intel(0): Integrated Graphics Chipset: Intel(R) HD Graphics 3000
SJL@Gyro:~> 



which makes sense after looking up at what my CPU is compatible with, and what the Lenovo base comes with, I may have a talk with the seller to see if he might’ve screwed up on the order, because I was convinced it came with dual graphics card. That aside, I’ve done this solution:

http://ubuntuforums.org/showthread.php?t=2042773

eliminating nomodeset in /etc/default/grub
from:

GRUB_CMDLINE_LINUX_RECOVERY="showopts apm=off noresume edd=off powersaved=off nohz=off highres=off processor.max_cstate=1 nomodeset x11failsafe"

I am not having issues with glitchy screen at some points anymore, but I am unsure if this solved it because I haven’t installed the same game yet.

Forgot to mention, Xorg.0.log was taken after I used the “solution”, I’m uncertain if there was a problem before, but the screen got glitchy in certain menus and etc.

That is an incredibly conservative - almost crippling is your grub command line. In fact, it is a grub recovery line and it should NOT be the normal boot code.

My boot has “showopts” and nothing else wrt boot codes. Possibly you need one or two of those boot codes, but I seriously doubt that you need them all.
.

nomode set loads older more generic and less capable drivers. Really not suited to games only there to allow booting if there is a graphics problem since they should work with about and hardware. It is normal used in the recovery boot option or added at boot to allow work if for some reason the better drivers fail.

Well, the game still doesn’t work.

I am going to change back the grub recovery line.

Why are you booting your PC from recovery mode ? You lose all sorts of functionality when you do that.

The recovery mode boot option should nominally not be touched, and instead you should have another option for nominal boot as the default. In that default boot option, you should have the bare minimal of boot codes needed to boot and no more than the bare minimal. Typically for each extra boot code you add, there may be some loss of functionality and change in behaviour, which can have consequences on applications, graphics, networks, etc …

I’ve been booting from regular mod, I just thought I’d try this method. No changes.

Just an addition, today many cards present them selfes as “3D” rather than “VGA”, so something like the following should be used to list them:

/sbin/lspci | egrep 'VGA|3D'
SJL@Gyro:~> /sbin/lspci | egrep 'VGA|3D'00:02.0 VGA compatible controller: Intel Corporation 2nd Generation Core Processor Family Integrated Graphics Controller (rev 09)