Lenovo T410 will not install 11.2 64bit

I have tried installing 11.2 64 bit with Gnome. Every time if finishes the install and reboots it will start HAL daemon and just black screen. I have tried loading with using the number 3 with no video. Same thing black screen after loading HAL daemon. I did a install with selecting VESA same thing. Any help would be great.

Do you eventually get a text log in screen after you press “3” in the grub/splash bot menu ?

Is it possible for you to tell us EXACTLY what graphic hardware your Lenovo T410 has? If it is possible, can you do so?

No I do not get a text screen after I push 3. The video card is a Intel Graphics Media Accelerator HD - AMT

Also it is a Intel Core I5

Do you get a text screen if you boot with the failsafe settings?

Is there not normally a model number associated with that? ie there is more than one model of the Intel Graphics Media Accelerator ??

No I do not get a text screen when I boot in safemode. Also the video is a Intel Graphics Media Accelerator HD - (Core i5) is all I can find out. Thank you very much for the help. Also I have checked the media and it is fine.

If you do not get a text screen with a regular boot (when typing “3” ) and if you do not get a text screen in failsafe, then there is likely nothing I can do. You could write a bug report on this: Submitting Bug Reports - openSUSE using your forum username and password, but I think your hardware is too new for openSUSE-11.2. In essence it does not look good for opensuse 11.2 with the 2.6.31 kernel.

Reference your graphic/video. …I then took a look at thinkwiki and read this: Intel HD Graphics - ThinkWiki

Note that states:

A very recent Linux distribution with kernel 2.6.33 and Intel Xorg driver 2.10 or newer is recommended.

Note openSUSE-11.2 comes with the 2.6.31 (not 2.6.33) kernel and it comes with the Intel Xorg driver 2.9.1 and NOT 2.10.0. OpenSUSE-11.3 (milestone releases) has the 2.6.33 kernel and the 2.10.0 Intel driver.

Hence IMHO you need to try the milestone3 release of openSUSE-11.3 even though it is not released and it is still buggy. openSUSE-11.2 simply is not new enough.

The link for that is here: Software.openSUSE.org

As a development release it will have more bugs and many 3rd party applications will not be packaged yet. Plus there will be thousands of updates coming as new milestone releases are output.

Perhaps the upside, if one has a positive attitude and is adventurous (with some time) is one can then write bug reports Submitting Bug Reports - openSUSE on this and have a big influence in the quality of the new openSUSE-11.3.

Sorry to read of your difficulty.

I do thank you for your time and will try 11.3. Again thank you.

@bryannash
On a slightly different tack, is this a dual-boot situation with say Win7? Did you first try h/w out successfully (or not) with the Gnome livecd?

I’m also interested as preparing for installing 11.2 onto new Lenovo SL510 but it’s different intel chipset to yours. Mine came with fully partitioned (3) disk, so can I assume you kept any Lenovo partitions intact from the openSUSE installation(?).

Yes it is with a duel boot with Windows 7. I deleted all the partions except for windows 7. Then tried the install with full dvd and gnome cd all to the same problem. It does resize windows 7 fine and I can boot to it after it does the first part on the 11.2 install.

@bryannash, thanks for your reply which helped to restore my confidence, since I hadn’t seen oldcpu’s last reply when I posted. The 11.2 kde4 livecd detects all the important h/w on my notebook, except the fingerprint rdr. That’s ok as it will be sorted out on a proper install. I’m hoping that the resize of the W7 partition will work even if I retain the lenovo recovery partition at the end of the disk. I’ve created lenovo’s factory recovery/restart cd/dvd’s, so if push comes to shove I can remove that recovery partition.

Hope the news wasn’t too disappointing for you, good luck with 11.3. Will look out for any of your posts re 11.3 - you will probably get to that before me on a lenovo, as it will likely hit the testing partition on the desktop pc first. :wink:

Exact same issue in a Lenovo T410I.

Hate to use another distro that works (Ubuntu) with this laptop. It appears that not many people are using Suse in Lenovo machines given the fact that this thread was almost hidden.

Did you try 11.3 milestone or Release Candidate?

As I noted, you need the 2.6.33 kernel at least, and hence 11.3 of openSUSE.

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

What kernel are you trying to install? kernel-desktop? I have a
similar problem with that kernel on an Acer Aspire One, desktop-kernel
and the system hang up loading udev after hal, try changing to
kernel-default


VampirD

Microsoft Windows is like air conditioning
Stops working when you open a window.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

iEYEARECAAYFAkwbxN0ACgkQJQ+0ABWtaVlF4QCgux3oQskxgdJEGYqowdqGdm7y
U+AAnjPEZkrh9D9ZiVrRWARXuNUS763y
=Gzh+
-----END PGP SIGNATURE-----

-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1

What’s the difference beetwen desktop and default kernel? I have
problems with many laptops if I install the desktop kernel that are
solved with the default :S


VampirD

Microsoft Windows is like air conditioning
Stops working when you open a window.
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v2.0.12 (GNU/Linux)
Comment: Using GnuPG with SUSE - http://enigmail.mozdev.org/

iEYEARECAAYFAkwbyRkACgkQJQ+0ABWtaVn60ACdEKDSi5Bo7IHV0PZDbOyeyYwN
B34AoJQb8FDj8hvRGARypJ1ULfEO1z4V
=VI6p
-----END PGP SIGNATURE-----

Main difference is how time slices are allocated. Default is more optimized to server loads. Where desktop is optimized for desktop operations.

I had the same problem with installing 11.2 on a T410. After rebooting during the install a black screen. In my case it turns out that there was no xorg.conf file. I solved this as follows:
-) go into rescue
-) mount the / disk
-) cd into /etc/X11
-) cp xorg.conf.install xorg.conf
-) unmount the / disk
-) reboot and finish the installation.

Hopefully this helps for yo as well.

By default there is no Xorg.conf on 11.2+ In 11.3 they get rid of sax2 entirely.