Lenovo SL510 & acpi

I am eagerly awaiting my newly purchased lenovo sl510 and once received intend on loading opensuse 11.3 onto it as my primary os.

I understand this particular laptop has had some issues with acpi.

Can anyone comment on how this is now with newer kernel releases since the default installed with the opensuse 11.3 DVD.

Thanks

It has similar spec to my G550, assuming you bought the Intel Graphics one.
Other than that I can’t really comment. But for me everything is perfect.
Only the 550 came with the One Key Recovery and 4 Primary Partitions - not a problem because I wiped the HD anyway.

apparently the sl410 & 510 come with ideapad firmware and have some issues with the thinkpad acpi module in linux.

There was supposed to be some work being done though to get it working - particularly fan control - so I was wondering if this is sorted now for these particular modules with kernel 2.6.34.7-0.5.1

I can’t say I know
But I guess you’ll find out soon enough

Yes you are correct about the ideapad firmware, so thinkpad_acpi is a non-starter. My SL510 is now a year old, and yes there are a few issues remaining for linux. However, generally it worked well on 11.3 with the standard distro (KDE4 or Gnome) now fully upgraded including all official kernel updates.

I found thisThinkWiki page for SL510 generally useful.

However that still leaves a problem for full-screen Flash not working with the “intel” graphics driver, but windowed Flash is fine. Alternatively you can use “intellegacy” driver, as a workaround for the full-screen Flash problem, but that driver won’t receive any attention from devs, so no good for the longer term. Please see this post of mine for the original bug reference (closed), and an update on the problem concerning progress with a then newer kernel version.

Correct LCD resolution always worked OOTB with the standard distro.

Backlight controls work through ACPI video, but level gets reset on reboot. Hardly any of the special function keys work OOTB with linux/openSUSE. General ACPI modules (battery, processor, thermal, video) work. Gnome seems to support the power management functions on SL510 better than KDE4. In either case, you can use terminal commands such as:

xbacklight --help shows how to display and adjust the backlight

usage: xbacklight [options]
  where options are:
  -display <display> or -d <display>
  -help
  -set <percentage> or = <percentage>
  -inc <percentage> or + <percentage>
  -dec <percentage> or - <percentage>
  -get
  -time <fade time in milliseconds>
  -steps <number of steps in fade>

acpi -V reports

     Battery 1: charging, 99%, 00:02:26 until charged
     Thermal 1: ok, 37.0 degrees C
  AC Adapter 1: on-line

sensors reports

acpitz-virtual-0
Adapter: Virtual device
temp1:       +37.0°C  (crit = +105.0°C)                  

coretemp-isa-0000
Adapter: ISA adapter
Core 0:      +30.0°C  (high = +105.0°C, crit = +105.0°C)  

coretemp-isa-0001
Adapter: ISA adapter
Core 1:      +32.0°C  (high = +105.0°C, crit = +105.0°C)

Haven’t noticed any issues with the fan, as the operating temps look ok. The fan is not on much of the time, so it’s quiet. It seems to come on during reboot, for example.

Suspend to Disk worked OOTB, but Suspend to RAM has never worked. The machine will never wake up from suspend to ram, you have to hold down the power on/off button for several seconds to restart the SL510. It only works properly on W7.

Thanks - that is a most helpful post.
It seems the unit is probably better supported than I had anticipated.
I’m expecting delivery in the next couple of days so will post back if I have any issues / questions.

Thanks again.

all installed and working well.
Had an issue with getting the wireless adapter to work but after adding the wireless rep all fixed up.

Am having trouble getting the built in microphone to work though.
Any ideas on that?

Gnome or KDE installation?

Have you tried setting Front Mic Boost and Capture channels to max in your mixer? Then if working you can adjust down as necessary. I will try mine as well.

BTW it would be useful to compare/confirm what else doesn’t work e.g. some Fn key combinations (Fn + Delete/Home works ok for LCD brightness).

KDE 4.4.xx

Have it half sorted but seeing some strange behaviour. Started a thread here

fn+Delete+Home work fine for brightness
Volume buttons work fine as does the mute button
fn+F4 puts to sleep
fn+PrtSC is fine

few more to try yet I guess.

Thinkvantage button doesn’t do anything - but that is not surprising as that is windows software.

Haven’t been able to reproduce the flash video prob you have.
I did have that problem on my Thinkcentre - but was fixed with a kernel update a few months back.

Good idea! Thanks for the link. You are ground breaking there, as I haven’t needed to record with the mic (yet!).

Volume buttons work fine as does the mute button

Agreed, but watch out for a regression on newer kernels if the mute button’s backlight doesn’t come on when pressed. Seen the bug posted on ubuntu, and experienced here on kernel-desktop 2.6.36 versions.

fn+F4 puts to sleep

Important question for clarification: Yes it puts it to sleep, but does your m/c wake normally? I ask, because your machine should have come with a newer BIOS(?). Thus far, I haven’t updated my BIOS.

fn+PrtSC is fine

Useful to know as I haven’t needed that one so far.

Yes, not expecting Thinkvantage button to do anything under linux.

I did have that problem on my Thinkcentre - but was fixed with a kernel update a few months back.

Yes, I noticed an improvement with that kernel update. Instead of Flash full-screen freezing immediately, it starts ok but after a short while it fails. I suspect display power management (KDE settings) may trigger it, but need to investigate further.

see any advantages / improvements in the newer kernel? Wireless adapter support built into this kernel?

Important question for clarification: Yes it puts it to sleep, but does your m/c wake normally? I ask, because your machine should have come with a newer BIOS(?). Thus far, I haven’t updated my BIOS.

seems to work as it should.
Goes to sleep. Get a pulsating power button (same as in windows)
Hit the power button and machine wakes to a black screen.
Move the mouse and get a login dialogue.
enter password and back as it should be.
Does let out an almighty beep when clicking the power button to wake though.

Difficult to say as I have KDE 4.5.4 on the same system, and the quicker firmer feel could KDE. Don’t use wireless regularly on here. But when I did try a very old Belkin wireless router, I didn’t need to install any module/packages unsurprisingly.

seems to work as it should.

Not here. Sleep button (Fn + F4) operates on standard kernel, but does nothing on 2.6.36.2-3 (KDE 4.5.4).
Goes to sleep if button set (KDE) to Suspend (to RAM). Get a pulsating power button (same as in windows), and flashing crescent moon led (on right front edge).
Hit the power button: nothing, no wake-up.
Hold power button down several seconds gives power-off reset.
Hit the power button for power-on reboot.

On standard 11.3, if Sleep button (Fn + F4) set (KDE) to Hibernate, that works properly saving to HD and powers off. Pressing power button restores with fast boot to previous desktop displayed with working network.

If you have time, please post back with your BIOS release level.

Thanks.

It wasn’t DPMS (KDE settings), that works without interference, but it was the KDE blank screensaver timed in at 4mins. Turned it off, and no further problems on kernel-desktop 2.6.34.7-0.7 :wink:

Here are the differences for thinkpad_acpi with the newer 2.6.36 kernel. It’s not complete support, but it’s improving. I believe the auto muting of speakers on plugging headphones in, is fixed in kernel 2.6.37, but I haven’t tried that yet.

With kernel-desktop 2.6.34.7-0.7, /var/log/boot.msg contains the line:

<3>   16.498777] thinkpad_acpi: Not yet supported ThinkPad detected!

With kernel-desktop 2.6.36.2.3, /var/log/boot.msg contains the lines:

<6>   16.293829] thinkpad_acpi: ThinkPad ACPI Extras v0.24
<6>   16.293831] thinkpad_acpi: http://ibm-acpi.sf.net/
<6>   16.293833] thinkpad_acpi: ThinkPad BIOS 6JET58WW (1.16 ), EC 6JHT48WW-1.168000
<6>   16.293835] thinkpad_acpi: Lenovo ThinkPad SL510, model 28473PG
<6>   16.294147] thinkpad_acpi: detected a 8-level brightness capable ThinkPad
<6>   16.294902] thinkpad_acpi: radio switch found; radios are disabled
<6>   16.294913] thinkpad_acpi: possible tablet mode switch found; ThinkPad in laptop mode
<5>   16.296236] thinkpad_acpi: asked for hotkey mask 0x078dffff, but firmware forced it to 0x008dffff
<5>   16.299269] thinkpad_acpi: setting the hotkey mask to 0x00ffffff is likely not the best way to go about it
<5>   16.299271] thinkpad_acpi: please consider using the driver defaults, and refer to up-to-date thinkpad-acpi documentation
...
<6>   16.310847] thinkpad_acpi: rfkill switch tpacpi_bluetooth_sw: radio is blocked
<7>   16.311978] Registered led device: tpacpi::thinklight
<7>   16.312210] Registered led device: tpacpi::power
<7>   16.312274] Registered led device: tpacpi::standby
<7>   16.312473] Registered led device: tpacpi::thinkvantage
...
<6>   16.331477] thinkpad_acpi: Standard ACPI backlight interface available, not loading native one.
<6>   16.331658] thinkpad_acpi: Console audio control enabled, mode: monitor (read only)
<6>   16.338238] input: ThinkPad Extra Buttons as /devices/platform/thinkpad_acpi/input/input9

The module thinkpad_acpi is loaded, and you can also see what other modules it uses (rfkill and snd):

lsmod | grep thinkpad_acpi
thinkpad_acpi          79217  0 
rfkill                 21843  2 thinkpad_acpi,cfg80211
snd                    83579  16 snd_pcm_oss,snd_mixer_oss,snd_seq,snd_seq_device,snd_hda_codec_intelhdmi,snd_hda_codec_realtek,snd_hda_intel,thinkpad_acpi,snd_hda_codec,snd_hwdep,snd_pcm,snd_timer

looks like support for the SL510 has greatly improved in the 2.6 kernel (I think this was indicated in the thinkwiki)
What kernel is Opensuse 11.4 going to ship with?

Kernel 2.6.37 for 11.4, IIRC.

After I installed kernel-desktop 2.6.36.3-4, I noticed some additional hardware “sensors” being reported for the thinkpad isa adapter, including the fan. Results from running the “sensors” command line applet are shown here:

sensors
acpitz-virtual-0
Adapter: Virtual device
temp1:       +48.0°C  (crit = +105.0°C)                  

thinkpad-isa-0000
Adapter: ISA adapter
fan1:        653 RPM
temp1:        +0.0°C                                    
temp2:       +48.0°C                                    
temp3:        +0.0°C                                    
temp4:        +0.0°C                                    
temp5:        +0.0°C                                    
temp6:        +0.0°C                                    
temp7:        +0.0°C                                    
temp8:        +0.0°C                                    

coretemp-isa-0000
Adapter: ISA adapter
Core 0:      +43.0°C  (high = +105.0°C, crit = +105.0°C)  

coretemp-isa-0001
Adapter: ISA adapter
Core 1:      +44.0°C  (high = +105.0°C, crit = +105.0°C)

The fan is at zero most of the time, so I had to load the processors with a high quality Flash video, and a few other resource eating apps. The fan appears to kick in/out when the temp goes past 40C or thereabouts.

BTW, the “sensors” package is not installed by default, but is available from the normal 11.3 Oss repo. You have to run “sensors-detect” as root, to pick up hardware sensors. It will ask you to confirm any actions and at each detection attempt. You can safely press enter to default each Yes reply.

Having recently upgraded kernel-desktop to 2.6.37-8, “sensors” continues to deliver the same results, but “acpi -V” lost the temperature report as here:

acpi -V
     Battery 1: charged, 100%
No support for device type: thermal
  AC Adapter 1: on-line

With the 2.6.37 kernel installed, I can confirm that the speakers are now automatically muted on plugging in headphones. However, keying Fn+F4 now does nothing where before it initiated Suspend. Fn+F12 to Hibernate still does nothing along with several other Fn thinkpad functions. Microphone mute and ThinkVantage buttons still appear to do nothing.

Progress is definitely being made, but slowly. :slight_smile:

:slight_smile:

does it suspend to ram by itself with the latest kernel?
If it does, can it be awoken? awaken? whatever that word is? :slight_smile:

Still no successful suspend to ram here. Even tried it from runlevel 3 using pm-suspend. It cannot awaken or be awoken, and appears to go deeper on attempts to wake it. Then a very long press on the power button is needed for a full power off, to enable a power-on reboot. It’s almost certainly a lenovo problem, and probably requires exactly the same BIOS and/or firmware update as shipped with your SL510. Not sure that it’s available as a download yet.

Hibernate still works from the desktop shutdown menu, but Fn+F12 does nothing.

BTW the internal Mic still works first time and every time, with 2.6.37-7.