Lenovo S10-3 Opensuse 12.1 internal Microphone

Hi all,

I’m wondering if anybody got the internal microphone working properly?

I’m struggeling with the settings.
The Lenovo uses: Intel Corporation N10/ICH 7 Family High Definition Audio Controller
with the ALC272 codex.

So the snd-hda-intel drive should be a good start.
I played around with the “model” option, like lenovo, basic, laptop. etc.
But even if the internal mic was seen, I only got noise recordings. The exteernal one works fine.

The Lenovo comes with a splashtop kernel for quick boot as well. The splashtop implementation work pretty well with the microphone, so there must be a solution for linux.

Does anyone got the internal micro working??

Thanks
Eric

The internal mic works fine on my wife’s Lenovo x220 with a 64-bit openSUSE-12.1 and KDE desktop. The same is true for my old Dell Studio 1537 laptop.

I recommend you install the application pulse audio volume control (pavucontrol) and use that to tune your internal mic. I provided an indication as to how that can be done in this blog posting : Pulseaudio Basics for openSUSE with pavucontrol - Blogs - openSUSE Forums

If that does not help, can you :

/usr/sbin/alsa-info.sh 

and select the SHARE/UPLOAD option and after the script finishes it will give you a URL to pass to the support personnel. Please post here the output URL/website-address that gives. Just the URL/website-address. You may need to run that script twice (the first time with root permissions to update in the /usr/sbin directory, and the second time to get the URL).
.
Note if for some reason that gives you no website/url/address then run it with the no-upload option:

/usr/sbin/alsa-info.sh --no-upload

and post the file /etc/alsa-info.txt it creates to Pastebin.comand press SUBMIT on that site and again post here the URL/website-address it provides.

.
… some clarification on running the script “alsa-info.sh” … when you run:

/usr/sbin/alsa-info.sh 

you should get something like this (if it asks for an update, select NO):
http://thumbnails33.imagebam.com/9280/a5973e92794041.jpg](http://www.imagebam.com/image/a5973e92794041)

followed by this (select the SHARE/UPLOAD option):
http://thumbnails30.imagebam.com/9280/5e84f992794044.jpg](http://www.imagebam.com/image/5e84f992794044)

followed by this (its quickest if you simply select ‘NO’ to seeing the output - you will see it on the web page) :
http://thumbnails32.imagebam.com/9280/214da092794048.jpg](http://www.imagebam.com/image/214da092794048)

followed by this (where in RED is the URL).
http://thumbnails23.imagebam.com/9280/d9858092794051.jpg](http://www.imagebam.com/image/d9858092794051)

Just post the URL you get (similar to the RED URL in my example, but yours will be different).

Again, if you can not get that, then run this with the no upload option:

/usr/sbin/alsa-info.sh --no-upload

which will create the file /tmp/alsa-info.txt. Copy that file and paste it on Pastebin.com and press submit. That will give you a URL address. Please post that URL here.

That will give us some information such that we can better understand your problem.

Hi oldcpu,

upload=true&script=true&cardinfo= !!################################ !!ALSA In - Pastebin.com here is the pastbin.

I set the model=asus-mode1 with this mode I can see an internal and an external micro.
The external works perfect. From the internal, I only get hissing and noise…

Thanks

Can you please tune your mixer and run that script again and post here the output, BUT first tune your mixer. Your mixer is setup such that it can’t possibly capture sound with the internal mic, and I can only think that you did not tune your mixer before running the script.

Here is what I note:


**Simple mixer control 'Mic Boost',0**
  Front Left: 0 **[0%]** [0.00dB]
  Front Right: 0 **[0%]** [0.00dB]
**Simple mixer control 'Digital',0**
  Front Left: Capture 0 **[0%]** -30.00dB]
  Front Right: Capture 0 **[0%]** -30.00dB]
**Simple mixer control 'Input Source',0**
  Capabilities: cenum
  Items: 'Internal Mic' 'Mic' 'Internal Mic 1'
  Item0: **'Mic'**
**Simple mixer control 'Internal Mic',0**
  Front Left: Playback 0 **[0%]** -34.50dB] [on]
  Front Right: Playback 0 **[0%]** -34.50dB] [on]
**Simple mixer control 'Internal Mic Boost',0**
  Front Left: 0 **[0%]** [0.00dB]
  Front Right: 0 **[0%]** [0.00dB]

Note internal mics are typically digital. Your mixer has digital capture at 0% (muted). Your internal mic is not selected. Boost is at 0%. Clearly, the mixer is not tuned for the internal mic.

You must address that.

Now if tuning the mixer does not help, reference the model option, there are many to choose from. Did you try others ? I note this from the HD-Audio-Models.txt file for the alc722 that is on your PC:


ALC662/663/272
==============
  3stack-dig	3-stack (2-channel) with SPDIF
  3stack-6ch	 3-stack (6-channel)
  3stack-6ch-dig 3-stack (6-channel) with SPDIF
  6stack-dig	 6-stack with SPDIF
  lenovo-101e	 Lenovo laptop
  eeepc-p701	ASUS Eeepc P701
  eeepc-ep20	ASUS Eeepc EP20
  ecs		ECS/Foxconn mobo
  m51va		ASUS M51VA
  g71v		ASUS G71V
  h13		ASUS H13
  g50v		ASUS G50V
  asus-mode1	ASUS
  asus-mode2	ASUS
  asus-mode3	ASUS
  asus-mode4	ASUS
  asus-mode5	ASUS
  asus-mode6	ASUS
  asus-mode7	ASUS
  asus-mode8	ASUS
  dell		Dell with ALC272
  dell-zm1	Dell ZM1 with ALC272
  samsung-nc10	Samsung NC10 mini notebook
  auto		auto-config reading BIOS (default)

here is the new pastbin
alsa-info.txt - Pastebin.com

I changed the mixer stuff. Also I tried with other model. Nothing changed…

Did you restart the sound driver between each change of model ? If not, then it was not done properly and results will be misleading.

If you did then IMHO you need to write a bug report on this, which will get the attention of the SuSE-GmbH packager, who is also an alsa sound developer, and he will fix the problem, not only for you but for all users of same model laptop. There is guidance here for raising bug reports: openSUSE:Submitting bug reports - openSUSE you can use your openSUSE username and password to log in to bugzilla. Raise the bug report against component ‘sound’. Attach to the bug report the file /tmp/alsa-info.txt that you get by running:


/usr/sbin/alsa-info.sh --no-upload

and ensure your bug report is complete. Do not bother to reference this thread as the SuSE-GmbH packager will refuse to read it. The bug report needs to be complete.

In parallel, you could also try updating your alsa* versions (and install the kmp-desktop ) (which are version 1.0.24) to the latest 1.0.25, where I wrote a guide here how to do this: SDB:Alsa-update - openSUSE be careful in updating as > 50% users fail to update, or say there is no update when there is, and all they show is they do not know how to use YaST to update. Ensure you reboot after updating before testing.

Solved it :slight_smile:

with kernel 3.2.6-1-desktop it works fine out of thebox

Thanks

I note the current openSUSE-12.1 kernel is the 3.1.9-1.4-desktop.

When using kernel versions that are NOT tested with the release (such as your previous 3.2.0-7-desktop kernel) these sorts of things can happen. I recommend in future help requests, that you specifically note you are not using a nominal kernel release (that is packaged with openSUSE). This is absolutely KEY information to bring to the attention of anyone monitoring the thread/and/or trying to help.

Glad to read the newer kernel has this working. I just hope the newer kernel has not broken something else.