Lenovo Notebook Freezing In When Closing The Lid

Hello to everyone,

I just installed openSUSE on my G510 Lenovo Notebook. All works fine with one exception: Whenever I close the lid of my notebook, my notebook hibernates and when I try to resume the notebook freezes (nothing appears; blank screen). I’d like the notebook to do nothing when I close the lid. I tried the following things until now (without success):

  • I went to “System settings / Power”. Problem: there aren’t any options asking me what to do when I close the lid.
  • I downloaded the “Gnome Tweak Tool”. There is an option asking me what to do when I close the lid - when I chose “Nothing” there, nothing changes (the notebook keeps going to hibernate when I close the lid).

The only thing that works is when I add the parameter “acpi=off” to the bootloader. The problem is: I read that this should be the last step to take since this turns off even the cpu ventilator which is really bad.

Do you have an idea how I can prevent the notebook from going to sleep when I close the lid without turning off the hole ACPI?

Product Name: Lenovo G510
BIOS Version: 79CN36WW(V2.00)
EC Version: 79EC36WW(V2.00)
Lenovo SN: CB26487689
Board Number: 3268085900647
UUID Number: 9D521728-2992-11E3-A967-201A062EDD5C

Thanks in advance,

Hi, welcome

Are you running KDE or GNOME, I’m asking since you say you downloaded gnome-tweak-tool, which should be installed by default on a GNOME install IIRC.
In KDE, you configure this behaviour through Systemsettings - Power management. You can even set different behaviour for working on battery.


Thanks for your response. I’m running GNOME. Didn’t know that the gnome-tweak-tool was already installed.
In GNOME also you can normally configure this behaviour through Systemsettings-Power management. But as I described in my first post, an option “action when closing the lid” is missing there.
And changes made to the Gnome Tweak Tool are simply ignored by the system.

I just fixed the problem thanks to this article:

I did exactly the same thing, I rebootet and it worked. Thank you very much for your help.