Lenovo notebook - critical battery issues

Hi I have a Lenovo notebook and I just installed OpenSuse 13.1, default installation.
I have a little issue with my power saving mode, when the battery arrives at 8% (critical battery in my settings), the notebook should go in sleep mode, but it makes nothing and the notebook dies below my eyes :frowning:
In the message log I don’t find any errors regards acpi, can you help me to understand and fix this issue?

Could depend on what model of lenovo notebook and what desktop environment you installed, so it may help to share that info. :wink:

sure!! :slight_smile:
I have a thinkpad x230 with KDE installed. I hear this issue many times from thinkpad users… I don’t know if it’s a bug or less but I’d like only fix it… if it’s possible :slight_smile:

The Lenovo Thinkpads have been supported on this forum for a long time.
Since you are using the X230, I would highly recommend reading this Archlinuxwiki link below:

https://wiki.archlinux.org/index.php/Lenovo_ThinkPad_X230

Install the package “tlp” from this link: http://software.opensuse.org/package/tlp
Also install “powertop” to monitor your power usage from konsole or xterm.

To install from konsole or xterm. Type:

zypper in powertop

tlp
Advanced energy-saving tools for laptops

           TLP is a collection of scripts enabling laptop-mode and implementing power save features for Thinkpad laptop hardware. 

Configuring TLP
http://linrunner.de/en/tlp/docs/tlp-linux-advanced-power-management.html

Additional help for Thinkpads can be found on the Thinkwiki website:
http://www.thinkwiki.org/wiki/Thinkpad-acpi#Thinkpad-specific_ACPI_driver

Most of the power saving features are now controlled with the kernel. Copy the code below and append to /etc/default/grub:

GRUB_CMDLINE_LINUX_DEFAULT="quiet ipv6.disable=1 elevator=bfq"
GRUB_CMDLINE_LINUX="init=/usr/lib/systemd/systemd pcie_aspm=force acpi_backlight=vendor" 

Next open konsole or xterm and type " su - " (without the quotes). Copy and paste the line below and run:

gurb2-mkconfig -o /boot/grub2/grub.cfg

Shutdown and restart your laptop.

Together with “tlp” and the modified /etc/default/grub, you should see about 70% improvement on battery performance.

Follow Up

Adding the code below to the kernel command-line may save some further power.

i915.i915_enable_rc6=7 i915.lvds_downclock=1

thanks at all :slight_smile:
I followed all yours advice but:

  1. when I put
    grub2-mkconfig -o /boot/grub2/grub.cfg
    Generating grub.cfg …
    Found theme: /boot/grub2/themes/openSUSE/theme.txt
    Found linux image: /boot/vmlinuz-3.11.10-21-desktop
    Found initrd image: /boot/initrd-3.11.10-21-desktop
    Found linux image: /boot/vmlinuz-3.11.10-17-desktop
    Found initrd image: /boot/initrd-3.11.10-17-desktop
    /dev/sdb: open failed: No medium found
    No volume groups found
    done

why I obtain this strange error??

  1. at boot I obtain:
    scheduled bfq: not found

can you help me?

Since your main drive is sda - the second drive is sdb. Do you have another drive enabled? Check your BIOS.

  1. at boot I obtain:
    scheduled bfq: not found

can you help me?

The entry "elevatoe=bfq is a flag for “Budget Fair Queueing”. Some distros have it enabled by default. However it isn’t enabled by default in this kernel.
**
Budget Fair Queueing** is a disk scheduler which allows each process/thread to be assigned a portion of the disk throughput.
It is supposed to improve throughput to your hard drive and SSD.

Please read: http://algo.ing.unimo.it/people/paolo/disk_sched/ How to enable: https://wiki.archlinux.org/index.php/linux-ck#How_to_enable_the_BFQ_I.2FO_Scheduler

Remove the entry “elevator=bfq” from /etc/default/grub so that it looks liked the example below:

GRUB_CMDLINE_LINUX_DEFAULT="quiet ipv6.disable=1"

And rerun:

grub2-mkconfig -o /boot/grub2/grub.cfg

Important
For optimizing your power settings for Intel please read: https://wiki.manjaro.org/index.php?title=Optimized_power_settings

I followed your advice but the problem it’s yet here with me :frowning:
I reinstalled opensuse 13.2 but no fixed it.
someone has the same issue?
thanks