Lenovo Ideapad Z585 - Cannot install Suse

I have been trying to install OpenSuse on a Lenovo Ideapad Z585.

Having spent hours researching the issue I have burned an ISO to both a DVD and a USB stick.

Both boot to the install options, when I select the installation or live option the kernel loads then I get a black screen with a blinking cursor.

I have checked the bios, secure boot is turned off and I ensured that Legacy settings are used instead of UEFI.

I also changed setting to allow any OS to be installed.

I am stumped. I have tried just about everything that has been suggested but cannot get passed this.

I would class myself as having an intermediate level of understanding of Linux and Suse in particular having used it for a number of years on my old machine.

Please help!

What video chip/card?

Did you try a noKMS option in video modes I think it is F3 says on bottom of screen anyway

Sorry for the delay in responding.

The video card is an AMD A8-4500M APU with Radeon HD Graphics 1.90Ghz.

I have tried the noKMS option and try to boot to the live version. When it gets to a certain point I am told that Gnome 3 has failed and I get a basic gnome desktop. When I then try to install from the drop down menu it crashes after it gets to the partitioning section.

I have tried all sorts of different combinations and to be honest am about ready to give up.

I have also tried other flavious of Linux and have the same issue with them all.

Were all of these combinations with Gnome desktop ? Did you try to boot to a KDE liveCD or XFCE liveCD desktop ?

In all cases did you conduct an md5sum check of the downloaded .iso file, against the md5sum on the website from whence you obtained the .iso file ?

Some things to consider (which are only very remote possibilities but IMHO need to be checked) : Did you ensure the media is not an issue ? ie did you burn on the same PC (as the install is being attempted) ? … When burning did you burn to a high quality +R or -R media and not to an RW ? Also to a high quality name brand and not some bargain basement special? Did you burn at the slowest speed your burner allows ? Any chance the DVD reader in your PC is faulty ?

Did you try the safe F4settings boot ? How about an F3 text mode boot ? (user name ‘linux’ and password is < enter > ) . If those work you could install from either. It would be useful 1st thou, to find confirmation this is not a gnome specific problem with your graphic hardware.

I note if this is a GPT formatted hard drive issue then it may also be more complex than what I can do to help, and we may need one of our Secure-Boot/UEFI/GPT knowledgeable forum members to step in and provide advice.

Thanks for the response.

I have tried Gnome, KDE and XFCE.

Medium has been checked, checked again. I have burned it using two different DVD drives. I have also used two different usb drives when creating bootable usb.

As stated I have tried the no aspci option, the noKMS option and have also tried some of the numerous boot commands metioned on the net.

Same results with them all.

Windows 7 boots with no problems at all, as does an old Windows XP disk I had lying around. Linux however does not get on with this macine.

According to linlap: Lenovo IdeaPad Z585 [Linux Laptop Wiki] GNU/Linux does work with this laptop.

But also according to linlap, you should leave the UEFI setting enabled and not use legacy. In which case, you may wish to consider this thread that I started to learn more on the UEFI subject: https://forums.opensuse.org/english/get-technical-help-here/install-boot-login/485517-opensuse-windows8-dual-boot-installation-questions-secure-boot-uefi-gpt.html and also this blog entry: Notes on UEFI, Windows and linux | Thoughts on computing

Some light reading?

Thanks for you help, I will get into to it see what happens.

Good luck on this. I would help more if I could, but I won’t have in my possession my first UEFI laptop until another 2+ weeks. Hence I am also still in the reading/researching stage and I can not provide specific guidance. It does appear to me though you may need to boot with secure boot disabled, UEFI enabled, and use a GPT partitioning.

Do the liveCD/DVD’s boot ok with secure boot disabled and UEFI enabled ? If so, that might provide a hint that this is the right path to follow.

I have now spent most of the night trying to get this to work, taking into account the information listed via the links in the last post. I have managed to get absolutely nowhere. The only thing I have done is managed to damage my windows 7 installation. I don’t have enough time to spend on this so I am going to call it a day and stick with the dreaded windows, I don’t even like saying that but with the lack of support available at the moment I don’t have enough time to try and sort this out by myself. My thanks to the continbutors on this thread, you have been my only friends on this issue.

Sorry to read that this did not work, and that you damaged the one OS that would work.

When and if the time comes that you are ready to look at this again, it would be useful to learn if with Secure boot disabled, but with UEFI enabled, whether a boot to a liveCD/DVD (but do NOT install and do not touch the hard drive) works.

Best wishes.

Unfortunately with my machine, if you enable UEFI it automatically enables secure boot. You cannot disable secure boot unless you disable UEFI first. The only sort of result I got was from live CD’s.

One thing of note, I used the vesa display component command at the boot screen which is the only thing that got me any further than the grey screen with the blinking cursor!

So as well as everything else, it would appear the video adapter also causes problems.


I recommend you check for a Firmware update.

The linlap article on your laptop contradicts what you noted, and the only explanation I can come up with for the contradiction is the firmware version in your Lenovo is different than the firmware in the Lenovo of the user reporting in linlap. I note:

The first thing I checked was that the firmware was the latest version.

In the boot section of the Bios the Boot Mode has two options - Legacy First and UEFI. If you select UEFI it does not allow you to disable secure boot. The second option is Boot Priority, again it gives two options - Legacy first and UEFI. With either selected you can disable secure boot.

So you cannot have UEFI Boot Mode.

You have to have Legacy First as the boot mode and UEFI as the boot priority.

I have checked and doubled checked this to the point of having it all written down.

I hope that makes sense.

Writing down is good. I always write down (or do a screen print, or take a picture with my digital camera of my screen) of changes that I do to a configuration. IMHO to do anything less is to simply invite chaos.

You could, if you have not already, ask about this here: Linux Discussion - Lenovo Community I see a number of Z585 users have asked questions on that Lenovo Linux forum.

My not having the Lenovo, and only having the Internet, I can only go by what other’s post. I can’t explain why the user posting on linlap posts about a configuration that you note to be impossible.

I do note that users who succeeded in installing GNU/Linux would for use the boot code ‘acpi=off’. I assume you tried that.

The perplexing thing is, this is a really nice machine, it ticks all of the boxes. I am certain that Suse is the OS for this laptop and I will get it on here one way or another.

I think the main issue is me! I am used to things working right first time with Linux, I guess I will have to adjust my perspective.

Don’t be put off buying one of these (no matter how it is badged).

I am pretty sure it will all fall into place sooner or later.

Take care and thanks for the input.

I like Lenovos. My wife has a Lenovo X220, which is small and lightweight. Ideal for travel. Fortunately for her and for myself, installing openSUSE on her X220 was a breeze (the X220 has nominal boot with regular BIOS and MBR partitioning).

Secureboot, UEFI, and GPT adds a new dimension to this. There is also a lot happening in GNU/Linux currently with the kernel modesetting being used, as sometimes graphic devices don’t work automatically with kms. openSUSE also implemented ‘plymouth’ as a splash boot screen and unfortunately for some hardware (such as my old radeon hd3450) plymouth can cause problems (I need to disable it at boot to achieve a reliable boot).

I have some ideas as to what I would try if I were in your shoes, but since I have no secureboot, nor UEFI, nor GPT experience, my views are too speculative to suggest. Its possible (1) my views are no good and (2) you may have tried such already.

Hence lets hope instead that with time this is sorted, either via someone succeeding with a clear explanation (as most users who succeed with the Z585 and GNU/Linux appear to have a very fuzzy idea as to how they succeeded) or via someone with very clear secureboot/UEFI/GPT understanding together with a clear understanding as to how openSUSE has implemented this.

What you could do is write a bug report on openSUSE installation failing on the Lenovo IdeaPad Z585. That will get the Nurnberg SuSE-GmbH expert packagers of openSUSE’s attention. They may then pitch in and provide you solutions that will work (as opposed to my speculations which are not helping). There is guidance here on writing a bug report on openSUSE-12.3 : https://en.opensuse.org/openSUSE:Submitting_bug_reports … you can use your openSUSE forum username and password when logging on to bugzilla. Check on the bug report every few days and pay attention to the ‘NEED INFO’ flag and be certain to CLEAR that flag if/when you provide any needed info.

Best wishes.

On 2013-05-26 13:06, ambrostan wrote:
> I am pretty sure it will all fall into place sooner or later.

You might try the factory version. If it does not work, report it to the
factory mail list and perhaps bugzilla. If you say that you tried
several distributions and all failed, there is something in that machine
that Linux does not like, and perhaps the developers can work around, if
told with time.

Cheers / Saludos,

Carlos E. R.
(from 12.1 x86_64 “Asparagus” at Telcontar)

I have news.

I actually back flashed the bios (the previous version) and saw some change.

Now Su4se actually installs as it should.

The anticipation was killing me but alas all was not well.

When I got to the reboot message at the end of the install, nothing. I used the boot menu from the installation media and got this error message:

/EFI/BOOT/boot64.efi not found; and

/boot/x86_64/loader/linux not found

I have done some more research but must of it is too complicated for me.

Any suggestions before I try again?